LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-01-2009, 05:21 AM   #1
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Rep: Reputation: 32
MSI R4350 driver problem on Ubuntu 8.10 and 9.04 (Alpha 5)


I tried to install the driver for my MSI R4350 graphics card. So I downloaded the linux driver from their website (http://support.amd.com/us/gpudownload/Pages/index.aspx) . I downloaded the ati_.bla_bla_bla.run file.

Then I changed the permissions for that file to 777 So I could run it and started the file.

All went surprisingly well until the moment I rebooted. Then I get a message that I'm running in a very low graphical mode.

What can I check/do about this?

I'm using Ubuntu 8.10 and 9.04 Alpha 5 but no difference between them.


Thx

Wannes

Last edited by bucovaina78; 03-01-2009 at 05:46 AM.
 
Old 03-01-2009, 06:58 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,701

Rep: Reputation: Disabled
Quote:
Originally Posted by wannessmet View Post
I tried to install the driver for my MSI R4350 graphics card. So I downloaded the linux driver from their website (http://support.amd.com/us/gpudownload/Pages/index.aspx) . I downloaded the ati_.bla_bla_bla.run file.

Then I changed the permissions for that file to 777 So I could run it and started the file.

All went surprisingly well until the moment I rebooted. Then I get a message that I'm running in a very low graphical mode.

What can I check/do about this?

I'm using Ubuntu 8.10 and 9.04 Alpha 5 but no difference between them.


Thx

Wannes
If you're talking about the ati-driver-installer.....run file you have to run this with sudo or as root (at least I do on my debian box). If I try running that as an ordinary user it always fails with error messages. So, have you tried running it as root? I don't think changing permissions on the run file makes any difference. I download it normally so I am the owner of the file and I can execute it as me but, as I said, it will always fail if I don't do it as root/sudo.
Cheers,
jdk
 
Old 03-01-2009, 08:01 AM   #3
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
Running as root is no problem, it's the fact that the driver is not working.

I'm running on low resolution right now and no hardware accel.

I added the line in fstab that enables POSIX (whatever that may be ) and read in the release notes that I needed these packages:

- XFree86-Mesa-libGL
- libstdc++
- libgcc
- XFree86-libs
- fontconfig
- freetype
- zlib
- gcc


Some I can find with apt-get but the first two, not found
 
Old 03-01-2009, 09:05 AM   #4
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,701

Rep: Reputation: Disabled
Is the fglrx module built and loaded? Try
Code:
lsmod | grep fglrx
and see if the module has been loaded.
If not then try
Code:
sudo modprobe -v fglrx
and then stop and restart your X server.
cheers,
jdk
 
Old 03-01-2009, 10:03 AM   #5
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
Code:
wannes@Quad:~$ lsmod | grep fglrx
fglrx                2234744  0 
wannes@Quad:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Segmentatiefout (core dumped)
That's what I get. If I run glxinfo I get a crash report?
 
Old 03-22-2009, 11:23 AM   #6
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
BUMP, problem not solved yet
 
Old 04-01-2009, 04:24 AM   #7
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
BUMP, problem not solved yet
 
Old 04-01-2009, 06:07 AM   #8
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,701

Rep: Reputation: Disabled
Quote:
Originally Posted by wannessmet View Post
Running as root is no problem, it's the fact that the driver is not working.

I'm running on low resolution right now and no hardware accel.

I added the line in fstab that enables POSIX (whatever that may be ) and read in the release notes that I needed these packages:

- XFree86-Mesa-libGL
- libstdc++
- libgcc
- XFree86-libs
- fontconfig
- freetype
- zlib
- gcc


Some I can find with apt-get but the first two, not found
If glxinfo is segfaulting then the driver is not installed properly which is to be expected because as you stated, you are missing packages necessary for building the driver.

You'll need libstdc++6 and possibly the dev package, libstdc++6-4.3-dev (your version may be different on your system). You can find the available packages on your own system by typing this on a terminal
Code:
aptitude search libstdc++
You will probably need these packages too:
Code:
libgl1-mesa-dev
libgl1-mesa-dri
libgl1-mesa-glx
Install those packages and try building the driver again. Take careful note of any error messages that come during the building process.
Cheers,
jdk
 
Old 04-07-2009, 12:14 AM   #9
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
Thanks for your reply jdkaye. I installed the packages you told me to and downloaded the 64-bit driver again. Now I get this error when I run the .run file as root:

Code:
Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.vvaCYy
Well I searched it on google saying something like architecture so I tried to download the 32-bit driver version. That doesn't work on the ATI-site, in any case it download the x86_64 file,



uname -a:
Code:
Linux Quad 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:23 UTC 2009 i686 GNU/Linux
I'm right if I'm running the 32-bit version on my box? i can't see x86_64 anywhere?



Well I'm downloading the 64-bit Ubuntu again I'l reinstall it and hope it works this time.

I'll let you know
 
Old 04-07-2009, 11:23 PM   #10
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,701

Rep: Reputation: Disabled
Yes. If you're running the 32bit kernel why would you download the 64bit driver? Installing the 64bit version is a good idea but from your uname -a results you hadn't installed it in the first place. So it seems you're installing it rather than reintalling it, right?
jdk
 
  


Reply

Tags
ati, graphics, radeon, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing ubuntu 8.10 on msi ex705x laptop miazanoapte Linux - Laptop and Netbook 5 11-07-2008 10:35 AM
Belkin Flip USB KVM switch & MSI K9A2 mobo (ochi_hcd driver problem?) daniel.santos Linux - Hardware 1 05-19-2008 06:31 PM
msi cb54g2 driver orko3001 Slackware 2 10-09-2006 11:26 AM
Nvidia driver probs on MSI G4... EliteTurk Linux - Newbie 12 06-26-2004 08:56 PM
MSI Geforce 4 4200 driver problem Notfromkansas Linux - General 1 07-13-2002 02:37 PM


All times are GMT -5. The time now is 01:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration