LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-01-2003, 04:06 AM   #1
lonely10072003
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
mplayer no sound " initialize audio "


HELLLLP , anyone Redhat 8.0

I am using mplayer 0.90
I installed the win32 codec that allows me to play all media.
The video works on vcds and divx files but I don't have sound. This is the error message I get = "Could not open/initialize audio device - > no sound" .....

I have the regular sounds when I close the windows or play a cd.
In my sound detection here are the figures. "Vendor: ESS Technology, Model: ES1978 Maestro 2E, Module: maestro"
-----------------
Here is my modules.conf file looks like
-----------------
#Sound
alias char-major-14 soundcore
alias char-major-116 snd
--------one-line--------------------------
options snd snd_major=116 snd_cards_limit=1 snd_device_gid=17 snd_device_uid=0
--------one-line-finish
alias sound-slot-0 maestro
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 maestro
--------one-line--------------
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>%1 || :
--------one-line-finish
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/ /.aumixrc -S >/dev/null 2>&1 || :

--------------THATS IT_______________________

In mplayers preference i got avaible drivers for:
mpegpes Mpeg-PES audio output
oss OSS/iocti audio output
sdl SDLib audio output
null Null audio output
pcm RAW PCM/WAV file writer audio output

I can configure oss and sdl .
*****IN OSS**********************START*****
Driver
devicein oss = device:/dev/dsp
/dev/dsp0
/dev/dsp1
/dev/dsp2
/dev/dsp3
)
& also has this figure below
Mixer/dev/mixer
/dev/mixer0
/dev/mixer1
/dev/mixer2
/dev/mixer3
)
*****IN OSS************************END*****

-------IN SDL------------------------------------START--------
Driver
alsa
arts
esd
jack
oss
nas
---------END of SDL

{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{
My Sound Server. -KDE Control Module

General

My start arts soundserver on KDE startup is checked
rund soundserver with realtime priority is checked
autosuspend if ide for 60 second is checked
display meessages using arts message is checked

&
in my sound I/O = Autodetect
Below no checks
--------------------------------------finally

I am really new to linux and I love it like heck. I got my cd rom
to play music and its great. I am using a amd k6-3 450mhz and runs excellent. Please help me out. Appreciate you guys. thanks.
Please answer with step by step instructions. I am too new to linux. thanks very much for your time and help.
 
Old 08-01-2003, 08:48 AM   #2
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
I notice you have your "start aRTS sound sever on startup box ticked". I had some problems with sound recently that went away when I unticked this box. I was then able to use OSS for sound.
 
Old 08-01-2003, 03:38 PM   #3
lonely10072003
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Not Solved ( No sound aRts ) sound server

( post #2)

I notice you have your "start aRTS sound sever on startup box ticked". I had some problems with sound recently that went away when I unticked this box. I was then able to use OSS for sound.


When you uncheck the "start aRTS sound server on startup . The Redhat Will Not have sounds like alerts or closing or opening windows. Please help me find another way where my Redhat sounds are there and the mplayer can play sounds too. thank you . I am really stuck on ice.....Helpp people. Thank you for helping guygriffiths. But this problem isn't solved. dying here!!
 
Old 08-04-2003, 02:33 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
go into preferences and choose a different audio output driver.
 
Old 08-05-2003, 01:07 PM   #5
lonely10072003
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Preference don't work

I used the preference and it does not work. I choose all of the preference and tried it. Please look at the above description of what I did. thanks very much for this help. Also I will testing mysql and other stuff soon. I will soon start a startup soon. You guys are the best. Windows server will be defeated soon with mysql and open source linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer sound error: "Could not open/initialize audio device -> no sound" GTBlackwell Linux - Software 9 06-11-2008 02:23 PM
k3b: "error decoding audio tracks" and "could not unlock cd driver" lefty.crupps Linux - Software 7 10-13-2005 11:29 AM
... How to set audio "channel" in Mplayer ... Blue Jacket Linux - Software 1 10-12-2005 05:53 AM
"Broken Record" Sound, SUSE 9.1, VT823/A/8235/8237 AC97 Audio Controller... cillm527 Linux - Hardware 1 05-06-2005 03:42 AM
driver for ADI AD1985 "82801EB AC'97 Audio" sound card ??? (Asus P4C800) christophe.dr Linux - Hardware 3 09-07-2003 02:46 PM


All times are GMT -5. The time now is 07:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration