LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-16-2003, 09:38 PM   #1
trmong
LQ Newbie
 
Registered: Nov 2003
Distribution: redhat 9.0
Posts: 5

Rep: Reputation: 0
Mouse and Keyboard won't work after install


I just recently installed Redhat 9.0 on a secondary machine. The install seemed to go flawlessly.... except when the first boot screen comes up my keyboard and mouse go dead. No Ctrl-Alt-X or Alt-X, no mouse movement, no Ctrl-Alt-Del, no Num lock or Cap Lock.

I read some other posts about Kudzu killing the mouse so I tried an interactive boot to not start Kudzu. Same problem.

I am lost at to what to try next. Any suggestions would be appreciated.

Thanks.
 
Old 11-16-2003, 09:42 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
This maybe a misconfiguration in X, what does your /var/log/XFree86.0.log say.
 
Old 11-16-2003, 09:48 PM   #3
trmong
LQ Newbie
 
Registered: Nov 2003
Distribution: redhat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Leonscape,

What is the easiest way to get to the log. With no keyboard and mouse I can't go anywhere. I also havn't figured out a way to keep X from booting using the (I)nteractive boot sequence.

I tried booting from the CDROM again using the rescue mode.... Is this the best way?

Thanks
 
Old 11-16-2003, 10:01 PM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
What are you using to boot? Grub or LILO?

You can usually force these to drop to single user mode. on grub you press 'e' and add '1' on its own to the end on the kernel line. in LILO you can use the boot promt (if you in graphical press Ctrl X to get the command promt) and type linux single

Then it should boot and ask you for you root password (some distros dump you straight to a CLI which is fine)

now you can type:
Code:
less /var/log/XFree86.0.log
and tell us what it says.

Then you can use the single user mode to fix the problem.
 
Old 11-16-2003, 10:26 PM   #5
trmong
LQ Newbie
 
Registered: Nov 2003
Distribution: redhat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for single user mode info.... That helps alot.

I tried to pull some relevant portions of the log. Let me know if you need more.

Module Loader present
OS Kernel: Linux version 2.4.20-8 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 16:42:56 EST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Nov 16 21:38:55 2003
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "DevInputMice"
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(++) using VT number 7

(II) Open APM successful


..... Later in the file


(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(II) Keyboard "Keyboard0" handled by legacy driver
(**) Option "Protocol" "IMPS/2"
(**) DevInputMice: Protocol: "IMPS/2"
(**) Option "AlwaysCore"
(**) DevInputMice: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "no"
(**) Option "ZAxisMapping" "4 5"
(**) DevInputMice: ZAxisMapping: buttons 4 and 5
(**) DevInputMice: Buttons: 5
(II) XINPUT: Adding extended input device "DevInputMice" (type: MOUSE)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)


Thanks.
 
Old 11-16-2003, 10:36 PM   #6
trmong
LQ Newbie
 
Registered: Nov 2003
Distribution: redhat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
I was just trying some more things to get it to work and I noticed that after I start the GPM service using the (I)nteractive start mode that I loose control of the keyboard. If I don't start the service the keyboard works fine (up till the point that X starts. Then the lights go out on the keyboard and it is effectively dead).
 
Old 11-16-2003, 10:44 PM   #7
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
According to this you've got two mice. one at /dev/psaux and one at /dev/input/mice, /dev/psaux is your core pointer. Apart from the /dev their Identical.

From single user mode alter the start line in /etc/initab from runlevel 5 to 3. Your looking for the line
Code:
id:5:initdefault:
change the 5 to a 3 and it should start in text mode.

Login and try startx. If this doesn't work reboot.

If you go in and edit the /etc/X11/XF86Config file and try commenting out the line for the /dev/input/mouse by adding a # infront of the line in ServerLayout so it looks like

Code:
#InputDevice "DevInputMouse"
and then try startx. and then try doing it to the other mouse. Hopefully this may work if not we'll try something else.
 
Old 11-16-2003, 10:48 PM   #8
greensleeves_2K
LQ Newbie
 
Registered: Nov 2003
Location: New Delhi, India
Distribution: Redhat Linux 9.0
Posts: 11

Rep: Reputation: 0
Incidentally I had a similar problem recently. My redhat was working properly until I changed the setting of the mouse from Generic PS/2 to wheel mouse PS/2. Now exactly the same problem came up - the keyboard lights would go off just when X starts, and neither keyboard nor mouse would work. In interactive mode, the keyboard would stop working the moment 'crond' service starts. I tried all kinds of things with the XConfig file, including changing the setting of the mouse back to earlier level, but of no use. I even tried running the redhat cd in the rescue mode, but it did not work. Finally I ran the cd in the upgrade mode and reloaded all the applications related to multimedia and desktop - and now it has started working again !!! Though I could not figure out what had gone wrong in the first place.
 
Old 11-16-2003, 11:25 PM   #9
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
I found this list of stuff for Redhat, about Keyboard and Mouse problems. Theirs aparently more files involved in a redhat setup, this maybe what is causing all the grief, anyway theirs a solution as well verbatim from the TLUG mailing list archives

Quote:
After logging in as root run the command:less /etc/sysconfig/mouse and less /etc/sysconfig/keyboard and check the files is it contains the correct settings for your mouse and keyboard.You may also remove these files, with the command:
rm /etc/sysconfig/mouse

then run the command:
mouseconfig

The latter command will then again generate the file /etc/sysconfig/mouse, thus, refresh the configuration file. And as for the keyboard you need to run the command:
kbdconfig

to generate the /etc/sysconfig/keyboard file.

Check also the file /etc/X11/XF86Config file;
less /etc/X11/XF86Config

and check the Section "Keyboard" and Section "Pointer" and see if this contains the correct settings for your device. Try also running this command and see if this will help.
Xconfigurator --preferxf3 --server XF86_SVGA

Then run the command:
startx
I hope thats useful.

Last edited by leonscape; 11-16-2003 at 11:27 PM.
 
Old 11-16-2003, 11:38 PM   #10
trmong
LQ Newbie
 
Registered: Nov 2003
Distribution: redhat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Here are the results:

First when I changed the run level from 5 to 3.... I could not log into the command prompt. The keyboard was dead to all keystrokes. I then started the system (I)nteractively and did not start the GPM service. I was then able to log into the CLI. I tried the startx command.... it started but the same issue happened. The mouse and keyboard were dead.


Next I changed the XF86Config file to comment out the following line:

InputDevice "Mouse0" "CorePointer"

X failed to start with the mesage "(EE) No Core Pointer device specified"


Next I undid the previous change and commented out the following line:

InputDevice "DevInputMice" "AlwaysCore"

X started this time with no messages but the keyboard and mouse were still dead. I found the following lines in the XF86Config file that explains this operation since it seems to be optional:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

I also thought Greensleeves_2k post interesting since I have a ps2 wheel mouse installed. I don't know if this mouse type is causing the issue with both GPM and X. Any thoughts?

BTW... how can I stop the GPM service from starting up temporarily till I can figure this out? It is a real pain to interactively start everything.

I scanned through the RC.d directory but it looks like it can be started at many run levels. How can I kill it generically?

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse/Keyboard don't work. tmack8968 Debian 15 07-19-2005 06:22 PM
Keyboard/mouse doesn't work after Enterprise 4 install uther@lit.net Red Hat 2 06-21-2005 01:52 PM
the keyboard and mouse can't work!! ayiiq180 Linux - Hardware 2 09-12-2004 09:08 AM
Problems with X. Keyboard/mouse won't work. FLOODS Slackware 1 05-13-2004 09:21 AM
My mouse and keyboard dont work under X fatal Linux - General 4 06-08-2001 10:45 AM


All times are GMT -5. The time now is 04:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration