LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-05-2005, 04:35 AM   #1
M2H
LQ Newbie
 
Registered: Feb 2005
Location: Holland
Distribution: Red Hat 9.0
Posts: 3

Rep: Reputation: 0
Question Mouse & Keyboard problem after installation.


Hello,
I hope i really find an answer here since no1 on IRC knows the answer.

I installed red hat 9.0, the textbased install went perfect.

But when i reboot after the install and it asks me to configure the last few things , im stuck since my mouse and keyboard both don't work.

The keyboard is connected on a port with a sticker COM1 on it... and the mouse is an AT adaptor type(? at least thats what they told me on irc when i got some pictures etc, its an odd mouse, the connector is pretty huge)

I dunno what more info you should need to reply, ask it and ill reply quick cuz ill be checking this post the whole day.


Thanks in forward !

Last edited by M2H; 02-05-2005 at 06:36 AM.
 
Old 02-05-2005, 05:20 AM   #2
amosf
Senior Member
 
Registered: Jun 2004
Location: Australia
Distribution: Mandriva/Slack - KDE
Posts: 1,672

Rep: Reputation: 46
Com port keyboard? Never heard of that one. Older keyboards do have a larger DIN plug and older mousies have a 9 pin com port plug...

The keyboard has worked on any PC I have ever installed on, and that has been a few, from the 386 up to a P4 or a AMD64 - and just about everything in between.

You can have a mouse issue on older com port mouses, tho not usually. You'll need to set the mouse to a /dev/cua0 or ttyS0 or whatever... Been a while since I had to deal with non-ps/2 mousies...

Must be a weird machine. Don't suppose you can tell us what it is, perhaps, hmm...
 
Old 02-05-2005, 06:31 AM   #3
M2H
LQ Newbie
 
Registered: Feb 2005
Location: Holland
Distribution: Red Hat 9.0
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for your reply.

I used my webcam to make some pics..borrowed out my digi cam, so sorry for the abd reso.

Both the keyboard, mouse and the connectors:
http://www.m2h.nl/linux/1.jpg KEYBOARD+MOUSE
http://www.m2h.nl/linux/2.jpg SYSTEM (mouse on left, keyboard on right)
http://www.m2h.nl/linux/3.jpg KEYBOARD connector
http://www.m2h.nl/linux/4.jpg MOUSE connector
http://www.m2h.nl/linux/5.jpg MOUSE connector

bah too bad its so smal..but maybe you know what keyboard and mouse this are at once...

Last edited by M2H; 02-05-2005 at 06:34 AM.
 
Old 02-05-2005, 07:00 AM   #4
amosf
Senior Member
 
Registered: Jun 2004
Location: Australia
Distribution: Mandriva/Slack - KDE
Posts: 1,672

Rep: Reputation: 46
Yep. Looks like a standard XT style keyboard and a serial mouse. This is normal for the original pentium class PC's and I have a couple of those here.

The keyboard should work fine. Are you booting straight into the gui? ( I assume so). When you get the lilo/grub screen do you have keyboard control? Can you hit escape and type linux 3 to boot into text mode linux (works with lilo anyway)

The mouse might not get detected as it's a serial mouse and they sometimes have to be set up manually, but the keyboard should be going - but hard to get it to do much if you are booting into gui mode unless you are used to the OS.

If you can get it to boot into the text mode and the keyboard works, then maybe you can edit the XConfig and set up the mouse.

Or perhaps reinstall and make see if you can set the mouse to serial during the install, tho you will need to know which serial port the mouse is on. THe PC's usually have two of them, tho the mouse is usually on the first one, which is sometimes called 0 (zero)... Confusing, and I don't work with the mouse on these older boxes much any more - sorry
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse & keyboard problem 666 Ubuntu 4 03-17-2007 04:21 AM
keyboard & mouse problem with x-server Andrejchy Linux - Hardware 2 07-11-2005 11:12 AM
keyboard & mouse problem with x-server Andrejchy Debian 1 07-10-2005 05:37 AM
SUSE 9.2 Installation Issue - NO Mouse & Keyboard scoats Linux - Newbie 2 12-26-2004 12:28 PM
Wine, Keyboard & Mouse problem ! Baran Linux - Software 1 10-23-2003 10:25 AM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration