LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-12-2005, 09:17 PM   #1
matthewa
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 123

Rep: Reputation: 15
mounting removable media


I am currently running slackware 10.1. I have three removable drives in my system, a cdrom-writer, a dvdrom, and a dvdwriter. At this point I cannot get the system to mount any of my drives. In fact, everytime I try to mount any drive it tries to read my dvdwriter. Im thinking that the problem can be worked out in fstab, but im not sure how to set up multiple drives in fstab.

PLEASE HELP!!!

My fstab is as follows:
# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system> <mount point> <type> <options> <dump> <pass>
#
# dump(8) uses the <dump> field to determine which file systems need
# to be dumped. fsck(8) uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# This is a root linux partition:
/dev/hda3 / reiserfs noatime 0 1
/dev/hda4 /home reiserfs noatime 0 2

# This is a linux ext2 partition:
#/dev/hda2 /mnt/linux ext2 defaults 0 2

# For dos partition use type 'msdos'.
# For win95/98 fat16 or FAT32 partition use type 'vfat'.
#/dev/hda1 /mnt/win vfat umask=0,quiet,shortname=mixed 0 0

# Floppy disks
# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/fd0 /mnt/floppy auto defaults,noauto,user 0 0
#/dev/fd1 /mnt/floppy auto defaults,noauto,user 0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd /mnt/ls120 auto defaults,noauto,user 0 0

# CDROM, CDWRITER, DVD
/dev/hdd /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/hdd /mnt/cdwriter iso9660 noauto,user,rw 0 0
/dev/hdd /mnt/dvd auto noauto,user,ro 0 0

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de /mnt/nfs nfs defaults 0 0

# proc file system:
proc /proc proc defaults 0 0

# Unix98 devpts filesystem:
none /dev/pts devpts gid=5,mode=666 0 0

# Shared memory filesystem:
#none /var/shm shm defaults 0 0

# Basic USB filesystem
usbdevfs /proc/bus/usb usbdevfs defaults,noauto 0 0

# this is for USB pendrive, but you may need to adjust the device
#/dev/sda1 /mnt/pendrive vfat umask=0,noauto,user,quiet,shortname=mixed 0 0

# The 'sw' option indicates that the swap partition is to be activated
# with 'swapon -a'.
/dev/hda2 none swap sw 0 0

Last edited by matthewa; 11-12-2005 at 09:19 PM.
 
Old 11-12-2005, 09:35 PM   #2
nonzero
Member
 
Registered: Feb 2005
Distribution: Debian FC4 LFS Slackware
Posts: 174

Rep: Reputation: 31
Quote:
# CDROM, CDWRITER, DVD
/dev/hdd /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/hdd /mnt/cdwriter iso9660 noauto,user,rw 0 0
/dev/hdd /mnt/dvd auto noauto,user,ro 0 0
These entries all point to the same drive. You need to figure out the order then edit /etc/fstab and change it to something on the order of;

/dev/hdd /mnt/cdrom ...
/dev/hde /mnt/cdwriter ...
/dev/hdf /mnt/dvd ...

nz
 
Old 11-12-2005, 09:44 PM   #3
matthewa
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 123

Original Poster
Rep: Reputation: 15
thanks for the help, nonzero, but I figured it out. Just in case someone else has the problem:

I had to set up my drives classification according to their positions on my ide bus. In other words, my cdrom is a slave to my hard drive, my dvdrom is the second master drive and my dvdwriter is my second slave to my dvdrom. Sooooooo, fstab had to read:

1) harddrive partition (hda)
2) cdrom (hdb)
3) dvdrom (hdc)
4) dvdwriter (hdd)



Problem solved!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount a removable media using C skie_knite007 Programming 1 10-02-2005 12:49 AM
Encrypted Filesystems on Removable Media Soltis Linux - Security 8 03-21-2005 01:35 PM
Mounting removable media george_mercury Linux - General 1 07-28-2004 11:14 AM
Removable media problems under FreeBSD TJandE *BSD 1 07-14-2004 06:05 PM
Problem with accessing removable media kcreagh Linux - Newbie 1 08-04-2003 09:54 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration