LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-14-2004, 01:34 PM   #1
plasticus
LQ Newbie
 
Registered: Feb 2004
Location: Iowa
Distribution: Mandrake
Posts: 8

Rep: Reputation: 0
mounting local hard drive, permissions


when I mount hdc1 to /mnt/windows/, the file permissions get a bit screwy. root gets r+x, but no other users are allowed access to the files. chmodding the dir doesn't do anything. it's 777 when not mounted, but as soon as I mount the hard drive, the permissions change to root r+x. What might I be doing wrong?

I've messed with the fstab, as per other posts on this board... but the permissions never seem to change. I can get it to automount, but root is still the only user with access.
 
Old 02-14-2004, 02:00 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well show us your entry you have for it in your fstab file ..
 
Old 02-14-2004, 04:25 PM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Include umask=000 in you mount options.
 
Old 02-15-2004, 03:17 AM   #4
plasticus
LQ Newbie
 
Registered: Feb 2004
Location: Iowa
Distribution: Mandrake
Posts: 8

Original Poster
Rep: Reputation: 0
/dev/hda1 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
/dev/hdc1 /mnt/win ntfs umask=000 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

that is currently what is in there... the drive I'm concerned about is hdc1. I just put the umask=000 in there... really have no idea what should be in that spot.
 
Old 02-15-2004, 01:35 PM   #5
plasticus
LQ Newbie
 
Registered: Feb 2004
Location: Iowa
Distribution: Mandrake
Posts: 8

Original Poster
Rep: Reputation: 0
Actually, after rebooting, that umask=000 seems to have worked. Thanks, Electro.
 
Old 02-15-2004, 03:14 PM   #6
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Instead of rebooting. You could just type mount -a or mount -av. It will remount all devices if it needs to.

Instead of putting umask use ro because if you write to ntfs linux may currupt your partition. Use FAT32 if you switch back and forth from windows to linux.

I'm sorry I assume that the windows partition was FAT32.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting local hard drive in a remote shell (SSH) noir911 Linux - General 1 06-24-2005 05:55 AM
Hard Drive Permissions djljjm Linux - Newbie 1 04-18-2005 11:29 AM
Hard drive permissions R¬dical_úD Suse/Novell 3 01-10-2005 07:20 AM
Having problems mounting a drive (with appropriate permissions...) Robhogg Linux - Hardware 3 11-01-2004 02:14 PM
mounting hard drives and permissions revdave Linux - Newbie 1 12-11-2002 10:14 AM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration