LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-27-2004, 04:30 AM   #1
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Rep: Reputation: 15
mounting hard drive


Hey, first off let me just start with saying thank you all for all the help you've given me thus far.

Now im back with another small problem. I wanted to be able to listen to my mp3 files on windows and linux. So i decided to move all my files on to a fat 32 partition thats about 4 gigs in size. Those files use to be on a NTFS file system, but for some reason i cant get Fadora Core 3 to mount that hard drive. And i was told that it should be able to mount a fat 32, so thats why i went ahead and did that.

Now im cant figure out how to do it. When i type mount into my terminal i get this


[root@ool-18be212d ~]# mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hdb1 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
[root@ool-18be212d ~]#

I really dont know wha much of this means but im hoping that it can help you help me.

And just for the record, i have two hard drives in my system. The first hard drive is windows and it has a totoal of 3 parititons on it, one of those partitions being the fat 32 with the music files on it. And on the Second hard drive i have linux.

Please help if you have any suggestions. Thanks in advance.
 
Old 11-27-2004, 05:20 AM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Since you have multiple partitions on the 1st hard drive which is hda, you would have to use the following command

1. Know where you want to mount the music and make the directory
- mkdir /mnt/music

2. Mount the fat32 partition. I'm assuming its on the 2nd partition of the 1st drive.
- mount -t vfat /dev/hda2 /mnt/music

That should do it, but if you get an error post it

good luck
 
Old 11-27-2004, 05:40 AM   #3
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Original Poster
Rep: Reputation: 15
[root@ool-18be212d thugpoet22]# mount -t vfat /dev/hda2 /mnt/music
mount: mount point /mnt/music does not exist
[root@ool-18be212d thugpoet22]# mount -t vfat /dev/hda5/mnt/music
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
[root@ool-18be212d thugpoet22]#

thats what i got, i know the location is

/dev/hda5

but you put music at the end, why? I did not name the partition Music?
 
Old 11-27-2004, 05:45 AM   #4
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Original Poster
Rep: Reputation: 15
Disk /dev/hda: 20.0 GB, 20020396032 bytes
240 heads, 63 sectors/track, 2586 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1903 14386648+ 7 HPFS/NTFS
/dev/hda2 1904 2586 5163480 f W95 Ext'd (LBA)
/dev/hda5 1904 2448 4120168+ b W95 FAT32
/dev/hda6 2449 2586 1043248+ 7 HPFS/NTFS

Disk /dev/hdb: 10.2 GB, 10262568960 bytes
255 heads, 63 sectors/track, 1247 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1247 9912105 8e Linux LVM

this is all of my information i want to mount the "/dev/hda5"

Thanks in advance
 
Old 11-27-2004, 06:41 AM   #5
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Quote:
Originally posted by thug_poet22
[root@ool-18be212d thugpoet22]# mount -t vfat /dev/hda2 /mnt/music
mount: mount point /mnt/music does not exist

The folder you are mounting to must exist, you haven't created it or don't have permission(not likely), you are mounting the partition /dev/hda5 to a mount point of /mnt/music

As root

mkdir /mnt/music
mount -t vfat /dev/hda5 /mnt/music

CONCEPTUAL mounting
What device do I want to mount? /dev/hda5
Where do I want those file to be? /mnt/music or /root/my_music
how the command is parsed?

Mount
what filesystem? -t vfat
what linux device(parition)? /dev/hda5
The files should be located at? /mnt/music or /root/my_music

Total command once the directory exists
mount -t vfat /dev/hda5 /mnt/music
OR
mount -t vfat /dev/hda5 /root/my_music

If I'm not making sense, let me know

Last edited by musicman_ace; 11-27-2004 at 06:48 AM.
 
Old 11-28-2004, 12:33 AM   #6
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Original Poster
Rep: Reputation: 15
this is what i got when i tried that,


[thugpoet22@ool-18be212d ~]$ su
Password:
[root@ool-18be212d thugpoet22]# mkdir /mnt/music
mkdir: cannot create directory `/mnt/music': File exists
[root@ool-18be212d thugpoet22]# mount -t vfat /dev/hda5 /mnt/music
mount: /dev/hda5 already mounted or /mnt/music busy
mount: according to mtab, /dev/hda5 is already mounted on /mnt/music
[root@ool-18be212d thugpoet22]#

Its saying that /dev/hda5 is already mounted on /mnt/music, if thats the case how do i put an icon on the desktop so i can go into that partition.
 
Old 11-28-2004, 05:48 AM   #7
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
1. /mnt/music does exist
2. /dev/hda5 is mounted somewhere.
The error doesn't necessarily imply it is at /mnt/music, it said /mnt/music was busy meaning something is there.
3. To create a "link" to it assuming KDE
{right click->new->device->HD device}
Click the Device tab
type "/dev/hda5"

You didn't really say if you can actually get to these files though?
 
Old 11-28-2004, 09:04 AM   #8
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Original Poster
Rep: Reputation: 15
when i tried to mount that drive this is what i got.


mount: can't find /dev/hda5 in /etc/fstab or /etc/mtab

do i have to change where its looking for that drive, maybe i have ot edit the /etc/fstab or the /etc/mtab.

I have a friend that things going through all this trouble isn't worth using linux. But i keep telling him that you been with windows so long that you dont even remember when you were in the learning process. And when i use windows i dont feel like im learning anything. Thats why i figured i would try Linux out and im glad i did. Even when the problems seem hard to figure out, there never impossible.
 
Old 11-28-2004, 09:36 AM   #9
addy86
Member
 
Registered: Nov 2004
Location: Germany
Distribution: Debian Testing
Posts: 332

Rep: Reputation: 31
If you do this:
[root@ool-18be212d thugpoet22]# mount -t vfat /dev/hda5 /mnt/music

and you get that:
mount: /dev/hda5 already mounted or /mnt/music busy
mount: according to mtab, /dev/hda5 is already mounted on /mnt/music

then you have already mounted your partition. To have it automatically mounted every time you start Linux, add the following line to the end of /etc/fstab :
/dev/hda5 /mnt/music vfat defaults 0 0


Btw:
ls -l /mnt/partition
should give you a quick verification of the success of the mount.

Last edited by addy86; 11-28-2004 at 10:04 AM.
 
Old 11-29-2004, 11:31 PM   #10
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by addy86
If you do this:
[root@ool-18be212d thugpoet22]# mount -t vfat /dev/hda5 /mnt/music

and you get that:
mount: /dev/hda5 already mounted or /mnt/music busy
mount: according to mtab, /dev/hda5 is already mounted on /mnt/music

then you have already mounted your partition. To have it automatically mounted every time you start Linux, add the following line to the end of /etc/fstab :
/dev/hda5 /mnt/music vfat defaults 0 0


Btw:
ls -l /mnt/partition
should give you a quick verification of the success of the mount.
hey the last part of your instructions are kinda confusing.

What did u want me to do with this,

/etc/fstab :
/dev/hda5 /mnt/music vfat defaults 0 0

Thanks in advance for clearing that up.
 
Old 11-30-2004, 12:50 AM   #11
thug_poet22
LQ Newbie
 
Registered: Jan 2004
Location: New York
Posts: 22

Original Poster
Rep: Reputation: 15
And when i put in,

/dev/hda5 /mnt/music vfat defaults 0 0

I get, this

[root@ool-18be212d thugpoet22]# /dev/hda5 /mnt/music vfat defaults 0 0
bash: /dev/hda5: Permission denied

Thanks for the help.
 
Old 11-30-2004, 06:40 AM   #12
addy86
Member
 
Registered: Nov 2004
Location: Germany
Distribution: Debian Testing
Posts: 332

Rep: Reputation: 31
/dev/hda5 /mnt/music vfat defaults 0 0
is no command.
Start your favorite text editor (as root), open the file '/etc/fstab', then add the above line to the end of the file, Finally save it.
 
Old 12-08-2004, 08:23 PM   #13
unwrittenlaw
Member
 
Registered: Sep 2003
Distribution: Slackware FreeBSD Gentoo Novell
Posts: 73

Rep: Reputation: 15
ive been having the same problem.........ive edit /etc/fstab and i have read write and execute permission.....but when i go to the folder where this drive is mounted i get access denied!!!!111oneone
what do i do?
 
Old 01-04-2005, 01:49 AM   #14
myrrdan
LQ Newbie
 
Registered: Jan 2003
Location: Alberta canada
Distribution: Redhat 8.0
Posts: 5

Rep: Reputation: 0
Question i'm having a problem mounting a partitioned hard drive....

Ok.. i have a 120 maxtor hard drive, running windows, then a 10 gig running linux. dual boot.

the 120 gig is partitioned into 4 drives,
I run this command

Code:
mount -t vfat /dev/hda2 /mnt/d:
and this is the error
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)
now, I had to use Partition magic 8 to partition this hard drive, which is running windows 98 2nd edit.
So, anyone have any ideas why its not taking it???

i've tried adding this to /etc/fstab
Code:
/dev/hda2                   /mnt/d:              vfat     user,defaults
but same error...
 
Old 01-04-2005, 02:11 AM   #15
myrrdan
LQ Newbie
 
Registered: Jan 2003
Location: Alberta canada
Distribution: Redhat 8.0
Posts: 5

Rep: Reputation: 0
Ok, well i did some fiddling around, and in redhat 9..

I used the Hardware Browser under System tools...

When i looked at my hard drives, it listed this...
hda1 as my main partition, no problems, we all knew this...
now, hda2 was extended partition, that held
hda5, hda6, hda7 <---- vfat partitions...
so when i tried to mount hda2, thats the error, when i tried to mount hda5 it worked without a problem..
unfortunately, i can't get it to mount the other two, hda6, hda7...

Is there a limit to the amount of drives mounted???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help mounting a hard drive cevilgenius Linux - Newbie 15 04-12-2005 02:35 PM
Mounting a Hard Drive Bill413 Linux - Newbie 6 11-15-2004 05:19 PM
Mounting a Hard Drive Garoth Linux - Software 9 11-11-2004 08:47 PM
mounting a second hard drive evilRhino Linux - General 2 10-17-2002 01:22 AM
Mounting hard drive Runt888 Linux - Newbie 1 08-29-2001 02:02 AM


All times are GMT -5. The time now is 09:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration