LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   mount: unknown filesystem type 'ntfs' when trying to mount windows drive... (http://www.linuxquestions.org/questions/linux-hardware-18/mount-unknown-filesystem-type-ntfs-when-trying-to-mount-windows-drive-272350/)

DiZASTiX 12-31-2004 01:11 PM

mount: unknown filesystem type 'ntfs' when trying to mount windows drive...
 
I get this error when I try to mount my Windows XP drive:

Code:

# mount /dev/hda1 /mnt/win
mount: unknown filesystem type 'ntfs'

Here is my /etc/fstab:

Code:

# /etc/fstab: static file system information.
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.14 2003/10/13 20:03:38 azarah Exp $
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail and tail freely.

# <fs>                  <mountpoint>    <type>          <opts>                  <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hdb2              /boot          ext2            deafaults,noatime              1 2
/dev/hdb3              /              reiserfs                noatime                0 1
/dev/hdb5              none            swap            sw                      0 0
/dev/cdroms/cdrom0      /mnt/cdrom      auto            noauto,user            0 0
/dev/hda1              /mnt/win        auto            ro,user                1 0
#/dev/fd0              /mnt/floppy    auto            noauto                  0 0

# NOTE: The next line is critical for boot!
none                    /proc          proc            defaults                0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none                    /dev/shm        tmpfs          nodev,nosuid,noexec            0 0

I am running gentoo linux.

masand 12-31-2004 02:03 PM

for ntfs u need to have that support
either compile ur kernel for that support
or visit
linux-ntfs.sourceforge.net

regards

DiZASTiX 12-31-2004 02:09 PM

Quote:

Originally posted by masand
for ntfs u need to have that support
either compile ur kernel for that support
or visit
linux-ntfs.sourceforge.net

regards

ok, I figured out it wasn't in my kernel. Can I just add it as built in and do a make modules && make modules_install or do I have to recompile the whole kernel?

masand 12-31-2004 02:54 PM

Quote:

Originally posted by DiZASTiX
ok, I figured out it wasn't in my kernel. Can I just add it as built in and do a make modules && make modules_install or do I have to recompile the whole kernel?
i have mentioned it quite clearly in my post
either comple ur kernel or
visit that site
linux-ntfs.sourceforge.net

regards

DiZASTiX 12-31-2004 03:36 PM

Ok, following this page I rebuilt the kernel with ntfs support. I then looked in /proc/filesystems but ntfs was not listed (I included it in the kernel, not as a module). I still get the same error when trying to mount (mount: unknown filesystem type 'ntfs')...did I do something wrong?

masand 12-31-2004 03:49 PM

did u rebult ur kernel or got urself a prebuilt .obj file from the site??
and i f u built ur kernel are u sure u built it correctly

regards

DiZASTiX 12-31-2004 03:55 PM

Quote:

Originally posted by masand
did u rebult ur kernel or got urself a prebuilt .obj file from the site??
and i f u built ur kernel are u sure u built it correctly

regards

I rebuilt it myself. I am using kernel 2.6.9:

- cd /usr/src/linux
- make menuconfig (include ntfs support)
- make && make modules_install
- cp bzImage to /boot
- reboot

EDIT: I added it as a module instead of built in, did make modules && modules_install, loaded the module and it works! Thanks.

uqkobi 11-07-2006 02:49 AM

or just use livna on FC
 
Just incase a fellow Fedora user reads this....

If you're using Fedora just use the yum livna repository rpm.livna.org

yum install kmod-ntfs

brwyatt 12-18-2006 03:31 AM

New to linux (mostly)... gotta love yum!

I'm assuming I'll need to reboot?

Also, did it download the kernel source? ("Dependency Installed: kernel.x86_64 0:2.6.18-1.2849.fc6" looks like it did)

Thanx :D

nadsab 03-17-2008 09:34 AM

Can't mount a cdrw in Centos 5.1
 
Moved to new thread.

jschiwal 03-17-2008 09:44 AM

The /etc/fstab file isn't a bash script. It is a table of devices, mount points, filesystems and options.
Look at "man fstab".

Does the "disc" already have data on it? It needs a filesystem before it can be mounted.

If the cdrom drive is /dev/sr0 and you have a mount point /mnt/cdrom available, this command will mount the disc's filesystem:
sudo mount -t iso9660 /dev/sr0 /mnt/cdrom -o ro,unhide

The most recent distros use hal & udev that automatically create a device node and a mount point after you insert a disc. Then you get a popup on what you want to do.

If it is a blank disc, then you need to burn it using a program, such as K3b.

If it is an audio disc, you can't mount it because it doesn't have a filesystem.

nadsab 03-17-2008 10:00 AM

Hi jschiwal thanks (and Sorry) I posted in the wrong place, I moved my question to here: http://www.linuxquestions.org/questi...os-5.1-628666/
and am answering your question there right now...

sudeshna 09-28-2008 08:29 PM

hii...

I'm using 2.6.18-1.2798.fc6

I used the following code:

[root@localhost ~]# mount -t ntfs /dev/hda1 /mnt/ntfs

it showed:
mount: unknown filesystem type 'ntfs'

as I have found out from forums that I need to install some kernel driver.

please anyone help me to find out the right kernel driver.I'm not geting it anywhere.
Please post the link from where to download.


All times are GMT -5. The time now is 08:32 AM.