LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   mount / umount problems (http://www.linuxquestions.org/questions/linux-hardware-18/mount-umount-problems-301474/)

d1l2w3 03-14-2005 11:00 AM

mount / umount problems
 
sys is 1.7ghz, 512m ram
/dev/hda 160g, /dev/hdb 120g
/dev/hdc is a dual cd/dvd-rw, /dev/hdd is a cd-rw
MDK 10.1, KDE 3.2

/etc/fstab:
/dev/hdb5 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users,unhide 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdb1 swap swap defaults 0 0

[root@localhost don]# umount /mnt/cdrom
umount: /mnt/cdrom: device is busy
umount: /mnt/cdrom: device is busy
[root@localhost don]#
There is no cd or dvd in /dev/hdc.
No program that uses /dev/hdc is open.

When inserting a cd or dvd, 'mount /mnt/cdrom' gives this error.
[root@localhost don]# mount /mnt/cdrom
mount: /dev/hdc already mounted or /mnt/cdrom busy
mount: according to mtab, /dev/hdc is already mounted on /mnt/cdrom

After opening /dev/hdc the first time with a file manager or k3b, I have to reboot to use it again.
When it is mounted, I can open and close the cd/dvd at will.
Any ideas on how to solve this?
Also, is there a way that /dev/hdc is always mounted?
I am the only user on this box so it doesn't matter if it's always mounted.

dlw

Valhalla 03-14-2005 11:41 AM

Backup your current fstab and then try setting your /dev/hdc filetype to iso9660, and removing all of your options with the exception of user.

d1l2w3 03-14-2005 12:15 PM

Same as before.
No difference.

In order to use /dev/hdc again the sys has to be rebooted.

dlw

Tovad 03-14-2005 12:38 PM

I have the same problem - a solution for me is to use the lazy umount
The fam (file alteration monitor) daemon (famd) sometimes refuse to relaese the cdrom/floppy and can then not unmount - use the umount -l option

Valhalla 03-14-2005 03:16 PM

If it doesn't matter if its always mounted, I suppose you could look into submount, and do it that way. I don't know whats going on though.

d1l2w3 03-14-2005 03:22 PM

The -l option works.
Shutting down and booting up again is over... hopefully.
I'll keep working on it.

Thanks,
dlw

RemusX2 03-14-2005 04:23 PM

Another thing you could try is

Code:

/sbin/fuser/ -m /mnt/mount point
This will display the PID that is keeping the device from umounting. Then when you get the PID you can kill it with

Code:

kill PID
And of course changing mount point with where it's mounted and PID with the corresponding PID to the device.

Hope this helps too =]


All times are GMT -5. The time now is 08:10 AM.