LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Motherboard P5QL-E and disk ST3500641AS-RK not seen in Enhanced Mode (http://www.linuxquestions.org/questions/linux-hardware-18/motherboard-p5ql-e-and-disk-st3500641as-rk-not-seen-in-enhanced-mode-699334/)

linuxscout 01-23-2009 06:27 AM

Motherboard P5QL-E and disk ST3500641AS-RK not seen in Enhanced Mode
 
Hi everybody.

I have a brand new, home assembled machine with all new components.
The config is as follows:

Mobo : P5QL-E from ASUS
Disks: 3 x ST3500641AS-RK from Seagate
Mem: 8 Gb
Processor : Q9550 Quad core from Intel
Graphic card: 8300 GS , NVidia
Diskette drv, DVD, etc,etc.

It seems to be working fine, but as I tried to install Linux (I must use Linux Redhat AS 4, or Linux 5 EL, due to my software apps require one of them, otherwise I would have no support), it only sees the disks in BIOS Compatible mode.
The BIOS give me only three choices, Disable, Enhanced and Compatible.

Linux Redhat 5 doesn't see the disks at all.

Ok, I installed Linux 4 in compatible mode, but it happens that all disk I/O operations seem to be really slow. The disks are seen as /dev/hdx (a,b,c...and so on), not /dev/sdx as I have in some other machines.

I measured the disk behavior with the Linux command hparm -Tt /dev/hda, for instance, and I get a very, very low data transfer:

[root@localhost ~]# hdparm -Tt /dev/hdb

/dev/hdb:
Timing cached reads: 8040 MB in 2.00 seconds = 4020.61 MB/sec
Timing buffered disk reads: 12 MB in 3.07 seconds = 3.90 MB/sec


I have other machine, which has a P5KSE mobo, from ASUS too and WDC disks WDC5000AAKS and which by the way recognizes the disks in either mode (Enhanced or Compatible), and the hdparm reports a ten times faster transfer speed. The same happens in other computer with similar configuration.

Returning to the problem machine,I found no way to make it see the Seagate disks as sdx, neither achieve a decent transfer speed. The most I've got, was after tweaking a little with hparm like this:

hdparm -d1 /dev/hda

hdparm -c3 /dev/hda

hdparm -m16 /dev/hda

hdparm -a16 /dev/hda

The first command doesn't like to the system and is refused. That makes me think that the DMA mode is not working??. Could that be the problem? The others commands run without complaining and after that, the value in the second line of the hparm output showed :

Timing buffered disk reads: 24 MB in 3.11 seconds = 7.71 MB/sec

which is double the speed that before. That is the most I could achieve.

I asked Seagate but they didn't answer and they have no drivers for this model of disk. Also in the ASUS website I was unable to find out any tip.

At last, I found some forum entry, I don't remember where, telling that AHCI mode should be used, however when I turn AHCI mode in BIOS on, it doesn't see any disks at all.

Did anyone has a similar problem? Any tips?

Thanks!

stress_junkie 01-23-2009 06:50 AM

Looking at the specs of the motherboard I don't immediately see anything that could cause problems for Linux. I am using a new Asus P5GC motherboard on my newest computer without problems. Here is a link to the description of your motherboard on the Asus USA web site.

http://usa.asus.com/products.aspx?l1...72&modelmenu=1

Naturally the first thing to do is to check the specifications of your disk drives and RAM and any other devices attached to the motherboard to be sure that they are compatible with the motherboard. Then check the cables and connectors. Hopefully you did all of that sort of thing before you wrote your question here.

The picture on the Asus web site of the back panel does not show a VGA connector. That is unfortunate. It would be good if you could use an on board video to eliminate the possibility of your problems being caused by an add-in video card. I hope that you are not using one of the new Nvidia cards. They can be problematic due to improper fill material being used in their manufacture.

I hope that you haven't tried to overclock the CPU or RAM. That wouldn't make sense to do before the operating system is installed.

Hopefully your power supply is at least 500 watts.

The first thing that comes to mind when reading your post is what are all of these modes that you speak of? I've purchased a lot of motherboards and I've built a lot of computers from scratch and I have no idea what you could be talking about with the various modes.

I would download one or more Linux distributions that are available as a bootable live CD/DVD. Then I would boot the live CD Linux to see if any distribution can see your disk drives. If you find one that will work with the disk drives then open a terminal window and enter
Code:

lsmod
That will list the kernel modules that are loaded. Write this list down. Then get Red Hat to use the same modules.

The Asus support site has motherboard BIOS updates. You may want to upgrade the motherboard BIOS. It also has drivers for Linux. You should download them and try to use them.

http://support.asus.com/download/dow...s&model=P5QL-E

So, please explain the modes that you are talking about, try what I recommended, and post the results back here.

Good luck. You shouldn't be having any trouble with the motherboard that you selected. I'm sure that we can get your machine running. :)

linuxscout 01-23-2009 08:31 AM

Hi stress_junkie, thanks for your quick post. I'll answer below, hope my answers are well read since this is my first post in this forum.


>> Yes, I checked cables, connectors, etc. first. I have also pretty long experience with hardware and soft, however there's always something that can beat us, since there are lot of hardware combinations...Anyway, I'll try to answer your questions:

Quote:

Originally Posted by stress_junkie (Post 3418494)
Looking at the specs of the motherboard I don't immediately see anything that could cause problems for Linux. I am using a new Asus P5GC motherboard on my newest computer without problems. Here is a link to the description of your motherboard on the Asus USA web site.

http://usa.asus.com/products.aspx?l1...72&modelmenu=1
>> Yes, I've seen it. Thanks.

Naturally the first thing to do is to check the specifications of your disk drives and RAM and any other devices attached to the motherboard to be sure that they are compatible with the motherboard. Then check the cables and connectors. Hopefully you did all of that sort of thing before you wrote your question here.
>> done!

The picture on the Asus web site of the back panel does not show a VGA connector. That is unfortunate. It would be good if you could use an on board video to eliminate the possibility of your problems being caused by an add-in video card. I hope that you are not using one of the new Nvidia cards. They can be problematic due to improper fill material being used in their manufacture.
>> well, I've installed a NVidia Gforce 8400 GS, is that what you meant?. Actually I don't care very much about the graphic card, since I will be mostly using the system thru the network, as part of a cluster.
Do you think this could have somethingg to do with the problem?

I hope that you haven't tried to overclock the CPU or RAM. That wouldn't make sense to do before the operating system is installed.
>> No, I didn't. I don't need that for now.

Hopefully your power supply is at least 500 watts.

>> Yes, it is.

The first thing that comes to mind when reading your post is what are all of these modes that you speak of? I've purchased a lot of motherboards and I've built a lot of computers from scratch and I have no idea what you could be talking about with the various modes.

>> I'm sorry. I was talking about the SATA modes, which are available in the BIOS screens, under SATA Configuration. Please, take a look at the mobo manual , all the screens are there.

I would download one or more Linux distributions that are available as a bootable live CD/DVD. Then I would boot the live CD Linux to see if any distribution can see your disk drives. If you find one that will work with the disk drives then open a terminal window and enter
Code:

lsmod
That will list the kernel modules that are loaded. Write this list down. Then get Red Hat to use the same modules.
>> I'm not at the place where the machine is, but I'll post it later, as soon as I get there.

The Asus support site has motherboard BIOS updates. You may want to upgrade the motherboard BIOS. It also has drivers for Linux. You should download them and try to use them.

>> Ok, I'll try that. I didn't see before.

http://support.asus.com/download/dow...s&model=P5QL-E

So, please explain the modes that you are talking about, try what I recommended, and post the results back here.
>> Of course I will.
>> Thanks for now, I'll get back here as soon as I tried everything you suggested.

Good luck. You shouldn't be having any trouble with the motherboard that you selected. I'm sure that we can get your machine running. :)

>> Thanks!

linuxscout 01-24-2009 06:49 AM

Hi again.

Well, I did a couple of things before trying BIOS update, which is for me a last resource...
Yesterday I found a report on the web, telling that the only way these disks would work was configuring the BIOS to see the disks as AHCI.

I'm not being able to find that report again, but it came from Applab. I remembered that, so before doing anything else I decided to try AHCI configuration, so I changed the BIOS under SATA Configuration to use AHCI. That gives me some additional options (that you can see in the manual pages), but without changing anything else I booted up with a Linux 4 CD , as if I would begin a new install and now , as you arrive to the Disk Druid screen to define the partitions, you see the disks as sda, sdb...etc.
This never happened before, so I suspected that this should be the right BIOS settings (as stated by that little sentence at the end of the report, that I can't find again in the internet...!).

Ok, from now on what should I do?. The first thing was to make a full backup of all the partitions with Clonezilla, in order to be able to go back at any time.

Once the backup finished, I would try an upgrade which is proposed by the Linux 4 install program.

But before doing that, I tried (just to see what happens) booting a new Red Had Linux EL 5.3 that I downloaded from the Red Hat site suscribing as a 30 days trial. Just booting it I was able to see the disks as sda, b...etc. always with the BIOS set to AHCI too.

Ok I now know that either Linux Red Hat 4 or 5.3 both see the disks as they should. I'm convinced that seeing the disks as sdx, will make the right driver (supossedly ata_piix) load and make the disks work fine.

I booted up Linux 4 CD again and started the upgrade. I'm now on that stage.

Besides, I was checking with the software application vendor and they say that Linux Red Hat 5 is also supported, so as a last chance and if this upgrade doesn't work, I could install Linux 5 and it should see the disks right, hopefully...

Sorry I skipped some of your suggestions by now. However, I'll get back to them if this doesn't work.

I'll let you know what happened as soon as I can.

stress_junkie 01-24-2009 06:56 AM

Quote:

Originally Posted by linuxscout (Post 3419574)
Sorry I skipped some of your suggestions by now. However, I'll get back to them if this doesn't work.

No need to apologize. All that matters is that the machine works. It sounds like you are on the right path. I will keep watching this thread for a few days to see if you have any new information. It sounds like the new BIOS setting for the disks worked.

linuxscout 01-25-2009 07:49 AM

Quote:

Originally Posted by stress_junkie (Post 3419578)
No need to apologize. All that matters is that the machine works. It sounds like you are on the right path. I will keep watching this thread for a few days to see if you have any new information. It sounds like the new BIOS setting for the disks worked.

Hello again.

I believe that I have good news. At first, I must say that I made a little mistake when I posted for the first time which I've just realized: it's not a P5QL-E motherboard, but a plain P5QL without the "E". I don't know if that matters, but I must clarify. I'm sorry about that.
I've got confused with some other machine at my office.

Anyway, here are the final facts:

Since the last time I was able to see the disks in AHCI mode, booting from Linux 4 and Linux 5.3, I decided to do an upgrade from Linux AS 4.

This didn't work. The upgrade looked like it didn't uptade too much and finally it said that the boot loader was not modified.
Ok, that's it. Tired of loosing too much time I did the following:

1) Booted the machine back from CD and started a fresh install.
2) It installed ok, but at the time of booting from hard disk for the first time, it seemed not to find the boot record correctly and displayed the grub prompt. All attempts to find out the boot disk and record failed.
(tried : find, root and setup grub commands, they worked but the boot record did not get fixed)

3) I tried a couple more of times and after arriving to the conclusion that, for some reason, the machine tried to boot from some other disk and not the right one, I disconnected all the disks but the one to be the installation target.

4) With disk only, I did a new install from scratch and this time everything worked fine: the disks were seen as sdx, and it booted up correctly from the hard disk!

5) Just to avoid any more problems with the boot loader, I turned the machine off, put just one of the remaining disks back and booted from CD in rescue mode.

6) Once in rescue mode, chroot /mnt/sysimage, fdisk /dev/sdb (the just added disk) and deleted the whole partition on it, and exit. Then entered back to fdisk, created the same partition back and write it on disk. Exit and booted again.

7) With the machine now up and running, I created a filesystem on the just formated partition on /dev/sdb : mkfs.ext3 /dev/sdb1, mounted it and added to the /etc/fstab.

8) I rebooted and everything was mounted and seen as it should!.

9) Then I started to install my software and configure the users. Once more, all the steps without any problem.

My conclusion is, that for some reason , when you switch to AHCI mode the order and naming of the disks seem to change when you start to install Linux. This confused me and if I'm not wrong, confused the machine too,in that it looks for the boot record in a disk that it shouldn't. Not sure about that, but it's something to have into account when you install a OS in your brand new machine.

Anyway, I believe that all the problem was that the BIOS SATA mode should be set to AHCI before you started a new install. If you do, you'll see the disks as sdx and the tranfer speed will be the right one.

Just to end this story: hdparm -Tt /dev/sda (or b, or c) now gives a transfer speed of about 315 mb in 3 sec. !, about 26 times the speed I've got with the disks seen as hdx!!.

Thanks stress_junkie for your help. Hope this works for someone else.

Best Regards.-

stress_junkie 01-25-2009 07:39 PM

Thank you for posting the answer and your results. I'm sure that your experience will help others as we all slowly transition to SATA. :-)


All times are GMT -5. The time now is 09:53 AM.