LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-21-2004, 09:23 PM   #1
adamc91115
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Rep: Reputation: 0
More problems installing ATI drivers..


System-
ATI Radeon 9000
suse 9.0

Hi, whenever I run ./make_install.sh i get -

- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.21-144-athlon/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See [removed] for information about tainted modules
/lib/modules/2.4.21-144-athlon/kernel/drivers/char/drm/fglrx.o: init_module: Operation not permitted
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-144-athlon/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.21-144-athlon/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.21-144-athlon/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.


and that messes up the whole install. anyone have a solution?

Last edited by adamc91115; 04-21-2004 at 09:25 PM.
 
Old 04-21-2004, 09:53 PM   #2
adamc91115
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
nevermind, i got it.
 
Old 05-08-2004, 11:18 PM   #3
shorty_boy
Member
 
Registered: Oct 2003
Location: Lemoore, Ca
Distribution: Debian Testing
Posts: 88

Rep: Reputation: 16
same prob

could you tell me how to force the install cause i recompiled my own kernel and it does the same thing...thanks, Antonivs
 
Old 05-09-2004, 12:52 AM   #4
adamc91115
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
installed in runtime level 3
 
Old 05-09-2004, 01:05 AM   #5
LavaDevil94
Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
well, the operation not permitted probably means it wasnt done in root...
 
Old 05-09-2004, 02:37 AM   #6
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Nope, for future reference, this error with fglrx usually means that you've already got something pertaining to DRI in the kernel. Can be anything from agpgart to the kernel or X's radeon module.

Check the output of dmesg.

--Shade
 
Old 05-09-2004, 02:39 PM   #7
pe666o
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Hello,
since i have problems with ATI's drivers
on my debian i just wonder do i need to install DRI prior to installing ATI's driver!?
also after installing the driver,
should i precompile the kernel and install it,
i did that and looks like i messed my partition since i cannot load linux anymore.


cant figure how to get my A10 running on 2.4.X kernel and debian.

tried all tutorials on the web.
i am new to linux hardware installation.

can anyone give me some advice!? i might give more details if smn is willing to help me set it up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing drivers for ATI 9600XT Young Padawan Linux - Hardware 3 11-10-2004 09:25 AM
Installing ATI Drivers creates problems jrdioko Linux - Software 4 07-08-2004 03:25 PM
Problems after installing ATI radeon drivers in Mandrake 10 Cetrocet Mandriva 8 05-21-2004 05:32 PM
problems with ati drivers (NOT installing) rymdninja Linux - Software 1 04-27-2004 07:52 AM
Problems installing ATI drivers on Red Hat 9 < HELP > Tr1baL Linux - Hardware 2 03-17-2004 04:36 PM


All times are GMT -5. The time now is 05:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration