LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-14-2005, 11:09 AM   #1
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Rep: Reputation: 15
Angry More Madness - My WIndows Physical Drives have Vanished


HI All.

Just opened the media folder and no sign of my physical windows drives in there. This followed a reboot in which they appeared there but could not open as they had apparently failed to mount on previous boot.

Can anyone explain simply how to restore them and be able to access files there as I have PDF.s there I wish to view?

Thanks

- Barabus
 
Old 05-14-2005, 11:15 AM   #2
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
More info:

I logged in as root and could find the drives but again as unmounted

With the following error message:

Code:
mount: can't find /dev/hda5 in /etc/fstab or /etc/mtab
 
Old 05-14-2005, 03:39 PM   #3
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
You may try this

as root in a terminal:

1. make a directory in /mnt "mkdir /mnt/windows"

2. then manualy mount with "mount -t vfat /dev/hda5 /mnt/windows

Or

1. in a terminal make a directory in /mnt "mkdir /mnt/windows"

2. in a text editor as root add a line in /etc/fstab

"/dev/hda5 /mnt/windows vfat defaults 0 0"
 
Old 05-14-2005, 09:11 PM   #4
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Jabfinger - thanks a lot for this info -

I entered partition info as described in fstab and did the mkdir /mnt/windows as described and can now access both windows drives directly - but only logged on as root.

When I try to do the same in user sessions I get 'cannot enter mount/windows' error message .Any idea how I might fix this?

Thanks again

- Blackbeard
 
Old 05-14-2005, 10:07 PM   #5
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
One more question - How about the other ntfs partition 'D' I've tried using /mnt/D etc but nothing doing!
 
Old 05-14-2005, 10:37 PM   #6
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Correction - now can see both partitions (Win C & D) but only when logged in as root! Can I configure to be read in user session also?

Thanks again for this Jabfinger!
 
Old 05-15-2005, 08:13 PM   #7
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
The section in the line in /etc/fstab

"/dev/hda5 /mnt/windows vfat defaults 0 0"

where it says "defaults" is where you will put your mount options. There are several options that you are able to put here seperated with commas.

try doing a "man mount" and scroll down to the -o section. here you will find a list of options that you may use.

You may try "user,noauto,rw" in this section. This means that any user may mount the filesystem and the filesystem must be mounted explicitly as opposed to mounted automaticaly and the filesystem is r/w.
 
Old 05-16-2005, 03:17 PM   #8
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Thanks again Jabfinger but still nothing doing when logging in as user. I tried configuring fstab (logged in as Root) as follows:

Code:
/dev/hda2            /mnt/windows         ntfs       user,auto,ro          0 0
/dev/hda5            /mnt/D               ntfs       user,noauto,rw          0 0

In each case I get the message "Could not enter......"

As I understand it (case a)I should be able to reboot into the user account the mount should automatically load in the user account with read-only priveleges

Any further thoughts on this? As stated before they are both accessible in root!

- Barabus
 
Old 05-16-2005, 10:06 PM   #9
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
I am not sure what type of partitions you have for hda2 and hda5. Are they both fat or are they ntfs or is one fat and the other ntfs?

Have you created a mountpoint "D" for hda5 to mount to?

It looks as if your /dev/hda2 will mount automaticly on /mnt/windows during boot and users should have read only access to it as long as the file system type is ntfs. If it is a fat partition then you will have to change your type to vfat on the line in /etc/fstab.

you will have to manualy mount /dev/hda5 with the command "mount /mnt/D" as long as it is an ntfs file system type and you have made a directory "D" in /mnt. You must explicitly mount this file because of the option "noauto" on your line in /etc/fstab. If you wish to mount this file automaticaly during boot you must change the "noauto" to "auto" .

If you are unsure of the filesystem type you are trying to mount you may try placing "auto" in place of ntfs or vfat in /etc/fstab.
 
Old 05-17-2005, 12:25 AM   #10
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jabfinger
I am not sure what type of partitions you have for hda2 and hda5. Are they both fat or are they ntfs or is one fat and the other ntfs?

Have you created a mountpoint "D" for hda5 to mount to?
Yes both are ntfs and yes I have 2 mount points: one for windows and one for D and both work fine when logged in as root but do not when logged into the user account!

That said the info I posted were two possible scenarios. For the time being I've switched both back to 'defaults' but both are ntfs filesystems so I left that part unchanged.

What I want to achieve is that both are visible and accessible in the user account as well as the root with perhaps the Windows drive being read only and the D being read write and would like for each to mount automaticall to save fiddling around every time I need to access my files - mainly pdfs and images.

Given this info and what it is I am trying to achieve, I hope you can lend further knowledge to the subject. It's just a little bit of a drag that I have to change sessions evry time I need to access these files. Hope you can help

- Blackbeard
 
Old 05-17-2005, 12:35 PM   #11
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
Barabus,

Here is part of my /etc/fstab file. I am using Gentoo

/dev/hdb1 /boot ext2 noauto,noatime 1 2
/dev/hdb3 / ext3 defaults 1 1
/dev/hdb2 none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
/dev/hda1 /windows vfat noauto,users,rw 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0
linux:/home/music /mnt/music nfs suid,dev,exec 0 0
linux:/home/movies /mnt/movies nfs suid,dev,exec 0 0

My windows partition is a vfat which is of course different from the ntfs however the mount process should be the same for both. By placing "noauto,users,rw" as options I am able to mount windows as a regular user by "mount /windows" and can read as well as write to the folder.

As far as automounting them at boot I dont Know what the problem is.

I hope this helps.
 
Old 05-17-2005, 02:52 PM   #12
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
Update

/dev/hda1 /windows vfat auto,users,uid=1000,rw 0 0

is my new line in /etc/fstab. I added uid=1000 which is my user ID. Now I have access to the windows directory automaticly after boot.

As a side note. I did a little reading in the Suse administrators guide and I think, from what I read, that it is not a good idea to write to your ntfs directory from linux. You may want to make windows a fat file system so you can write to it from linux.

If this dosent help, well
 
Old 05-17-2005, 04:11 PM   #13
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Can the uid be an alpha value............. most examples I've seen when googling seem to have numeric values. Is this actually the user account name in windows - or password or what?

I'm a little lost in this sense!

Thanks again for all the useful and helpful info
 
Old 05-17-2005, 07:27 PM   #14
jabfinger
Member
 
Registered: Jan 2004
Location: USA, Pa
Distribution: Gentoo, Fedora Core 3, Mepis, Vector
Posts: 83

Rep: Reputation: 15
To answer your question No, UIDs and GIDs are numerical values. Depending on what you are trying to achive each user should be assigned a unique UID. However you can assign more than one user the same UID but all usernames with the same UID will appear to the system to be the same user.

To go a little further if you look in your /etc/passwd file you will see your systems user info.

as an example:
iain:x:1004:100::/home/iain:/bin/bash

This equates to:
user name : password : UID : GID :: home directory : login Shell

Hope this helps.

Also see:
man useradd
man groupadd
 
Old 05-17-2005, 07:42 PM   #15
barabus
Member
 
Registered: May 2005
Distribution: SUSE LINUX PRO 9.3
Posts: 57

Original Poster
Rep: Reputation: 15
Hi again Jabfinger, I guess your last but one post did the trick - Thanks for hanging in there with me!

Funny thing is though that I got it working before your last post and yes I got it working with alpha values for uid

Example:

/dev/hda5 /mnt /windows ntfs auto,users,uid=bingo,ro 0 0

- where you would have the alpha login for the user account of 'bingo'.

Every little bit helps and your input on this has been a lot of little bits, which equate to a heck of a lot. Thanks againg for everything on this thread

- Barabus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there any way to verify the freespace on the available physical drives during setu sairndain Mandriva 2 11-13-2005 02:35 PM
Grub problem with two physical hard drives Fredstar Linux - Newbie 2 10-17-2004 02:01 PM
booting 2 physical drives Malique Linux - Hardware 5 04-06-2004 06:10 AM
single logical partion on multiple physical drives frieza Linux - Software 0 12-23-2003 04:48 PM
Multiple physical hard drives w/Red Hat 9 masterspud777 Linux - Hardware 7 07-29-2003 04:10 PM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration