LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-27-2005, 11:19 PM   #1
beebelo
Member
 
Registered: Mar 2005
Location: USA
Distribution: Ubuntu Studio 13.1, Debian Stable (Wheezy)
Posts: 68

Rep: Reputation: 15
Monitor turns brilliant white - SuSE


I am a newbie... no problems other than this intermittent one:
Sometimes when my monitor is changing modes (eg. when Linux is loading) the screen changes to a brilliant white. I'm afraid it will damage the monitor. I'm running a dual boot system with Windows2000, and this has never happened with Windows.

I have an STB Nvidia Velocity 4400 video card, which is not listed explicitly in the video setup listing in SuSE, so I accepted the default VESA driver which was suggested. The resolution is 1280x1024. As far as I know (from Windows config) this is an acceptable resolution for my card and monitor. (It's a Dell Trinitron monitor).

Any suggestions?

Thank you.
 
Old 03-27-2005, 11:25 PM   #2
JSpired
Member
 
Registered: Sep 2003
Distribution: Slackware, Suse 9.2
Posts: 565

Rep: Reputation: 30
I'm unfamiliar with your monitor..but..have you installed the Nvidia drivers? If not, fire up YaST and do just that, configure, and you should be set.
 
Old 03-27-2005, 11:31 PM   #3
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
http://download.nvidia.com/XFree86/L...-7167-pkg1.run
ftp://ftp.suse.com/pub/suse/i386/sup...nstaller-HOWTO
ftp://download.nvidia.com/XFree86/Li...167/README.txt

Get your monitor horizontal and vertical refresh rates(ex. 30-86/50-160). Get your monitor physical screen size(ex. 310X230). Install the nvidia driver like so.

As root
init 3
cd /usr/src/linux
make prepare-all
make menu-config
./NVIDIA-Linux-x86-1.0-7167-pkg1.run -q --kernel-source-path=/usr/src/linux
modprobe nvidia
sax2 -m 0=nvidia
Choose the setting you wrot edown before for your monitor. Save.
reboot

Done.
 
Old 03-27-2005, 11:34 PM   #4
JSpired
Member
 
Registered: Sep 2003
Distribution: Slackware, Suse 9.2
Posts: 565

Rep: Reputation: 30
Additionally, this driver is available to you in YaST.
 
Old 03-27-2005, 11:45 PM   #5
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
I don't think the newest driver is available. But "a" driver is avaible via yast.

JSpired, are you stalking me? You didn't even buy me flowers yet!

Last edited by Thoreau; 03-27-2005 at 11:46 PM.
 
Old 03-28-2005, 12:23 AM   #6
beebelo
Member
 
Registered: Mar 2005
Location: USA
Distribution: Ubuntu Studio 13.1, Debian Stable (Wheezy)
Posts: 68

Original Poster
Rep: Reputation: 15
Wow, I didn't expect help would come so fast - thanks, you folks are great!
I've been exploring video setup in yast and sax2 (not sure what the difference is). I was mistaken about a couple things in my post. YaST declares my card is a Riva TNT. There is no Velocity 4400 driver listed. I will try to find the driver in the places you have posted. The VESA setting was what YaST suggested for my monitor. I have now changed that to the correct one, which is Dell 1025TM.

I haven't done any manual installation in Linux yet, so this should be fun ...

Thanks for all your help!
 
Old 03-28-2005, 01:13 AM   #7
JSpired
Member
 
Registered: Sep 2003
Distribution: Slackware, Suse 9.2
Posts: 565

Rep: Reputation: 30
Quote:
Originally posted by Thoreau
I don't think the newest driver is available. But "a" driver is avaible via yast.

JSpired, are you stalking me? You didn't even buy me flowers yet!
Not stalking you.

I picked up the drivers via Yast, the reason for my suggestion. They're easily upgraded after that, if need be.
 
Old 03-31-2005, 08:05 AM   #8
beebelo
Member
 
Registered: Mar 2005
Location: USA
Distribution: Ubuntu Studio 13.1, Debian Stable (Wheezy)
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Thoreau
http://download.nvidia.com/XFree86/L...-7167-pkg1.run
ftp://ftp.suse.com/pub/suse/i386/sup...nstaller-HOWTO
ftp://download.nvidia.com/XFree86/Li...167/README.txt

Get your monitor horizontal and vertical refresh rates(ex. 30-86/50-160). Get your monitor physical screen size(ex. 310X230). Install the nvidia driver like so.

As root
init 3
cd /usr/src/linux
make prepare-all
make menu-config
./NVIDIA-Linux-x86-1.0-7167-pkg1.run -q --kernel-source-path=/usr/src/linux
modprobe nvidia
sax2 -m 0=nvidia
Choose the setting you wrot edown before for your monitor. Save.
reboot

Done.
I've been up way too late the last three nights, reading stuff and trying to get this install to work, so I come back to ask for help...

Thoreau, the instructions didn't work--probably my fault due to no knowledge of things you took for granted I understood ... (I've no problem with working in a terminal, being on old DOS person, but I don't understand Linux yet.)

-- I assumed you meant to actually put the .run file in /usr/src/linux. The path in my system is named /usr/src/linux-2.6.8-24-obj ... so that's where I put it..

-- "make prepare-all' returned "No rule to make target 'prepare-all'. Stop." I read the help on "make", but that was no help... it didn't show a 'prepare' parameter.

-- Thoroughly re-read the Nvidia Linux instructions. They recommend using YaST first, and if that doesn't work (or if one "isn't afraid" as they put it) follow their steps 1 - 3. Step one of their instructions say that you have to install 'kernal-source', 'make', and 'gcc' packages with YaST2. I couldn't find any explanation for that. In re-reading YaST's comments regarding Nvidia drivers, I noticed it says when you run YOU for Nvidia, the driver is saved--not installed--in the path /usr/share/doc/nvidia. So I went there and sure enough found the .run file version 6111. So I figured what-the-hell, I'll just try installing that one.

-- The commands in the Nvidia HowTo were:

modprobe agpgart
sh NVIDIA-Linux-x86-1.0-6111-pkg1.run -q
sax2 -m 0=nvidia


... similar to your yours, but slightly different

-- Well it seemed to be going fine until the end of the SaX2 run, when it tried to start the server. The program crashed with the message "Screens found, but none have usable configuration" and "Fatal Server error: no screens found."

-- So I shut down and re-booted. Everything loaded the first time. I ran Sax2 and found that even
3D was enabled (!). Then I noticed it had changed my monitor and resolutions again--changed it to VESA 1280x1024. I have my monitor manual -- I know what the specs are -- and I've been trying since I installed SuSE, to set up the monitor with the correct config. (It keeps changing scan and refresh rates to numbers outside the specs, and changing the display geometry also.) So I once again told SaX I have a Dell 1025TM, etc.

-- Shut down and re-boot. No KDE. The message is "Run level 5 has been skipped." I've tired to run init 5 from the Linux command line, but no luck, it won't start.

Sorry this is so long. If someone could direct me to the proper files that need editing, or whatever, I would be very grateful. Also, if you could explain what you are directing me to do, then I will learn something from this...

Thanks very much!
 
Old 03-31-2005, 06:55 PM   #9
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
beebelo -

I guess that sax2 is some kind of suse config tool? generally X reads a configuration file at startup. this is usually in /etc/X11, and called "xorg.conf"

monitor rates, modelines, etc. are listed in that file - how sax2 interfaces/modifies it, I don't know. but you can view/modify it in a terminal/console. I would recommend making a copy of it (cp xorg.conf xorg-BAK), then try editing it directly and inputting your horizontal and vertical refresh rates, etc.

it would be easier to change runlevel so X isn't started automatically - then you can start X from console using "startx" to check your modifications. typically runlevel will be set by the first line of the file /etc/inittab, with most distros using "3" as non-graphical, and "5" as graphical. again, making a backup copy may be a good idea before you modify it.

also, run a search for the Rute User's guide, and take a look at the free doc's at redhat.com - both excellent, free introductory resources.
 
Old 04-01-2005, 09:43 AM   #10
beebelo
Member
 
Registered: Mar 2005
Location: USA
Distribution: Ubuntu Studio 13.1, Debian Stable (Wheezy)
Posts: 68

Original Poster
Rep: Reputation: 15
Thank you, Genesee. Yes, SaX2 is a SuSE gui for graphics configuration. Obviously I don't know much about how it works, but I'm beginning to see that some "wires are crossed" somewhere.

Last night I booted off the SuSE cd and ran their repair module. There were some nVidia files missing. I have no idea why, since I've never uninstalled or deleted anything--only tried to update. After that I started up KDE and everything was fine: I got the nVidia spash, and all my graphic settings were correct, and SaX2 reported that 3D acceleration was enabled. Then when I rebooted later, all of that was gone. KDE loaded with no problem, but with the wrong video driver version again. Also, I have an "nvidia" folder and an "NVIDIA-GLX-1.0" folder. I didn't write down the path, so I can't say where, but my point is that both folders were empty just before I gave up last night.

So I'm sure I have some kind of conflict going on.... I will look for the xorg configuration files next. Thanks for your suggestions.

-beeb
 
Old 04-01-2005, 10:55 AM   #11
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
beeblo -

hmm... personally I don't like the auto-config-type apps, and this is a good example of why. I was going to suggest that you just try downloading the driver from nvidia.com and install it manually, but on second thought, I don't know much about suse and doing that may cause some havoc with yast, sax2, and whatever other stuff they have in there. you could do it either way, but no sense in making things more complicated than they have to be, at this point

anyway, nvidia driver problems are very common, I'm sure you'll find tons of answers on it (with enough searching) - also be sure to try the suse forum here, and the Linux forum at nvnews.net is excellent. good luck.
 
Old 04-02-2005, 01:24 AM   #12
beebelo
Member
 
Registered: Mar 2005
Location: USA
Distribution: Ubuntu Studio 13.1, Debian Stable (Wheezy)
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Genesee
hmm... personally I don't like the auto-config-type apps, and this is a good example of why. I was going to suggest that you just try downloading the driver from nvidia.com and install it manually, but on second thought, I don't know much about suse and doing that may cause some havoc with yast, sax2, and whatever other stuff they have in there.
That's ok. I'm just using the auto stuff because I don't know enough yet. If I could come back with another question/comment... Back at the top of this thread, Thoreau gave instructions for a manual install:

Get your monitor horizontal and vertical refresh rates(ex. 30-86/50-160). Get your monitor physical screen size(ex. 310X230). Install the nvidia driver like so.

As root
init 3
cd /usr/src/linux
make prepare-all
make menu-config
./NVIDIA-Linux-x86-1.0-7167-pkg1.run -q --kernel-source-path=/usr/src/linux
modprobe nvidia
sax2 -m 0=nvidia
Choose the setting you wrot edown before for your monitor. Save.
reboot


I *really do* want to learn how to do this manually, but that didn't work. Problems with the "make" command.

So 2 quick questions: *where* do I put this nVidia .run file prior to installing manually? Also, how do I (or do I need to) uninstall these drivers I have now? (I ran hwinfo this eve, and it lists two different drivers for the graphics card.)

I'm learning. I've already taken your advice to not load the x server automatically. As I mentioned earlier, I was an adept DOS guy back in the old days, so this is nothing more than a learning curve to me.

--Thanks again
 
Old 04-02-2005, 01:49 AM   #13
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
I've never tried that method - I just run the .run file itself, for example with the command:

sh NVIDIA-Linux-x86-1.0-6629-pkg1.run

you will have to exit out of X first and do it as root (type "su" and root passwd). I just run it from my home dir, I don't think it matters which dir you run it from. the .run file launches the installer, which will check that you have all dependencies installed, build/install the kernel module, and remove the existing module by default.

nvidia has a very good readme on everything you'd care to ever know about it - it looks a bit intimidating, but its very useful:

ftp://download.nvidia.com/XFree86/Li...174/README.txt

PS: again, this isn't taking any suse-specific elements into consideration.... any suse gurus feel free to chime in

Last edited by Genesee; 04-02-2005 at 01:50 AM.
 
Old 04-02-2005, 02:47 PM   #14
Thoreau
Senior Member
 
Registered: May 2003
Location: /var/log/cabin
Distribution: All
Posts: 1,167

Rep: Reputation: 45
I missed a step. before make prepare-all, do a make cloneconfig. Sorry.
 
Old 04-02-2005, 05:54 PM   #15
beebelo
Member
 
Registered: Mar 2005
Location: USA
Distribution: Ubuntu Studio 13.1, Debian Stable (Wheezy)
Posts: 68

Original Poster
Rep: Reputation: 15
Thanks Thoreau and Genesee. I will try again tonight.

I did find out something useful: NVidia's howto said you have to have some things installed: kernel-source, make and gcc. I didn't have a clue what those were, but last night I discovered two of those packages were NOT installed. I installed them last night with YaST.

Wish me luck!

WHen this is over, I plan on posting with my own experiences in the SuSE forum so that someone else like me in this situation may benefit...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Turns off wescrock Linux - Newbie 4 09-23-2005 12:42 AM
Monitor turns off by itself sometimes... juanbobo Linux - General 4 08-26-2005 04:06 PM
My monitor just turns off and doesn't get to the desktop (SUSE 9.3). Hrothgar15 Suse/Novell 3 08-22-2005 06:01 AM
ICEWM :Monitor Turns off.. Tried everything.... UsualTuxpect Linux - Software 8 10-31-2004 03:47 AM
SuSE problem, screen turns white phillipd Linux - Newbie 0 07-09-2002 11:05 PM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration