LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-13-2007, 07:47 PM   #1
esotericx10
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
Monitor signal input out of range


set to 60Hz 1280 X 1024. This is what happens when I boot up my new installation of Fedora Core 6. I'm running a 6 month old HP Pavilion with P-IV 3.06 Processor, 80Gig HDD w/ Win XP PRO installed. 1 Gig of DDR 2 RAM. Added ATI 1600 PRO display adapter, and Western Digital 250 Gig HDD. Installed Fedora on 250 Gig HDD on third primary partition.

The little monitor message is blocking the log on screen that comes up on post install boot, so can't read it to enter any information. So can't complete post install boot. I've check my ATI settings and they're set to those exact settings. 60 Hz 1280 X 1024.
 
Old 05-13-2007, 08:16 PM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
I've check my ATI settings and they're set to those exact settings. 60 Hz 1280 X 1024.
Where / how did you check those?
 
Old 05-14-2007, 12:13 AM   #3
esotericx10
LQ Newbie
 
Registered: May 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Those settings were checked through Windows XP
 
Old 05-14-2007, 01:30 AM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I'm sorry to say so but there appears to be some confusion here. You seem to assume that the settings of your video card under windows somehow carry over onto Linux. But that's not the case; a video card is a dead slab of technology that doesn't become functional until you install a piece of software known as a "driver". What you are reporting are the results of the windows driver on windows. That driver doesn't do anything for Linux because:
a. that driver was installed under windows, not linux - they are in a separate "box", to put it like that
b. it is a windows driver - linux requires a linux driver

In short, you will have to do some work to get your card properly configured under Linux. Here's how:
- boot your system
- select the fedora boot line and press E
- select the line that starts "kernel /vmlinuz ..." and press E again
- append this to the line that now appears on screen: single
- press Enter
- press B

You should now be presented with a command line.
- log in using the following username: root
- when the system requests it, submit your root password and press enter when you've done so
- type: cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bu
- type: nano /etc/X11/xorg.conf

This will bring up your xorg.conf (graphics configuration file). Use the arrows to move through the file and:
- locate the "device" section and replace the driver (probably "ati") with "vesa"
- locate the monitor section and have a look at the HorizSync and VertRefresh values; these can't be higher than what your monitor supports or you'll get the "out of range" error; adjust as required - you may have to consult a manual or the internet to find out which values are supported by your type of monitor.

When you're done editing, save and exit:
Ctrl + O
Enter
Ctrl + X
Enter

You're back at the command line. Now type:

startx

Should work. But at this point, you are using the generic vesa driver. It is required to work around the monitor issue but once you're up and running, you should install the proprietary ATI fglrx driver. Although it relates to an earlier FC release, the following article is still perfectly valid:

http://stanton-finley.net/fedora_cor...ion_notes.html

Last edited by jay73; 05-14-2007 at 01:34 AM.
 
Old 05-16-2007, 01:29 PM   #5
esotericx10
LQ Newbie
 
Registered: May 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Signal Input out of Range

Ok,

Here is exactly what appears on my screen while following your instructions

GNU GRUB Version 0.97 (639k / 1047360k upper memory)

Fedora Core (2.6.18-1.2798.fc6xen)
Other

Then my options are boot selected OS
e- edit
a- modify kernel arguments
c- commandline

I press E and get the following:
root (HD1,2)
kernel /boot/xen.gz.-2.6.18-1.2798.fc6
module /boot/vmlinuz-2.6.18-1.2798.fc6xen ro root=LABEL=/rhgb quiet
module /boot/initrd-2.6.18-1.2798.fc6xen.img

No combination of anything I try as per your instructions works. The line "kernel/vmlinuz" does not exist. Based on what you see here if you have any other ideas I'm all ears. In my original post I was going to mention that this was probably a driver issue. I'm not completely stupid, just mostly.

ESO...
 
Old 05-16-2007, 09:22 PM   #6
rwilcher
LQ Newbie
 
Registered: Mar 2006
Location: Maple Heights OHIO
Distribution: Centos 6
Posts: 21

Rep: Reputation: 0
Hows about trying whats on line 3 ? Hit e, mod the line and
hit escape them b . Asuming it's the grub loader booting your box. I dont use FC6 but I do use grub a lot. Dont think it will
hurt anything to try in any event.

root (HD1,2)
kernel /boot/xen.gz.-2.6.18-1.2798.fc6
module /boot/vmlinuz-2.6.18-1.2798.fc6xen -s ro root=LABEL=/rhgb
quiet
^^^

module /boot/initrd-2.6.18-1.2798.fc6xen.img
 
Old 05-16-2007, 09:26 PM   #7
rwilcher
LQ Newbie
 
Registered: Mar 2006
Location: Maple Heights OHIO
Distribution: Centos 6
Posts: 21

Rep: Reputation: 0
Hows about trying whats on line 3 ? Hit e, mod the line and
hit escape then b . Asuming it's the grub loader booting your box. I use FC4 and I do use grub a lot. Dont think it will
hurt anything to try in any event.

root (HD1,2)
kernel /boot/xen.gz.-2.6.18-1.2798.fc6
module /boot/vmlinuz-2.6.18-1.2798.fc6xen -s ro root=LABEL=/rhgb
quiet
^^^

module /boot/initrd-2.6.18-1.2798.fc6xen.img
 
Old 05-16-2007, 09:30 PM   #8
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
The line "kernel/vmlinuz" does not exist.
I didn't think you would be using the xen version of the kernel. In that case, you should go for the boot/vmlinuz line. Select, press E, append, press Enter, press B, etc.

One other thing that may get you the same result: wait for the blank screen to come up and hit Ctrl + alt + backspace; that should also take you to the command line; then proceed as I described before.

If none of this works, you could also use a liveCD.

Last edited by jay73; 05-16-2007 at 09:31 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor HP 1530 Input Signal Out of Range jojojo Linux - Hardware 1 06-16-2006 06:41 PM
input signal out of range - fpd1730 help! ryedawg Linux - Software 0 12-09-2005 09:15 PM
got a new monitor now 'signal out of range' mrtokyo Linux - Software 5 06-30-2004 01:42 PM
input signal out of range taoweijia Linux - General 1 06-04-2004 03:14 AM
input signal out of range tadspurgeon Linux - Software 4 01-30-2004 11:50 AM


All times are GMT -5. The time now is 08:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration