LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-14-2009, 10:09 PM   #1
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Rep: Reputation: 31
Monitor keeps blinking to black


I'm using Fedora 10, nvidia legacy drivers, twinview dual monitor setup. My left monitor keeps blinking to black. My right monitor is behaving 100% perfectly. This just started today (or at least today's the first time I ever noticed it. Sometimes it'll go minutes without blinking and something it'll blink three times in 3 seconds. I swapped out the VGA cable and it's still happening. I also dusted out my computer today, so it's not dust on the graphics card.

How can I figure out if it's happening because of the drivers? Or some kernel upgrade or something like that. Of course, I still have to try another monitor in its place to see if it's the monitor.

To be clear, the power isn't going off, the screen just turns black and my right monitor somewhat blinks as if Linux is saying - switch to just using this monitor. Then it goes back to displaying what it should be.

Thanks,
 
Old 03-15-2009, 08:46 AM   #2
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
I am now pretty sure it has to do with the nvidia driver and/or xorg.conf. When I switch to a virtual terminal I don't have any problems whatsoever.
 
Old 03-15-2009, 08:54 AM   #3
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
I deleted my xorg.conf and rebooted. Fedora 10, like Ubuntu 8.x will automatically generate a new xorg.conf for you. Unfortunately, it only generated a one-monitor xorg. So far it appears to be working sans flickers. So, thankfully (money-wise), it's just a software issue. I will post my old/new xorgs in case someone can offer up a suggestion. Also, I will try nvidia's generate an xorg.conf feature to try and bring back twinview.
 
Old 03-15-2009, 11:19 AM   #4
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
old xorg:
Code:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "0"
	Option	    "AIGLX" "on"
EndSection

Section "InputDevice"

    # generated from default
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "Emulate3Buttons" "no"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Unknown"
	ModelName    "LCD L17LCD2"
	HorizSync    30.0 - 83.0
	VertRefresh  55.0 - 75.0
	Option	    "DPMS"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
	BoardName   "GeForce FX 5500"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1280+0"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option	    "TwinView" "1"
	Option	    "TwinViewXineramaInfoOrder" "CRT-0"
	#Option	    "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: 1280x1024 +1280+0; CRT-0: nvidia-auto-select +0+0,CRT-1:  NULL"
	Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1280+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
new xorg:
Code:
# Xorg configuration created by livna-config-display

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
 
Old 03-15-2009, 05:59 PM   #5
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
interestingly - glxgears runs very, very slowly now - 4 FPS. What does this tell me? I know the nvidia driver is loaded becausae I did an lsmod | grep nvidia.
 
Old 03-15-2009, 06:54 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 12,601

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
DJOtaku , how did you install the driver ?
did you use the 173 kmod in the fedora repos or did you install the nvidia.run ?
 
Old 03-15-2009, 08:24 PM   #7
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
I used the fedora RPM fusion repos. I have the akmod rpm that's supposed to produce the latest version if it hasn't been released yet.
 
Old 03-15-2009, 09:11 PM   #8
John VV
Guru
 
Registered: Aug 2005
Posts: 12,601

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
and it is this rpm
akmod-nvidia-173xx-173.14.16-1.fc10.i686.rpm
Code:
rpm -qa | grep nvidia
and you still get 4 fps using the old xorg.conf or is that with using the new xorg.conf

? that "new " file it was made from running " livna-config-display " ?
 
Old 03-16-2009, 04:06 AM   #9
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
Code:
$ rpm -qa | grep nvidia
xorg-x11-drv-nvidia-173xx-libs-173.14.16-1.fc10.i386
xorg-x11-drv-nvidia-173xx-devel-173.14.16-1.fc10.i386
kmod-nvidia-173xx-2.6.27.12-170.2.5.fc10.i686-173.14.16-1.fc10.i686
kmod-nvidia-173xx-2.6.27.15-170.2.24.fc10.i686-173.14.16-1.fc10.1.i686
akmod-nvidia-173xx-173.14.16-1.fc10.i686
kmod-nvidia-173xx-2.6.27.19-170.2.35.fc10.i686-173.14.16-1.fc10.2.i686
xorg-x11-drv-nvidia-173xx-173.14.16-1.fc10.i386
Code:
$ glxgears 
27 frames in 5.1 seconds =  5.334 FPS
27 frames in 5.1 seconds =  5.247 FPS
I deleted my xorg.conf and that new one was auto-created for me.
 
Old 03-16-2009, 11:57 AM   #10
John VV
Guru
 
Registered: Aug 2005
Posts: 12,601

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
the only thing i can think of would be add a few lines to the old xorg.conf
[code]
Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/drivers"
ModulePath "/usr/lib/xorg/modules"
EndSection

# and with two screen sections these go here
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5500"
Option "AddARGBGLXVisuals" "True"
Option "UseEvents" "False"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "NVAGP" "3"

EndSection
 
Old 03-16-2009, 12:01 PM   #11
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
ok, I'll give that a shot when I get home from work. Did something change in Xorg or Xrandr or something? Those lines weren't in there before and it was working fine.
 
Old 03-16-2009, 12:34 PM   #12
John VV
Guru
 
Registered: Aug 2005
Posts: 12,601

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
these are the options i have gotten through the nvidia README for installing the nvidia driver
in the set up and configure section

http://www.nvidia.com/object/linux_d...173.14.18.html
Quote:
STEP 3: Install
....
Instructions for those wishing to edit their X config file by hand can also be found in the README.
the nvidia README
http://us.download.nvidia.com/XFree8...DME/index.html
 
Old 03-16-2009, 02:48 PM   #13
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
OK, before switching to your options I tried glxgears again; mysteriously, glxgears is now reporting in the 1400 fps range.

However, with your options, my situation isn't any better.

I did notice something I forgot to mention. Previously, both my monitors would be at the same resolution. Right now my right-most monitor (the one that doesn't flicker) is at 800x640 or something huge like that. They don't match up anymore. I wonder if that's a clue as to what's going wrong?

Also, if I leave it flickering for too long, it dumps me back to GDM - I guess basically the graphics driver is crashing.
 
Old 03-16-2009, 02:52 PM   #14
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
sometimes, however, running glxgears freezes the screen and i have to control-alt-backspace
 
Old 03-16-2009, 03:40 PM   #15
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 710

Original Poster
Rep: Reputation: 31
Tried running a liveCD of Mandriva. They loaded the nvidia 173 drivers and it crashed when running glxgears.

Sometimes (back on my Fedora box) X.org has been taking up like 90% of the CPU.

Does it sound like perhaps my graphics card or some other bit of hardware is failing? What could I check to confirm this?

Thanks!
 
  


Reply

Tags
blinking, graphics, monitor, nvidia, xorg, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen with blinking cursor immediately after installing Ubuntu 8.10 lazy_bones1987 Linux - Newbie 9 11-30-2008 10:19 AM
Black screen with blinking cursor mookini Linux - Newbie 4 09-25-2006 09:31 AM
Monitor keeps blinking on boot wearetheborg Linux - Hardware 1 12-13-2005 03:55 PM
Boot up with a black screen and the word 'GRUB' followed by blinking cusor davidas Debian 6 07-11-2004 02:29 PM
Redhat 9.0 + blinking monitor during install bgates Linux - Distributions 3 06-12-2004 12:12 AM


All times are GMT -5. The time now is 11:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration