LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-25-2003, 04:38 PM   #1
byronholldorf
LQ Newbie
 
Registered: Jul 2003
Posts: 3

Rep: Reputation: 0
module required for net card switches on reboot


I'm having a problem with a network card on an Internet gateway I'm setting up. The system has two network cards. Eth0 works fine, but eth1 is giving me problems. The card is a Linksys Etherfast 10/100 and was setup during installation using the tulip module. After a reboot (hard or soft) the card only works using the e100 module. After another reboot the card will again only work with the tulip module. Not the card since another Etherfast card operated in the same fashion.

I'm out of ideas. Maybe someone could enlighten me....

Redhat 9 - uptodate

---modules.conf---
alias eth0 e100
alias usb-controller usb-uhci
#alias eth1 e100
alias eth1 tulip

---lspci output (eth1 followed by eth0)---
....
00:11.0 Ethernet controller: Lite-On Communications Inc LNE100TX [Linksys EtherFast 10/100] (rev 25)
Subsystem: Lite-On Communications Inc LNE100TX [ver 2.0]
Flags: bus master, stepping, medium devsel, latency 72, IRQ 10
I/O ports at fc00 [size=256]
Memory at ffbeec00 (32-bit, non-prefetchable) [size=256]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [44] Power Management version 1

00:13.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 01)
Flags: bus master, medium devsel, latency 72, IRQ 11
Memory at ffbef000 (32-bit, prefetchable) [size=4K]
I/O ports at ff80 [size=32]
Memory at ff800000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled] [size=1M]
....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack drops 'route' after reboot. Manual config required - but why? fireman949 Linux - Networking 1 09-07-2005 01:15 AM
how many switches are required alvi2 Linux - Networking 1 03-31-2005 11:35 AM
Working PCMCIA Net Card Not Found On Reboot mortovski Linux - Laptop and Netbook 3 03-23-2005 05:51 PM
XML::Parser perl module is required farzan Linux - Software 8 09-26-2004 05:54 AM
Network fails fo work in Mandrake 10.0; annoying reboot required chrisrl Linux - Networking 2 03-27-2004 05:44 PM


All times are GMT -5. The time now is 07:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration