LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-16-2005, 06:25 AM   #1
GPLed
LQ Newbie
 
Registered: Oct 2005
Posts: 6

Rep: Reputation: 0
Exclamation Modem (Smartlink PCI) and webcam issues


Well I have a Fedora Core 4 system with a Smartlink PCI modem. I have kernel 2.6.13.1.1526_FC4 and gcc 4.01. I tried many drivers in the linmodems smartlink archive. Many are not compatible with gcc 4.0 + and those which are give segment faults when modprobing. I know this is a known issue so I tried installing slmodem with alsa support (I trief all alsa packages or smartlink.) but that gives me errors which I have attached. Furthermore I installed slmodem from Livna repository and tried running /usr/sbin/slmodemd (after loading snd-intel80x and other modules) but it gave me this output:
Code:
error: mixer setup: attach hw:1 error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM modem:1 definition (id: modem, value: cards.pcm.modem)
error: alsa setup: cannot open playback device 'modem:1': Invalid argument
error: cannot setup device `modem:1'
So what do I do now? How do I get slmodem installed and slmodemd working with alsa modem drivers? I also updated alsa-lib to 1.0.9 (ie the latest stable).

Also I have an issue with two webcams : a Logitech QuickCam Express and a Labtec webcam both of which accept the spca5xx driver and give a picture except for the colour which is purple or yellow and alternating. I know this is a known issue but I wasnt able to find a solution for it.


 
Old 10-16-2005, 06:25 AM   #2
GPLed
LQ Newbie
 
Registered: Oct 2005
Posts: 6

Original Poster
Rep: Reputation: 0
I forgot to mention: Thanks to any replies.
 
Old 10-23-2005, 10:33 PM   #3
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 995

Rep: Reputation: 294Reputation: 294Reputation: 294
Try one of the latest slmodem drivers from linmodems, they compile cleanly with gcc-4.0. (Look at the date of the release, look for the newer ones). I didn't have luck with alsa, so what I did was to download a non-alsa driver and the ungrab-winmodem module (available from the same site) which avoids errors when modprobing. Note that you have to load the ungrab-winmodem module before loading the slamr/slusb module. That's all, hope it works for you too.

Last edited by odiseo77; 10-23-2005 at 10:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
opensuse and smartlink modem vinzer Linux - Hardware 2 11-05-2005 05:46 AM
Smartlink PCI modem for AMD 64? markw8500 Linux - Hardware 0 08-20-2005 07:52 PM
I need drivers for Smartlink 56k PCI (netodragon) Cyb3rPr0 *BSD 3 12-31-2004 02:20 PM
can't install smartlink driver for modem Veivann Linux - Laptop and Netbook 1 02-22-2004 02:22 PM
Smartlink USB modem LordPBA Linux - Newbie 4 03-13-2003 02:50 PM


All times are GMT -5. The time now is 06:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration