LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-06-2011, 08:31 AM   #1
texasj
LQ Newbie
 
Registered: Feb 2011
Posts: 23

Rep: Reputation: 2
Unhappy middle mouse button doesn't work


Hi everybody...!
I am using Red Hat Enterprise Linux Server release 5.4 (Tikanga) some how the middle button which we use for copy & paste purpose is not working.
I checked the mouse configuration file & also the gpm service is enable but still it is not working.
Kindly address my issue...!
 
Old 12-06-2011, 08:48 AM   #2
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Rep: Reputation: 92
Please do not post same thread twice. If you want to edit, use "edit" button below your post.

/etc/sysconfig/mouse contains the mouse configuration information. check that file.

you can reconfigure mouse by editing /etc/X11/xorg.conf file or your distributions mouse configuration tool. You can also use xmodmap utility for modifying keymaps and mouse pointer button mappings in X

Here is my USB mouse entry:
Code:
 
Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[5]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Generic Wheel Mouse"
  Option       "Protocol" "explorerps/2"          
  Option       "Vendor" "Sysp"                    
  Option       "ZAxisMapping" "4 5"               
EndSection
I am not RHEL user, but I found out this command for you
redhat-config-mouse

Last edited by raju.mopidevi; 12-06-2011 at 08:58 AM.
 
Old 12-07-2011, 02:20 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Moved: This thread is more suitable in <HARDWARE> and has been moved accordingly to help your thread/question get the exposure it deserves.
 
0 members found this post helpful.
Old 12-08-2011, 03:15 AM   #4
texasj
LQ Newbie
 
Registered: Feb 2011
Posts: 23

Original Poster
Rep: Reputation: 2
Thanks Raju for reply..!
I checked the file(/etc/X11/xorg.conf) as suggested by you & I have the following configurations

Section "InputDevice"
Driver "vmmouse"
Identifier "VMware Mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

What changes should I make to this file for resolving the issue?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
middle mouse button doesn't work texasj Linux - Newbie 1 12-06-2011 08:59 AM
Mouse (middle scroller button) does work kat13 Red Hat 6 08-19-2009 03:18 PM
Middle mouse button doesn't paste CJ Chitwood Linux - General 3 06-12-2008 10:32 PM
middle button doesn't work laurentwahl Linux - Hardware 8 06-01-2005 03:35 PM
FC3: Middle mouse button wont work TheJkWhoSaysNi Linux - Hardware 4 03-12-2005 04:30 PM


All times are GMT -5. The time now is 09:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration