LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-24-2006, 03:18 PM   #1
nikodhmos
LQ Newbie
 
Registered: Mar 2006
Location: /Europe/Greece/Athens
Distribution: openSUSE 10.2, 2.6.18.2-34-default x86_64, KDE 3.5.5 "release 45"
Posts: 4

Rep: Reputation: 0
Microsoft Wireless Optical Mouse 2.0A Wheel button Not Working, Why ?


I have Suse Linux 10 Novell Edition (x86_64) with Kernel 2.6.13-15.8-default on
a dual boot machine (the other OS is Windows 2000 Pro).
I am very satisfied from the Suse Linux 10, but I have a minor problem that is a
bit irritating. That is, my mouse middle Wheel button does not work in Linux, so, when I
want to scroll up/down, mainly in web pages as I used to in Windows, I become irritated.
Is it a real problem or I have to configure my mouse somehow in order for my scroll button to work ?
Below is the output of dmesg regarding my keyboard & mouse:
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
input: USB HID v1.11 Keyboard [Microsoft Microsoft Wireless Optical Desktop 2.10] on usb-0000:00:02.0-8.2
input: USB HID v1.11 Mouse [Microsoft Microsoft Wireless Optical Desktop 2.10] on usb-0000:00:02.0-8.2
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Thanks in advance
 
Old 03-24-2006, 08:34 PM   #2
piscikeeper
Member
 
Registered: Jul 2003
Location: indiana,usa
Distribution: SuSE 11,Slack,Mint
Posts: 425

Rep: Reputation: 30
Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

etc/X11/xorg.conf should look similar to this.the button number and zaxis lines are the important ones.the lable for protocol may be imps/2 instead of explorerps/2.
 
Old 03-25-2006, 12:46 PM   #3
nikodhmos
LQ Newbie
 
Registered: Mar 2006
Location: /Europe/Greece/Athens
Distribution: openSUSE 10.2, 2.6.18.2-34-default x86_64, KDE 3.5.5 "release 45"
Posts: 4

Original Poster
Rep: Reputation: 0
Thumbs up Thank you very much, it works fine now with your config

Thank you very much, it works fine now with your configuration !!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft USB Wireless Optical Mouse (Intellipoint) not working Kritz Linux - Hardware 4 08-22-2005 12:04 PM
MIcrosoft USB Optical Mouse Wheel Scroll Not Working... onelung02 Slackware 8 02-02-2005 06:11 AM
Yet another 5 button optical wheel mouse problem buboleck Slackware 1 04-15-2004 12:09 PM
Microsoft wheel optical mouse not working on mandrake 9 wellisch Linux - Hardware 6 06-16-2003 02:43 PM
MS IntellyEye Optical - Mouse Wheel isn't working Canaris Linux - Hardware 4 05-27-2003 05:44 AM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration