LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Microphone not working in Skype (http://www.linuxquestions.org/questions/linux-hardware-18/microphone-not-working-in-skype-661834/)

bkorb 08-10-2008 02:54 PM

Microphone not working in Skype
 
The audio is crystal clear. When I speak into my mic, nothing is transmitted. Hmmm. Looks like the alsa information just got
posted to "pastebin.ca". I was about to do it by hand...I may
have to do it anyway because I don't see a URI for the data.
(I've preserved /tmp/alsa-info.txt.)

Thank you in advance.

Regards, Bruce

http://pastebin.com/de2205b7

bkorb 08-10-2008 04:03 PM

Hey, really cool. Got it working. All I had to do was keep fiddling with the dozen or so "alsaconf" attributes until my test call to Skype fed back by "testing 1, 2, 3" announcement. I don't really know what did the trick because I finally just turned up the volume on every control (they install as mostly off, so you have to go figure out what needs turning on).

If there are alsa developers out there listening, here are a little suggestion. (Hopefully filtering out my tinges of frustration. :)

When the configuration program is running, test for an active mic. For example, ask the user to say something and detect which mic input has more than static noise input. If there is input, then turn it on. Please. Thank you.

jmlm_1970 03-26-2012 07:18 PM

How to make microphone work!
 
The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

bkorb 03-27-2012 09:54 AM

Quote:

Originally Posted by jmlm_1970 (Post 4637080)
The only solution to make microphone work is to install linux-backports-modules-alsa-generic...Just go to:....And search and mark for...(if you have multiple versions click on the first and read)...If after the reboot and mic ... still does not work, just ... type:..."sudo vi /etc/modprobe.d/alsa-base.conf" and add or change the following:...write and exit, reboot and mic will work.

I didn't say configuring the mic was impossible. It is, however, beyond the grasp of any but the most dedicated hackers.

TobiSGD 03-27-2012 10:01 AM

Don't mind the comment of jmlm_1970, it was not related to your thread, but rather simple spam.


All times are GMT -5. The time now is 08:36 PM.