LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 03-22-2011, 07:06 AM   #1
andrewc54
LQ Newbie
 
Registered: Jan 2011
Location: Glen Waverley,melbourne, Australia
Posts: 12

Rep: Reputation: 0
microphone not working


for some reason my microphone is not working I'm running ubuntu10.10 on a Toshiba R500 Portege it plays sounds ok but i cannot record sounds nor use the mic in Skype etc any one know what to do?
 
Old 03-22-2011, 07:16 AM   #2
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
Hello,

Have you checked in your volume settings that it's not just 'muted'?

Kind regards,

Eric
 
Old 03-22-2011, 09:57 AM   #3
lidex
Member
 
Registered: Aug 2009
Location: Ohio, USA
Distribution: Ubuntu Development Release x64
Posts: 56

Rep: Reputation: 23
Also make sure you have selected a profile on the hardware tab of sound preferences with either
duplex or output + input.
 
1 members found this post helpful.
Old 03-23-2011, 03:17 AM   #4
andrewc54
LQ Newbie
 
Registered: Jan 2011
Location: Glen Waverley,melbourne, Australia
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks one and all all working as it should

once again many thanks
 
Old 03-23-2011, 03:19 AM   #5
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
Hello,

Glad you got it solved. May I ask what was the problem and solution in your case so that others with similar issues can give it a try? If you consider your problem solved then please mark the thread as such using the Thread Tools.

Kind regards,

Eric
 
Old 03-24-2011, 03:30 AM   #6
andrewc54
LQ Newbie
 
Registered: Jan 2011
Location: Glen Waverley,melbourne, Australia
Posts: 12

Original Poster
Rep: Reputation: 0
Not sure what I did but I remember clicking on sound then hardware make sure the sound card is present in my case internal audio click on analog stereo duplex for input I think it was microphone 1 eventually got it working not sure if this works for all but definitely a glitch with ubuntu
 
Old 03-24-2011, 03:30 AM   #7
andrewc54
LQ Newbie
 
Registered: Jan 2011
Location: Glen Waverley,melbourne, Australia
Posts: 12

Original Poster
Rep: Reputation: 0
Not sure what I did but I remember clicking on sound then hardware make sure the sound card is present in my case internal audio click on analog stereo duplex for input I think it was microphone 1 eventually got it working not sure if this works for all but definitely a glitch with ubuntu
 
Old 03-24-2011, 03:32 AM   #8
andrewc54
LQ Newbie
 
Registered: Jan 2011
Location: Glen Waverley,melbourne, Australia
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks to all those who assisted in this
 
Old 03-26-2012, 08:03 PM   #9
jmlm_1970
Member
 
Registered: Nov 2010
Location: Aveiro, Portugal, Europe
Posts: 38
Blog Entries: 1

Rep: Reputation: 1
How to make microphone work!

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Microphone Not working kujirasan Fedora 3 02-01-2011 06:44 AM
microphone not working jone kim Linux - Hardware 2 10-02-2010 06:03 PM
Microphone not working. jadex Linux - Hardware 8 04-04-2007 10:45 AM
Microphone not working Ashrack Linux - Software 0 09-01-2006 07:48 AM
microphone not working Abrocadabro Debian 1 12-03-2004 01:37 AM


All times are GMT -5. The time now is 07:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration