LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   microphone not working (http://www.linuxquestions.org/questions/linux-hardware-18/microphone-not-working-870184/)

andrewc54 03-22-2011 06:06 AM

microphone not working
 
for some reason my microphone is not working I'm running ubuntu10.10 on a Toshiba R500 Portege it plays sounds ok but i cannot record sounds nor use the mic in Skype etc any one know what to do?

EricTRA 03-22-2011 06:16 AM

Hello,

Have you checked in your volume settings that it's not just 'muted'?

Kind regards,

Eric

lidex 03-22-2011 08:57 AM

Also make sure you have selected a profile on the hardware tab of sound preferences with either
duplex or output + input.

andrewc54 03-23-2011 02:17 AM

Thanks one and all all working as it should

once again many thanks

EricTRA 03-23-2011 02:19 AM

Hello,

Glad you got it solved. May I ask what was the problem and solution in your case so that others with similar issues can give it a try? If you consider your problem solved then please mark the thread as such using the Thread Tools.

Kind regards,

Eric

andrewc54 03-24-2011 02:30 AM

Not sure what I did but I remember clicking on sound then hardware make sure the sound card is present in my case internal audio click on analog stereo duplex for input I think it was microphone 1 eventually got it working not sure if this works for all but definitely a glitch with ubuntu

andrewc54 03-24-2011 02:30 AM

Not sure what I did but I remember clicking on sound then hardware make sure the sound card is present in my case internal audio click on analog stereo duplex for input I think it was microphone 1 eventually got it working not sure if this works for all but definitely a glitch with ubuntu

andrewc54 03-24-2011 02:32 AM

Thanks to all those who assisted in this

jmlm_1970 03-26-2012 07:03 PM

How to make microphone work!
 
The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).


All times are GMT -5. The time now is 09:06 AM.