LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Microphone not working. (http://www.linuxquestions.org/questions/linux-hardware-18/microphone-not-working-530502/)

jadex 02-19-2007 02:48 PM

Microphone not working.
 
Can someone provide me with a screenshot of their kmix?

I have HDA Nvidia sound and snd-hda-intel driver installed. For some reason, I can't seem to set up the microphone to work correctly. I can hear sound, just can't use the mic.

There are 3 "Capture" sliders, 3 input options, 1 front mic slider,1 regular mic, etc. Not sure what all the kmix options do (and how enabling one affects the other). A snapshot would be helpful if anyone can provide it. I'm using the mic jack on the front of the machine, and both mic options are selected (will try the back of the computer jack shortly).

Thanks in advance!

GrueMaster 02-19-2007 03:39 PM

What system do you have? What version of alsa? (cat /proc/asound/version)

It might be a simple matter of loading a newer alsa-driver version, or if it is currently unsupported, send me some info and I can see about adding it.

JimBass 02-19-2007 04:23 PM

I just activated a microphone the other day through kmix. The issues are on the input and switches tabs.

Input tab:
The light should be pink under mic and capture, and dark red under line, CD, phone and aux. The sliders for mic and capture should be up around 75% or so.

Switches tab:
Mic boost, external amplifier, and stereo mic should be yellow. Video, mix, and mix mono should be red. The mic select I have at mic 1, and mono output select I have at mix.

Also, make sure the current mixer is set to your sound card, and not your modem.

If that is how you are set and it doesn't work, then it could be an issue with alsa, but I would try this first.

Peace,
JimBass

jadex 02-19-2007 09:26 PM

My info:

System: openSUSE 10.2
Motherboard: EVGA 122-CK-NF68-AR NForce 680i
ALSA version: Advanced Linux Sound Architecture Driver Version 1.0.12rc1 (Thu Jun 22 13:55:50 2006 UTC)
KMix version: KMix 2.6 (Using KDE 3.5.5 "release 45" openSUSE 10.2)

JimBass, my version of KMix doesn't provide some of the setup options you mention. Here are my KMix options:

"Output" tab:
-PCM
-Front
-Front Mic
-Surround
-Center
-LFE
-Side
-Line
-Mic

"Input" tab:
-Capture
-Capture
-Capture

"Switches" tab:
-Headphone (yellow radio button)
-IEC958 (red radio button)
-Input Source (pull down menu of: Mic, Front Mic, or Line)
-Input Source (pull down menu of: Mic, Front Mic, or Line)
-Input Source (pull down menu of: Mic, Front Mic, or Line)

I also have a "Left/Right Balancing" bar at the bottom of the KMix panel.

My /etc/modprobe.d/sound looks like this:
Code:

options snd-hda-intel enable=1 index=0
# rKvl.W3L1YU9eF5E:MCP55 High Definition Audio
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=ref

NOTE: I added the last line after reading someone's advice posted on a forum, but it doesn't seem to have helped much.

GrueMaster 02-19-2007 10:05 PM

Well, we've established two things, mainly that you need a newer alsa-driver, but also I need more info to be sure you are supported. Could you paste the output from "lspci -vn | fgrep -A1 0403" and the output from "cat /proc/asound/card0/codec*"? I can determine what to do from there, but upgrading to alsa-1.0.14rc2 is definitely on the todo list. After that, I may need to send you a patch.

You can also email this info to me at gmail.com (same UID).

Dragineez 04-03-2007 11:38 AM

How2
 
Quote:

Originally Posted by jadex
My info:

System: openSUSE 10.2
Motherboard: EVGA 122-CK-NF68-AR NForce 680i

I know I'm going wildly off topic, but I've just built a PC using that same motherboard. I've tried a few live CDs to see if I can install Linux, but none of them have worked.

Did you have to do anything special to get openSUSE to install?

jadex 04-04-2007 01:23 AM

No, I didn't have to do anything special. I downloaded the installation from openSUSE's website (I think it was the 10.2 i386 version).

Are you sure you burned the ISO correctly?

almatic 04-04-2007 02:50 AM

here I have made you some screenshots.

http://freenet-homepage.de/dateigarage/kmix1.jpg
http://freenet-homepage.de/dateigarage/kmix2.jpg

but you could easily test by just enabling everything and put every slider to max.

Dragineez 04-04-2007 09:45 AM

Known Good
 
Quote:

Originally Posted by jadex
No, I didn't have to do anything special. I downloaded the installation from openSUSE's website (I think it was the 10.2 i386 version).

Are you sure you burned the ISO correctly?

These are the same discs I've used to Live boot and install countless times, so they are known good (FC6, Ubuntu, Knoppix).

I think I may have found the solution in another thread. I am using the SATA RAID on this board. This may be causing the problem. Though OpenSUSE looks interesting, I may try that anyway just to take a peek.


All times are GMT -5. The time now is 02:38 AM.