LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Microphone not working (http://www.linuxquestions.org/questions/linux-hardware-18/microphone-not-working-388064/)

arnott 11-30-2005 05:54 PM

Microphone not working
 
Am running fedora core 4 on my AMD64 machine. I use KDE for my desktop. I recently bought a microphone with headset and am having problems to get it to work.

I cannot record using KRec. also I do not hear my voice on the speaker.

I have read discussions on many forums and tried different stuff and nothing is working.

I have changed settings in Kmix, alsamixer . changed /etc/asound.conf to :

pcm.asymed {
type asym
playback.pcm "dmix"
capture.pcm "dsnoop"
}
pcm.!default {
type plug
slave.pcm "asymed"
}
pcm.!dmix {
type dmix
ipc_key 5678293
ipc_key_add_uid yes
slave {
pcm "hw:0,0"
period_time 0
period_size 128
buffer_size 2048
format S16_LE
rate 48000
}
}
pcm.!dsnoop {
type dsnoop
ipc_key 5778293
ipc_key_add_uid yes
slave {
pcm "hw:0,0"
period_time 0
period_size 128
buffer_size 2048
format S16_LE
rate 48000
}
}

nothing is working. what should I do to get the microphone working ? I am testing microphone using KRec. is there another tool to test the microphone ?

settings :
1) /sbin/lsmod | grep snd
snd_intel8x0 39393 0
snd_ac97_codec 114053 1 snd_intel8x0
snd_ac97_bus 3393 1 snd_ac97_codec
snd_seq_dummy 4805 0
snd_seq_oss 39077 0
snd_seq_midi_event 9537 1 snd_seq_oss
snd_seq 65049 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 11345 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 60785 0
snd_mixer_oss 20161 1 snd_pcm_oss
snd_pcm 107081 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 29513 2 snd_seq,snd_pcm
snd 70049 9 snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,
snd_mixer_oss,snd_pcm,snd_timer
soundcore 12257 1 snd
snd_page_alloc 13137 2 snd_intel8x0,snd_pcm


2) ls -l /dev/dsp
crw-rw-rw- 1 arnott root 14, 3 Nov 11 23:36 /dev/dsp

3) ps aux | grep artsd
arnott 29102 0.0 5.7 127220 29288 ? S 12:29 0:03 /usr/bin/artsd -F 10 -S 4096 -a alsa -d -s 1 -m artsmessage -c drkonqi -l 3 -f


Thanks.
arnott

mewgle 12-01-2005 03:04 AM

Try running kmix. Check under the Input tab and make sure that your microphone isn't muted. Also, its kind of a dumb thing to do, but make sure that you have the mic plugged into the right port, and all the way in.

arnott 12-01-2005 10:37 AM

Thanks for your response, when I plugged the microphone on the port on the backside of the computer it started working. why is it different from the one on the front of my HP machine ?

mewgle 12-01-2005 04:22 PM

On some computers the front ports have to connect to the back ports. They just use an ugly wire to relocate them up front. It is possible that the wires were not plugged in. Other than that, I am not sure why it wouldnt work. its always possible that on your computer the front ports plug into a USB jumper, and linux did not know what to do with them. Im glad that it is working now though. Good luck


All times are GMT -5. The time now is 01:58 AM.