LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-20-2007, 04:15 PM   #1
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
microphone does not work with Realtek ALC883 HDA


I have a Gigabyte 965P-DS3 motherboard with a integrated audio chip Realtek ALC883 HDA. My sound partialyl working in Ubuntu 7.04 32bit desktop edition. Sound will play but depending on the application it is sometimes choppy. My microphone will not work at all. I have tried every single type of configuration possible from Sound Preferences with no luck to fix mic issue. I have posted a few weeks back to the kernel team. Here is the link, https://bugs.launchpad.net/ubuntu/+s...20/+bug/112695

I also noticed a discrepancy with lspci. My Realteak ALC883 shows up as, 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Here is my dmesg output.

Here is my lspci output.

Last edited by fakie_flip; 05-20-2007 at 04:23 PM.
 
Old 05-22-2007, 02:14 AM   #2
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
From your dmesg output:
Quote:
[ 14.323100] hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
This suggests that your board is not currently supported by the version of alsa you are trying to run.

Lspci is correct, you have an Intel HD Audio Bus specification compliant device. This is a separate bus off the south bridge controller (similar to usb). The RealTek codec is just the actual device on that bus (4 devices are supported according to the specification).

What I need to see in order to fix this (if it isn't already fixed), is more detailed output. Fortunately, there is a script you can run that uploads all of the info to a website and provides you with a link. The script is here. Please post the resulting link, thanks.

Tobin
 
Old 05-23-2007, 12:06 PM   #3
jcsjcs
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Rep: Reputation: 2
Thumbs up

I seem to have the same problem on a MSI K9N Ultra board:

May 23 21:21:24 localhost kernel: hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...

ALSA information is here:

http://pastebin.ca/505488

Good luck and thanks in advance,


JCS.
 
Old 05-23-2007, 01:02 PM   #4
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
jcsjcs: You need to get an updated driver before you can proceed. Your system is not listed in the driver yet, but there is support for several other MSI systems. It should be a simple matter of testing different models for the driver, then adding the correct one.

You can find daily snapshots of the driver here. Once you have it installed, try loading the driver with the following:

modprobe snd-hda-intel model=<model>

where <model> is one of the following:

6stack-dig
targa-dig
targa-2ch-dig
 
Old 05-23-2007, 08:13 PM   #5
jcsjcs
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Rep: Reputation: 2
Quote:
Originally Posted by GrueMaster
jcsjcs: You need to get an updated driver before you can proceed.
Thank you. Upon waking up this morning I had the same thought. Actually I was configuring the latest kernel at the time while looking at the output of the older stock-kernel to find out which drivers to include. I didn't make the connection just after midnight though :-/

I'll let you know once I had time to proceed.

Cheers,


JCS.
 
Old 05-25-2007, 02:02 PM   #6
jcsjcs
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Rep: Reputation: 2
I've finally got around to installing the latest kernel 2.6.22-rc2. I'm listening to the music coming out of the speaker despite of a warning on startup, so as far as I'm concerned everything is fine :-).

In case you want to investigate:

May 26 02:44:01 localhost kernel: [ 48.432721] Advanced Linux Sound Architecture Driver Version 1.0.14rc4 (Wed May 16 09:45:46 2007 UTC).
May 26 02:44:01 localhost kernel: [ 48.433179] ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 20
May 26 02:44:01 localhost kernel: [ 48.433212] ACPI: PCI Interrupt 0000:00:06.1[B] -> Link [LAZA] -> GSI 20 (level, low) -> IRQ 20
May 26 02:44:01 localhost kernel: [ 48.433302] PCI: Setting latency timer of device 0000:00:06.1 to 64
May 26 02:44:01 localhost kernel: [ 48.643989] hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
May 26 02:44:01 localhost kernel: [ 48.759800] ALSA device list:
May 26 02:44:01 localhost kernel: [ 48.759831] #0: HDA NVidia at 0xfbff0000
irq 20

Output of the script is located at:

http://pastebin.ca/509871


Cheers,


JCS.
 
Old 05-26-2007, 11:59 AM   #7
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
jcsjcs: Try reloading the sound driver with the following commands:

rmmod snd-hda-intel # remove driver
modprobe -i snd-hda-intel model=6stack-dig

If this gets everything working (which I believe it should), I'll add your system to the driver.
 
Old 05-26-2007, 11:19 PM   #8
jcsjcs
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Rep: Reputation: 2
Done. While I cannot say if "everything" works, I can play music (standard earphone stereo output) and no warning appears in the log (see below). I also tested the microphone with audacity and was able to record.

If there are specific other tests you'd like me to do please let me know.

Cheers,


JCS.

-----------

sudo modprobe -r snd_hda_intel

May 27 11:51:45 localhost kernel: [ 670.965259] ACPI: PCI interrupt for device 0000:00:06.1 disabled

sudo modprobe -i snd-hda-intel model=6stack-dig

May 27 11:51:49 localhost kernel: [ 675.069733] ACPI: PCI Interrupt 0000:00:06.1[B] -> Link [LAZA] -> GSI 20 (level, low) -> IRQ 20
May 27 11:51:49 localhost kernel: [ 675.069789] PCI: Setting latency timer of device 0000:00:06.1 to 64

sudo modprobe -r snd_hda_intel

May 27 11:53:22 localhost kernel: [ 766.936336] ACPI: PCI interrupt for device 0000:00:06.1 disabled

sudo modprobe -i snd-hda-intel

May 27 11:53:41 localhost kernel: [ 786.798049] ACPI: PCI Interrupt 0000:00:06.1[B] -> Link [LAZA] -> GSI 20 (level, low) -> IRQ 20
May 27 11:53:41 localhost kernel: [ 786.798077] PCI: Setting latency timer of device 0000:00:06.1 to 64
May 27 11:53:42 localhost kernel: [ 787.012111] hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
 
Old 05-27-2007, 03:08 AM   #9
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Ok, I'll submit a patch to the alsa team adding your system as a 6stack-dig configuration.
 
Old 05-30-2007, 03:04 AM   #10
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Original Poster
Rep: Reputation: 81
Quote:
Originally Posted by GrueMaster
From your dmesg output:


This suggests that your board is not currently supported by the version of alsa you are trying to run.

Lspci is correct, you have an Intel HD Audio Bus specification compliant device. This is a separate bus off the south bridge controller (similar to usb). The RealTek codec is just the actual device on that bus (4 devices are supported according to the specification).

What I need to see in order to fix this (if it isn't already fixed), is more detailed output. Fortunately, there is a script you can run that uploads all of the info to a website and provides you with a link. The script is here. Please post the resulting link, thanks.

Tobin
I ran the script. Here is the output.

http://pastebin.ca/521588
 
Old 05-30-2007, 03:24 AM   #11
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Just as I had expected. You are running alsa-driver-1.0.14rc1. Your system was added to alsa on 4/18 (by me - isn't that special) and was released in the alsa-driver-1.0.14rc4 snapshot.

You can do one of two things:

1. download and install alsa-driver-1.0.14rc4

2. try loading the module with "modprobe snd-hda-intel model=6stack-dig". If this works, you can add it to your modprobe.conf file in /etc as follows:

options snd-hda-intel model=6stack-dig

This is usually in /etc/modprobe.conf, but some distros are switching to a more modular config with /etc/modprobe.d/sound (for alsa).
 
Old 05-30-2007, 08:19 PM   #12
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Original Poster
Rep: Reputation: 81
Quote:
Originally Posted by GrueMaster
Just as I had expected. You are running alsa-driver-1.0.14rc1. Your system was added to alsa on 4/18 (by me - isn't that special) and was released in the alsa-driver-1.0.14rc4 snapshot.

You can do one of two things:

1. download and install alsa-driver-1.0.14rc4

2. try loading the module with "modprobe snd-hda-intel model=6stack-dig". If this works, you can add it to your modprobe.conf file in /etc as follows:

options snd-hda-intel model=6stack-dig

This is usually in /etc/modprobe.conf, but some distros are switching to a more modular config with /etc/modprobe.d/sound (for alsa).
I downloaded and compiled each one of these with ./configure, make, and make install.

alsa-driver-1.0.14rc4.tar.bz2
alsa-lib-1.0.14rc4.tar.bz2
alsa-utils-1.0.14rc4.tar.bz2

For the alsa-driver, I used the configure option ./configure --with-cards=hda-intel, but for the others, I didn't use any options while running configure. What options should I have used if any? After doing that, I rebooted and ran "modprobe snd-hda-intel model=6stack-dig". Now when I am using Skype, others can hear music being played with vlc and other sounds from my computer. That never happened before. I went through gnome-volume-control and alsamixer to make sure all mic volume settings were enabled and turned up all of the way. I also turned on mic boost. When I run vumeter, it freezes. Maybe that is because it is not getting sound from the mic when it tries. I should be able to hear myself through my speakers while talking on the micrphone, right?

Alsamixer gives me these options:

│ Card: HDA Intel │
│ Chip: Realtek ALC888 │
│ View: [Playback] Capture All │
│ Item: Input Source 1 [Front Mic]

and

┌─────────────────[AlsaMixer v1.0.14rc4 (Press Escape to quit)]────────────────┐
│ Card: HDA Intel │
│ Chip: Realtek ALC888 │
│ View: [Playback] Capture All │
│ Item: Input Source [Front Mic]

Should those be set to Microphone instead of Front Mic? I have 6 jacks on my sound card. Which one should the mic be plugged into? I've tried different ones but haven't got the mic working yet.
 
Old 05-30-2007, 08:24 PM   #13
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Original Poster
Rep: Reputation: 81
I don't know if this helps, but here is my /etc/modprobe.d/alsa-base.

Code:
mike@mike-desktop:~/Desktop/alsa-driver-1.0.14rc4$ cat /etc/modprobe.d/alsa-base 
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --Qb snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
mike@mike-desktop:~/Desktop/alsa-driver-1.0.14rc4$
 
Old 05-30-2007, 08:44 PM   #14
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
You should be able to mute the mux channel, the mixer, or one of the capture channels. One of these is causing your music output to route through your input channel. You can experiment with this in alsamixer.
 
Old 06-01-2007, 08:14 PM   #15
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Original Poster
Rep: Reputation: 81
The microphone still is not working. Should I be modprobing snd-hda-intel with a different model than 6stack-dig?
 
  


Reply

Tags
soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Realtek ALC883 onboard audio? cdrom600 Linux - Hardware 5 03-12-2010 08:10 AM
HDA Intel/Realtek microphone/line in very quiet format C: Linux - Hardware 1 02-20-2007 02:50 PM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 1 07-05-2006 11:13 PM
integrated hda audio modem bluetooth , (intel hda audio does not work) reggae linux Linux - Laptop and Netbook 2 07-05-2006 04:38 PM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration