LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   microphone, audacity, skype, recording (http://www.linuxquestions.org/questions/linux-hardware-18/microphone-audacity-skype-recording-663187/)

le1 08-16-2008 06:04 AM

microphone, audacity, skype, recording
 
I know that there is 10 000 people trying to fix the same problem as well and why would you try to help me instead of them? good question, but I'll try my luck anyway...

To cut the time here is what I've started to no avail:
http://forums.fedoraforum.org/showth...ght=microphone

I really do appreciate time developers put into making Linux (greatest OS ever!) but it would be really nice if "they" could come up with some sort of another brilliant idea to help people fully enjoy their multimedia experiences including microphone, camera etc...

ps. I also got rid of pulse in hope that this will solve my problem no luck neither...

Thanks for reading it.

GlennsPref 08-16-2008 11:42 PM

OK, can you show me the output of lsmod?

Does audacity play audio files?

Do you get any indication(flashing light bars) in the mic section of your sound mixer when you speak into the mic?

What kind of mic, cable and where is it plugged in to?

I did read all of the referenced post, although I run kde on mandriva linux we should be able to sort out something.

Check your syslog for errors,

See how you go, Glenn

Electro 08-17-2008 03:21 AM

At the terminal type "alsamixer -V all". Then in another terminal type "arecord | hexdump". Change the settings in alsamixer while arecord is recording sound. You should notice something changing while it is recording. If it does not change, keep on changing mixer settings until you see a change. Then press the combination CTL+C to stop arecord from recording. Test it in audacity and skype. They should work.

The problem with today's sound cards (well on-board sound) is most of them uses the snd-hda-intel module which have gone through tons of changes and the BIOS from the manufacture does not make it any easier too. A dedicated sound card such as Turtle Beach Santa Cruz and sound cards based on VIA ICE1712 or VIA ICE1724 are easy to setup audio recording.

If all else fails, update the kernel.

le1 08-18-2008 07:17 AM

Before we even start take a look at these: http://www.google.com/search?hl=en&q...ux&btnG=Search results on google.

Back to your questions:

Audacity plays audio files fine, check this:
[IMG=http://img152.imageshack.us/img152/9481/audii5.th.png]

"Do you get any indication(flashing light bars) in the mic section of your sound mixer when you speak into the mic?"
A: No

"What kind of mic, cable and where is it plugged in to?"
A: External mic plugged into jack-socket

I tried "Electro" advice as well but didn't work.

And i also found a great solution to my problem on google:

buy USB microphone http://www.logitech.com/index.cfm/bu...s/221&cl=gb,en that actually works with Linux [ thinking outside the box :) ]


If you still think we can make it work I'll paste output of: "/sbin/lsmod"

le1 08-18-2008 08:24 AM

...I was going through some feeds and I stumble on an interview
in which there was one question that kind of correlates with what I'm going through right now (and I believe it applies to most ditros):

"In your opinion. What is Ubuntu's greatest weakness?"

A: http://www.hardware.no/artikler/scot...nglish/54571/4

Electro 08-18-2008 05:05 PM

Use only OSS while recording in audacity for best results. My works just fine and yes my computer uses SigmaTel STAC9205 with ALSA version 1.0.15. I have to later amplify the recording to hear it. Any distribution that you try will have the same problem. The ALSA version depends on the kernel version used. Update the kernel if it does not work.

The greatest weakness of Linux is Windows users expecting the distribution that they pick will do the work for them. Sure Linux is free as in money, but it costs time and patience to set hardware and programs up. I recommend Gentoo or Arch to find out what I mean.

Do not let the desktop or window manager handle audio.

In alsamixer select the input for capture by using the space bar and make sure it is unmuted.

Running alsamixer -V all in one terminal and arecord | hexdump in another should work. It is a trial-n-error that always works for me with any sound card.

Sure you can go with the route that forces you to buy a USB microphone. Sooner or later, you are back to the same problem. The problem then becomes worst since there will be two sound cards.

Yes, it will help to have a list of modules using /sbin/lsmod and the print out from amixer.

BTW, your image is not helpful because it is very hard to make out what it is showing.

le1 08-18-2008 07:12 PM

Linux is great and we all know that.

"uname -r":

2.6.25.14-108

"amixer":

Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 65536 [100%] [on]
Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 65536 [100%] [on]
Front Right: Capture 65536 [100%] [on]

"/sbin/lsmod":

aes_i586 11648 2
aes_generic 30888 1 aes_i586
bridge 46104 0
bnep 14592 2
rfcomm 34576 4
l2cap 22272 16 bnep,rfcomm
fuse 41116 3
sunrpc 151412 3
ipt_REJECT 6784 2
nf_conntrack_ipv4 11396 2
iptable_filter 6528 1
ip_tables 13840 1 iptable_filter
ip6t_REJECT 7552 2
xt_tcpudp 6656 2
nf_conntrack_ipv6 15992 2
xt_state 5888 4
nf_conntrack 49748 3 nf_conntrack_ipv4,nf_conntrack_ipv6,xt_state
ip6table_filter 6400 1
ip6_tables 14736 1 ip6table_filter
x_tables 15236 6 ipt_REJECT,ip_tables,ip6t_REJECT,xt_tcpudp,xt_state,ip6_tables
cpufreq_ondemand 10124 2
acpi_cpufreq 11532 0
dm_mirror 26116 0
dm_multipath 18056 0
dm_mod 49236 2 dm_mirror,dm_multipath
ipv6 221660 16 ip6t_REJECT,nf_conntrack_ipv6
snd_hda_intel 336928 5
snd_seq_dummy 6660 0
snd_seq_oss 30364 0
snd_seq_midi_event 9600 1 snd_seq_oss
snd_seq 48448 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
sr_mod 17064 0
snd_seq_device 10124 3 snd_seq_dummy,snd_seq_oss,snd_seq
cdrom 32796 1 sr_mod
snd_pcm_oss 42496 0
snd_mixer_oss 16768 3 snd_pcm_oss
snd_pcm 67076 2 snd_hda_intel,snd_pcm_oss
snd_timer 21640 2 snd_seq,snd_pcm
firewire_ohci 21636 0
snd_page_alloc 11400 2 snd_hda_intel,snd_pcm
pata_acpi 8320 0
firewire_core 34464 1 firewire_ohci
snd_hwdep 10500 1 snd_hda_intel
hci_usb 16284 2
tifm_7xx1 9088 0
arc4 5760 2
yenta_socket 24716 1
i915 85764 2
snd 48312 16 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer,snd_hwdep
ata_generic 9092 0
rsrc_nonstatic 13696 1 yenta_socket
pcspkr 6272 0
tifm_core 10396 1 tifm_7xx1
video 20368 0
bluetooth 47588 8 bnep,rfcomm,l2cap,hci_usb
iTCO_wdt 13476 0
ecb 6528 2
crypto_blkcipher 18052 1 ecb
crc_itu_t 5760 1 firewire_core
iwl3945 146012 0
rfkill 11288 2 iwl3945
mac80211 181480 1 iwl3945
battery 14084 0
cfg80211 24968 2 iwl3945,mac80211
drm 145508 3 i915
button 10000 0
i2c_algo_bit 8964 1 i915
iTCO_vendor_support 6916 1 iTCO_wdt
ac 8068 0
sky2 41220 0
joydev 12608 0
output 6656 1 video
soundcore 9288 3 snd
ata_piix 20228 0
i2c_i801 11920 0
i2c_core 20628 4 i915,drm,i2c_algo_bit,i2c_i801
sg 31028 0
ahci 26760 4
libata 127328 4 pata_acpi,ata_generic,ata_piix,ahci
sd_mod 25624 5
scsi_mod 120948 4 sr_mod,sg,libata,sd_mod
ext3 108552 3
jbd 40980 1 ext3
mbcache 10116 1 ext3
uhci_hcd 22928 0
ohci_hcd 22404 0
ehci_hcd 32268 0

"Running alsamixer -V all in one terminal and arecord | hexdump in another should work. It is a trial-n-error that always works for me with any sound card."

A: I did try it as you advised in first reply but it didn't work

http://www.alsa-project.org/main/ind...stac9250&go=Go

I've got alsa-driver-1.0.17-70

Electro 08-18-2008 11:26 PM

You should have something similar to the following after running amixer.

Code:

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 118 [93%]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 225 [88%] [-6.00dB]
  Front Right: Playback 225 [88%] [-6.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control 'Analog Loopback',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]
Simple mixer control 'Digital Input Source',0
  Capabilities: enum
  Items: 'Analog Inputs' 'Digital Mic 1'
  Item0: 'Digital Mic 1'
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic'
  Item0: 'Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Mic'
  Item0: 'Mic'
Simple mixer control 'Mux',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 4
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'Mux',1
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 4
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]

I think it detected the wrong model for your sound card. You will have to specify a model. To do this you have to add the following in /etc/modules.conf or /etc/modules.d. The file depends on the distribution and some distributions require a utility to be run after making changes.

options snd-hda-intel model=

You can find the list of model for snd-hda-intel in /usr/src/linux-`uname -r`/Documentation/sound/alsa/ALSA-Configuration.txt.

le1 08-19-2008 06:02 AM

/etc/modules.conf & /etc/modules.d are not there but I found /etc/modprobe.d

and there's file called "modprobe.conf.dist". Is this what I should work with ?

In ALSA-Configuration.txt there is:

STAC9202/9250/9251, and "m6" looks like what I have.

Should I paste snd-hda-intel model=m6 into "modprobe.conf.dist" or that's the wrong file ?

fedora9

Electro 08-19-2008 08:13 PM

I suggest as root type "modprobe -r snd-hda-intel". Then type "modprobe snd-hda-intel model=m6". This should give a sense if it is the correct model. If it is not, repeat by removing the module and loading it up. When you got the correct model, you can then add to the file that loads that module up with the options. I am not sure that modprobe.conf.dist is the correct file. Check your distribution's documentation.

Again it is "options snd-hda-intel model=XXXX" not "snd-hda-intel model=XXXX".

le1 08-21-2008 08:28 AM

The good news is that i got back to ubuntu.

The bad news is that after typing in terminal "modprobe snd-hda-intel model=m6" sound disappear and nothing works.


All times are GMT -5. The time now is 11:25 PM.