LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Mic problem. Mic bar missing in alsaconf (http://www.linuxquestions.org/questions/linux-hardware-18/mic-problem-mic-bar-missing-in-alsaconf-696842/)

rengo.Java 01-12-2009 05:05 PM

Mic problem. Mic bar missing in alsaconf
 
Hi all!

I cant do my mic works.
I have an Slackware 12.2 with kernel 2.6.28, the sound is working fine, but the mic dont record a sound.

In alsamix, in the capture view, i had: Mic Boos, Capture, Digital and Internal, each with its own level bar setted to maxim.
But the Mic, Mix and Docking has no bar.
I set CAPTUR in the Capture bar and the Mic bar (although it has no level bar).
When I record sounds with arecord, it records horrible sounds, not my voice.

This is the sound kernel configuration:

Code:

CONFIG_SND=y
CONFIG_SND_TIMER=y
CONFIG_SND_PCM=y
CONFIG_SND_HWDEP=y
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_DRIVERS=y
CONFIG_SND_PCI=y
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_ATIHDMI=y
CONFIG_SND_HDA_CODEC_NVHDMI=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y

And this is my card

Code:

Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Any ideas how to make to the Mic bar appears??

Thanks!

onebuck 01-12-2009 06:23 PM

Hi,

You did run 'alsaconf' initially and then 'alsamixer' to setup the interface settings? You should then do a 'alsactl store' to save the settings.

rengo.Java 01-24-2009 06:34 AM

Hi onebuck

when I run alsaconf i get this message:
Code:

No supported PnP or PCI card found.
its rare because the sound card works fine (only the mic is not working)
is this causing the microphone problem?

Thanks!

Shadow_7 01-24-2009 04:19 PM

$ cat /proc/asound/cards

$ lsmod

$ amixer

You might not be defaulting (0) to the card that you think you are. Also in alsamixer, you have to press tab at least once to get to the mic / capture / recording levels, as it defaults to playback channels only. Also bear in mind that it might be a rose by another name. capture, adc, mic, ...???

HTH

rengo.Java 02-15-2009 06:02 PM

Ok, here I go:

# cat /proc/asound/card
Code:

cat: /proc/asound/card: No such file or directory
root@notebook:rc.d# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xe8580000 irq 21

#lsmod
Code:

Module                  Size  Used by
tun                    9732  0
snd_seq_dummy          2692  0
snd_seq_oss            25884  0
snd_seq_midi_event      5760  1 snd_seq_oss
snd_seq                41024  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5900  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            33408  0
snd_mixer_oss          12672  1 snd_pcm_oss
iwl3945              131808  0
fan                    4484  0
ohci1394              25648  0
rfkill                  9136  2 iwl3945
ieee1394              66752  1 ohci1394
tifm_7xx1              5376  0
mac80211              128288  1 iwl3945
tifm_core              6428  1 tifm_7xx1
thermal                15644  0
processor              40620  1 thermal
battery                10244  0
button                  6288  0
usbmouse                3968  0
ac                      4228  0

#amixer
Code:

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 63
  Mono:
  Front Left: Playback 51 [81%] [-15.00dB] [on]
  Front Right: Playback 51 [81%] [-15.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 29 [94%] [9.00dB] [on]
  Front Right: Playback 29 [94%] [9.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%]
  Front Right: 3 [100%]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [22.50dB] [on]
  Front Right: Capture 15 [100%] [22.50dB] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Caller ID',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]
Simple mixer control 'Docking-Station',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%]
  Front Right: 3 [100%]
Simple mixer control 'Off-hook',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

In alsamixer I have selected to capture the "Capture" and "Mic" columns, but the "Mic" have not the volume bar...

Thanks for your help...


All times are GMT -5. The time now is 06:07 AM.