LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-25-2012, 01:48 PM   #1
gumb
LQ Newbie
 
Registered: Oct 2005
Distribution: openSUSE
Posts: 27

Rep: Reputation: 15
Mic not recognised by PulseAudio (for Skype)


I desperately need to put the last piece of a jigsaw in place for the audio setup on my parents' PC before I leave it with them for another few months. I've finally got everything set up the way I've been trying to do it for years but with just one hitch, and most of my Christmas Day has been stolen already fiddling with this.

Scenario: Running openSUSE 12.2, KDE with Gstreamer Phonon backend and PulseAudio enabled. Two sound devices on the system - the on-chip Intel ICH as default for everything and a USB FM transmitter so that when my dad listens to his music collection in Clementine the sound goes to his hifi speakers. The only problem now is that Skype calls are not possible as the microphone isn't recognised anywhere in PulseAudio.

It's the USB webcam microphone, which has a separate audio input in the standard mic jack of the PC. In neither pavucontrol, nor the Veromix KDE plasmoid I'm using as a mixer, nor in the regular KMix mixer panel is the mic visible as an input source. However, it will record if I go into Audacity. Also, if I disable PulseAudio and reboot, the mic works fine including with Skype (problem there is that I can't find a way to channel just music to the hifi speakers without PulseAudio - the Phonon settings don't work and neither does choosing a specific output within Clementine).

I've checked all the Alsamixer levels and reapplied the mic boost and capture volumes each time after enabling/disabling PulseAudio. It appears this problem may be known - this post on the Fedora forums seems related but the fix doesn't work for me. I enabled the following line in the /etc/pulse/default.pa file:
Code:
load-module module-alsa-source device=hw:1,0
but on reboot the system starts up using ALSA and not PulseAudio.

I'm lost!
 
Old 12-26-2012, 09:04 AM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
Pulseaudio can be stopped / started at the user level.

$ pulseaudio --kill
$ pulseaudio --start

So no need to reboot. A lot of configurations are set to auto spawn pulseaudio when it is not running. Adding "autospawn = no" (or changing it) in /etc/pulse/client.conf should allow you to selectively not use pulse audio. While still retaining the option from the above user commands.

Pulse is a bit quirky still. I've had to add a number of things for my ice1712 (delta 44) setup. To include a udev entry, /usr/share/pulseaudio/alsa-mixer/profile-sets/ customization, and probably something else I can't recall off the top of my head. Although teamspeak 3 works fine for me with my setup and an odd mic location (input 3). I have yet to use skype, but I'm not a phone person.

With the autospawn disabled, I can stop pulse and run other audio applications that run over jack without the usual performance hit of using pulse over jack. It just takes a bit of user awareness to remember this option and to check ps output when in doubt. I'd recommend using pulse as common things are likely compiled against it like openjdk, with various quirks if you do not use pulse.
 
Old 12-26-2012, 09:53 AM   #3
gumb
LQ Newbie
 
Registered: Oct 2005
Distribution: openSUSE
Posts: 27

Original Poster
Rep: Reputation: 15
Hi. Thanks for responding. Looks like I've just stumbled upon the solution and it was something silly. Put it down to my lack of knowledge with PulseAudio and audio routing. I've always yanked it off every system to date because I don't like the dynamic mixer controls and it used to cause other problems, but now it's doing what I always hoped it would - manage two separate audio outputs and let me channel certain programs to one or the other. It's just not very obvious to non-sound-technicians how to do that.

The fix: I hadn't set the Internal Audio to Analog Stereo Duplex, which can be done from the Input tab of pavucontrol and other places. I'd had it set as Output only, hence the microphone didn't show up anywhere. All seems to be working fine now, including Skype. Just hope all the settings and volume levels stay intact for a few months and a few hundred reboots, until my next visit!
 
  


Reply

Tags
input, mic, pulseaudio, record, skype


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] F13. Mic not working. Skype 2.1 Beta. Pulseaudio. Alsamixer. 1337.HDLA Linux - Hardware 4 10-15-2010 01:25 PM
[SOLVED] Mic works, but doesn't record on Slackware 13 + Pulseaudio woes Ahmed Slackware 22 09-12-2009 01:16 PM
USB Sound (Mic) not working in Fedora 9 pulseaudio MikeyCarter Linux - Software 0 07-30-2008 11:01 AM
pulseaudio +Mic problems setlec_seta Mandriva 4 06-08-2008 07:07 PM
extra ports for speakers and mic not recognised roshan_singh Linux - Laptop and Netbook 1 09-20-2007 12:13 PM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration