LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 06-10-2010, 05:08 PM   #1
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Rep: Reputation: 1
Mic is not recognized using card [HDA NVidia] VT1708S Analog in ubuntu 10.04 or 8.04


Thnk you for your time in advance:
what I did, I followed this link that is: http://ubuntuforums.org/showthread.p...10#post6589810
step 1,
I tried to toggle the 'input source' in alsamixer:
see my .png
I have two options:
Front mic and Line,
tried to select Line and check it using sound recorder; result: beep
toggled again to 'Front mic' and check it using sound recorder; result: beep

step 2,
uninstall alsa-backports; I do not know if I have them, either how to chek it, but I tried the following in terminal:
sudo apt-get purge linux-backports-modules-alsa-lucid-generic:
Sudo says is not installed so it cannot be removed, so trying again with the upgrading.

Closing all programs that can need the alsa (ekiga, sound recorder, pidgin, leaving only openoffice, firefox (without music for your post) omegaT) and running the script

step 3,
download the script and save it somewhere
2. cd <your-download-dir>
3. tar xvf AlsaUpgrade-1.0.23-2.tar
4. sudo ./AlsaUpgrade-1.0.23-2.sh -d
5. sudo ./AlsaUpgrade-1.0.23-2.sh -c
6. sudo ./AlsaUpgrade-1.0.23-2.sh -i
7. sudo shutdown -r 0

step 4 checking the version
cat /proc/asound/version:
Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on Jun 10 2010 for kernel 2.6.32-22-generic (SMP).

step5 testing aplay
speaker-test -Dplughw:0,0 -c2: test OK

step 6, multiples checking:
check if your alsamixer-channels are activated and unmuted (gnome-mixer/volume-control/preferences)!! :
see in my .png that nothing is unmuted


step 7, /etc/modprobe.d/alsa-base.conf:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbi$
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-os$
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mi$
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-mi$
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist sn$
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist sn$
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist sn$

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-al$
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2

step 8, as it seems that the line options snd-hda is missing I will added manually

step 9, searching model hda using the following command:
cat /proc/asound/card0/codec#* | grep Codec:
Codec: VIA VT1708S

cat /proc/asound/card0/pcm0c/info:
card: 0
device: 0
subdevice: 0
stream: CAPTURE
id: VT1708S Analog
name: VT1708S Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 2
subdevices_avail: 2

step 10, waiting for help:
As this model "VIA VT1708S" is not present in HD-Audio-Models.txt do not know what to add and I am stopped,


Found in here http://ubuntuforums.org/showthread.p...nsaver+working
the output necessary to check issues. here it is:
uname -a:
Linux ignacio-desktop 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux

aplay -l
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: NVidia [HDA NVidia], dispositivo 0: VT1708S Analog [VT1708S Analog]
Subdispositivos: 2/2
Subdispositivo #0: subdevice #0
Subdispositivo #1: subdevice #1
cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on Jun 10 2010 for kernel 2.6.32-22-generic (SMP).

head -n 1 /proc/asound/card*/codec#*
Codec: VIA VT1708S

please, can you help me further to find out which model should add to my /etc/modprobe.d/alsa-base.conf.
Thanks in advance,
 
Old 06-16-2010, 06:16 AM   #2
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Original Poster
Rep: Reputation: 1
I am including more information as it was recommended to me in an automatic mail
It seems I have already installed gnome-alsamixer.
I tried the following
in terminal typed gnome-alsamixer: see .png
the front mic is muted, and the input source is blank
so I tried to check the input source with this result:
** (gnome-alsamixer:4028): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Independent HP"!

** (gnome-alsamixer:4028): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!

** (gnome-alsamixer:4028): WARNING **: gam_toggle_get_state (). No idea what to do for mixer element "Input Source"!

** (gnome-alsamixer:4028): WARNING **: gam_toggle_set_state (). No idea what to do for mixer element "Input Source"!

and tried to unmute the front mic:
trying with sound recorder and ... nothing
checked also pavucontrol: see my .png

I am including another 2 .png:
1) pavucontrolnotdetectinginputsoundrecorder.png
2) pavucontroldetectingoutputsoundrecorder.png

When I record usign sound recorder, the seconds move and everything looks as it were recorded, but the output is a beep. If I kill pulseaudio, then I cannot record or play using soundrecorder.

If I record using audacity, the second move and everything looks as it were recorded, but the ouput is silence.

Please, can you give me more hints?
 
Old 10-05-2010, 06:27 PM   #3
matti3
LQ Newbie
 
Registered: Nov 2007
Location: Belgium
Distribution: openSUSE 11.4, opensuse 12.1
Posts: 15

Rep: Reputation: 0
i also had trouble getting my mic to work with this chipset. Turned out I had to "mute" the "smart 5.1" option in the mixer
 
Old 10-06-2010, 03:47 PM   #4
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Dear Matti3,
I had surfed the net and others solve the question the same way than you. However I cannot find the "smart 5.1" in the alsamixer. I am sending you a .png of my alsamixer, can you check it and tell m how to "mute" it?
I guess that there is something to do in a config file, would you please specify step by step what to do?
Than you in advance
Attached Images
File Type: png alsamixer 0610.2010.png (70.3 KB, 9 views)
 
Old 12-03-2010, 01:54 PM   #5
matti3
LQ Newbie
 
Registered: Nov 2007
Location: Belgium
Distribution: openSUSE 11.4, opensuse 12.1
Posts: 15

Rep: Reputation: 0
hi, sorry for the late response. Just use the arrowkeys (left/right) to scroll through the different items. The Smart 5.1 control is located at the far right
alsamixer_smart5.1.png.
 
Old 12-05-2010, 08:08 AM   #6
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Dear Matti3,
thank you for your response, unfortunately, there is no SMART 5.1 in my CHIP; you have a NCP77/78 HDMI and I have a VT1708S. if you see my .png, the last element when you scrolled all the way to the right is the Input Source: I have 3 options: Line, Stereo Mixer and Mic, I have selected this last one.
Can you still help me?
Attached Images
File Type: png alsa mixer 0512 input source.png (63.4 KB, 5 views)
 
Old 12-05-2010, 08:38 AM   #7
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You may have better results if you change from Alsa to Jack.
http://jackaudio.org/
 
Old 12-05-2010, 01:12 PM   #8
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Dear Stress Jukie,
thank you for your advice, I will try, can you tell me if it is proved to work with my chip: VT1708S?
 
Old 12-19-2010, 10:15 AM   #9
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Dear linux user,
I finaly found the answer in http://ubuntuforums.org/showthread.php?t=1504904
the 'front mic' is still not working, but the back mic, also called only 'mic' is working.
so the mic is recognized using this card hda-nvidia-vt1708s in-ubuntu-10-04 and this post is solved.
the solution is:
1) use your 'mic' and not your 'front mic'
2) use your controls to get the correct levels, you can see more in the link of ubuntuforums above.
3) I will answer any user with the same problem in order to get the capture working.
 
Old 12-19-2010, 10:16 AM   #10
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Thank you for posting the answer.
 
Old 01-19-2011, 11:44 AM   #11
translator1111
Member
 
Registered: Jun 2010
Location: Slovakia
Distribution: Ubuntu 11.04; SLAX 6.0; ConnochaetOS 0.9. Natty chip: VT1708S
Posts: 33
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by stress_junkie View Post
Thank you for posting the answer.
Dear Junkie,
I am not sure if you want me to clarify the answer, I will:
the problem was solved the following way:
Code:
alsamixer
in alsamixer > playback > all "mics" has to be "muted"> use "M"
in Sytem>Pereferences>Sound>imput> clik to the "shield" *this will free the slides" scrolled one of them all the way to zero and you will have a "mic" capture with "mono"

If anybody need a more specific explanation. I will be glad to help.
Stara Posta
 
  


Reply

Tags
alsa, mic


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 8.10 audio drivers for via vt1708s? Lord Xeb Linux - Hardware 2 01-15-2009 07:21 AM
[SOLVED] HDA NVIDIA ALC883 Analog sound error messages mbvpixies78 Linux - Newbie 2 05-27-2008 09:21 AM
Analog Headset - Mic Is Not Working. Think_UNIX Linux - Hardware 1 09-27-2007 02:21 PM
No mic on alsa (hda-intel) hoofer Linux - Hardware 3 06-05-2007 01:36 PM
ran ubuntu updates, now Nvidia driver not recognized Daninchina Ubuntu 4 05-28-2005 10:47 PM


All times are GMT -5. The time now is 04:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration