LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-23-2006, 02:09 PM   #1
ryale138
LQ Newbie
 
Registered: May 2006
Posts: 7

Rep: Reputation: 0
Matrox G400 Dual Head Config


Just a question. I have installed Suse 10.0 and xurrently am running a GNOME desktop (although I'm going to switch to KDE when i resolve this problem). I have a Matrox Millenium G400 Dual Head Max video card, and I need to setup up a dual display (much like the behavior in WinXP).

YaST2 makes no mention of this in the configuration settings (doesn't even recognize a second monitor).

So, I know I need to edit my xorg.conf file, and I've looked all over LQ for the information I need, but it seems everytime I edit the xorg.conf file, something is wrong, and X cannot load. So I'm posting my xorg.conf file here in hopes that someone can walk me through the necessary changes I need to make. Thanks a Million!


# /.../
# SaX generated X11 config file
# Created on: 2006-05-23T14:54:13-0600.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Logitech Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 320 240
HorizSync 28-70
Identifier "Monitor[0]"
ModelName "FS740 COLOR MONITOR"
Option "DPMS"
VendorName "COMPAQ"
VertRefresh 50-120
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1152x864" 93.90 1152 1192 1312 1536 864 865 868 899
Modeline "1024x768" 86.18 1024 1088 1200 1376 768 769 772 803
Modeline "1024x768" 73.89 1024 1080 1192 1360 768 769 772 799
Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
Modeline "800x600" 73.98 800 848 936 1072 600 601 604 639
Modeline "800x600" 66.71 800 848 936 1072 600 601 604 635
Modeline "800x600" 58.73 800 840 928 1056 600 601 604 632
Modeline "800x600" 51.73 800 840 928 1056 600 601 604 628
Modeline "800x600" 44.13 800 840 920 1040 600 601 604 624
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "768x576" 67.79 768 816 896 1024 576 577 580 613
Modeline "768x576" 61.21 768 816 896 1024 576 577 580 610
Modeline "768x576" 53.75 768 808 888 1008 576 577 580 606
Modeline "768x576" 47.41 768 808 888 1008 576 577 580 603
Modeline "768x576" 40.41 768 800 880 992 576 577 580 599
Modeline "768x576" 33.74 768 792 872 976 576 577 580 596
Modeline "640x480" 51.43 640 680 744 848 480 481 484 514
Modeline "640x480" 46.80 640 680 744 848 480 481 484 511
Modeline "640x480" 42.22 640 680 744 848 480 481 484 508
Modeline "640x480" 36.97 640 672 736 832 480 481 484 505
Modeline "640x480" 32.64 640 672 736 832 480 481 484 503
Modeline "640x480" 27.74 640 664 728 816 480 481 484 500
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "MGA G400 AGP"
BusID "1:0:0"
Driver "mga"
Identifier "Device[0]"
Screen 0
VendorName "Matrox"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
 
Old 05-28-2006, 10:26 PM   #2
dutler
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Rep: Reputation: 15
ryale138,
I am havering simular troubles and we even have the same compaq mon....

First, does SuSE 10.x have the right Matrox driver? It should right, its SuSE....
Second, do you want separate displays or a shared frambuffer?
Last, does the the error say when you tried to start x from the cmd line via "startx" ?

I have mine working long time ago with debian, but just installed SuSE 10.1 ... man i wish i would have remembered to bkup the xorg.conf. One thing I remember is that I had to have two separate devices even though only one G400 adapter. They were identical with the same BusID except they had BoardName "G400_01" and G400_02"

Something to look at would be the sample files found in the Matrox Linux driver download: http://matrox.com/mga/support/drivers/files/lnx_43.cfm

br / dutler

ps im a newb, should i post my problem that is the same but differnt in this thread or should i start another?
 
Old 05-28-2006, 11:07 PM   #3
sleepindawg
Member
 
Registered: Aug 2003
Location: Kansas... USA
Distribution: Mandrake10 Offical, Debian Sarge, Knoppix, GO Ubuntu!!! my new home
Posts: 79

Rep: Reputation: 15
dunno if this will help you or not, but here is my config gile from my mandy install w/two monitors............. file as follows.... oh yeah, i am running two video cards as well.


# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't
work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor0"
VendorName "Samsung"
ModelName "Samsung SyncMaster 21GLs" (notice this section)
HorizSync 30.0-82.0
VertRefresh 50.0-120.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync
-vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Acer"
ModelName "Acer 56e" (notice this section)
HorizSync 30.0-69.0
VertRefresh 50.0-110.0

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync
-vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device0"
BoardName "NVIDIA GeForce4 (generic)" (notice this section)
Driver "nv"
BusID "PCI:0:11:0"
Option "DPMS"
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation" (notice this section)
BoardName "RIVA TNT2"
Driver "nv"
BusID "PCI:1:0:0"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen0"
Device "device0" (notice this section)
Monitor "monitor0"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "Screen"
Identifier "screen1"
Device "device1" (notice this section)
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 15
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 16
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 24
Virtual 800 600
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout2"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen0" 0 0 (this line)
Screen "screen1" Rightof "screen0" (this line)
Option "Xinerama" "On" (espically this line)
EndSection

Last edited by sleepindawg; 05-28-2006 at 11:09 PM.
 
Old 05-30-2006, 12:07 PM   #4
ryale138
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
sleepindawg

thanks for the the post! Haven't gottan a chance to see if it'll help me but when I do, I will let you know.

Actually, I downloaded the new latest drivers from matrox and installed them. (Now I get this HORRIBLE garbbled crap when I run init 3, but init 5 is running great...go figure!) I looked that those sample files that came with the drivers, and they told me what I need to accomplish, but not quite how to do it. (I don't know any of this coding...yet).

I want a system that spans the width of the two monitors. (Like when you run a dual monitor setup in WinXP). Unlike you, I'm running a card with two outputs on it, single card with two output heads on it. But I'll keep in touch
thanks again
 
Old 05-30-2006, 11:08 PM   #5
dutler
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Rep: Reputation: 15
For "spaning" you need
Quote:
Section "ServerFlags"
Option "Xinerama" "on"
EndSection
http://en.wikipedia.org/wiki/Xinerama

The will put all screens in to one framebuffer. your monitors will all need to run the same resilution.

here is my current xorg.conf that i am using in kubuntu with Xinerama and a G400. The matrox card has its onwe "MergedFB" (see screen[3]) option... maybe I play with it some more later.

I would like to get my #9 card to work. it seems to be the sorce of many of my troubles.
Quote:
Section "ServerFlags"
Option "Xinerama" "on"
EndSection

#Section "ServerLayout"
# Identifier "TriHead"
# Screen "Screen[0]" LeftOf "Screen[1]"
# Screen "Screen[1]" LeftOf "Screen[2]"
# Screen "Screen[2]"
# InputDevice "Keyboard[0]"
# InputDevice "Mouse[0]"
#EndSection

Section "ServerLayout"
Identifier "DualHead"
Screen "Screen[0]" LeftOf "Screen[1]"
Screen "Screen[1]"
InputDevice "Keyboard[0]"
InputDevice "Mouse[0]"
EndSection

#Section "ServerLayout"
# Identifier "DualMerged"
# Screen "Screen[3]"
# InputDevice "Keyboard[0]"
# InputDevice "Mouse[0]"
#EndSection

Section "ServerLayout"
Identifier "PrimaryHeadLayout"
Screen "Screen[0]"
InputDevice "Keyboard[0]"
InputDevice "Mouse[0]"
EndSection

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "il28"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse[0]"
Driver "mouse"
Option "CorePointer"
Option "Buttons" "10"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
BoardName "Matrox Graphics, Inc. MGA G400 AGP"
BusID "PCI:1:0:0"
Driver "mga"
Identifier "G400_01"
Screen 0
VendorName "Matrox"
Option "MGASDRAM"
EndSection

Section "Device"
BoardName "Matrox Graphics, Inc. MGA G400 AGP"
BusID "PCI:1:0:0"
Driver "mga"
Identifier "G400_02"
Screen 1
VendorName "Matrox"
Option "MGASDRAM"
EndSection

Section "Device"
BoardName "Imagine 128-II"
BusID "PCI:2:09:0"
Driver "i128"
Identifier "#9"
Screen 2
VendorName "Number 9"
EndSection

# Compaq FS740
Section "Monitor"
DisplaySize 345 259
HorizSync 30-70
Identifier "Compaq"
ModelName "FS740"
Option "DPMS"
VendorName "COMPAQ"
VertRefresh 50-120
UseModes "Modes[0]"
EndSection

# Dell D1728
Section "Monitor"
DisplaySize 300 281
HorizSync 30-64
Identifier "Dell"
ModelName "D1728"
VendorName "Dell"
VertRefresh 50-100
UseModes "Modes[1]"
EndSection

# eMachine 17F3
Section "Monitor"
DisplaySize 305 228
HorizSync 30-70
Identifier "eMachine"
ModelName "17F3"
VendorName "eMachine"
VertRefresh 50-160
UseModes "Modes[1]"
EndSection

# Dell D1728
Section "Modes"
Identifier "Modes[1]"
# V-freq: 60.00 Hz // h-freq: 63.73 KHz
#Modeline "1280x1024" 109.62 1280 1336 1472 1720 1024 1024 1026 1062
# V-freq: 42.70 Hz // h-freq: 44.87 KHz
Modeline "1280x1024" 70.00 1280 1320 1408 1560 1024 1024 1026 1050
EndSection

# Compaq FS740
Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 121.35 1280 1368 1504 1728 1024 1025 1028 1064
Modeline "1152x864" 107.91 1152 1224 1352 1552 864 865 868 903
Modeline "1152x864" 106.51 1152 1224 1352 1552 864 865 868 903
Modeline "1152x864" 104.99 1152 1224 1352 1552 864 865 868 902
Modeline "1024x768" 76.16 1024 1080 1192 1360 768 769 772 800
Modeline "1024x768" 96.73 1024 1088 1200 1376 768 769 772 808
Modeline "1024x768" 95.50 1024 1088 1200 1376 768 769 772 807
Modeline "1024x768" 94.39 1024 1088 1200 1376 768 769 772 807
Modeline "800x600" 75.47 800 848 936 1072 600 601 604 640
Modeline "800x600" 74.67 800 848 936 1072 600 601 604 639
Modeline "800x600" 73.98 800 848 936 1072 600 601 604 639
Modeline "800x600" 45.50 800 840 920 1040 600 601 604 625
EndSection


Section "Screen"
Identifier "Screen[0]"
Device "G400_01"
Monitor "Compaq"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen[1]"
Device "G400_02"
Monitor "Dell"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen[2]"
Device "#9"
Monitor "eMachine"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen[3]"
Device "G400_01"
Monitor "Compaq"
DefaultDepth 24

Option "Monitor2Position" "RightOf"
Option "MergedFB" "on"
Option "MetaModes" "1024x768-1024x768"
Option "Monitor2HSync" "30.0 - 133.0"
Option "Monitor2VRefresh" "50.0 - 85.0"

SubSection "Display"
Virtual 2048 768
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection

SubSection "Display"
Virtual 2048 768
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 06-07-2006, 12:41 AM   #6
ryale138
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Well guys,
Just wanted to write you and say thanks for all the help you've given me. After many tries, (and many, many hours of frustration) I now have a working xorg.conf file...
Here it is for those that it may benefit...

Quote:
# /.../
# SaX generated X11 config file
# Created on: 2006-06-06T00:14:09-0600.
# Modified on: 2006-05-06
# Modified by: Alex Smith
# Setups a dual display setup for SuSE 10.0
# using Compaq FS740, and IBM G54 for monitors.
# /.../

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Logitech Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 320 240
HorizSync 28-70
Identifier "Monitor[0]"
ModelName "FS740 COLOR MONITOR"
Option "DPMS"
VendorName "COMPAQ"
VertRefresh 50-120
UseModes "Modes[0]"
EndSection

Section "Monitor"
DisplaySize 320 240
HorizSync 28-70
Identifier "Monitor[1]"
ModelName "IBM G54"
Option "DPMS"
VendorName "IBM"
VertRefresh 50-60
UseModes "Modes[1]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1152x864" 93.90 1152 1192 1312 1536 864 865 868 899
Modeline "1024x768" 86.18 1024 1088 1200 1376 768 769 772 803
Modeline "1024x768" 73.89 1024 1080 1192 1360 768 769 772 799
Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
Modeline "800x600" 73.98 800 848 936 1072 600 601 604 639
Modeline "800x600" 66.71 800 848 936 1072 600 601 604 635
Modeline "800x600" 58.73 800 840 928 1056 600 601 604 632
Modeline "800x600" 51.73 800 840 928 1056 600 601 604 628
Modeline "800x600" 44.13 800 840 920 1040 600 601 604 624
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "768x576" 67.79 768 816 896 1024 576 577 580 613
Modeline "768x576" 61.21 768 816 896 1024 576 577 580 610
Modeline "768x576" 53.75 768 808 888 1008 576 577 580 606
Modeline "768x576" 47.41 768 808 888 1008 576 577 580 603
Modeline "768x576" 40.41 768 800 880 992 576 577 580 599
Modeline "768x576" 33.74 768 792 872 976 576 577 580 596
Modeline "640x480" 51.43 640 680 744 848 480 481 484 514
Modeline "640x480" 46.80 640 680 744 848 480 481 484 511
Modeline "640x480" 42.22 640 680 744 848 480 481 484 508
Modeline "640x480" 36.97 640 672 736 832 480 481 484 505
Modeline "640x480" 32.64 640 672 736 832 480 481 484 503
Modeline "640x480" 27.74 640 664 728 816 480 481 484 500
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
EndSection

Section "Modes"
Identifier "Modes[1]"
Modeline "1152x864" 78.82 1152 1152 1272 1472 864 865 868 894
Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "768x576" 33.74 768 792 872 976 576 577 580 596
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[1]"
Identifier "Screen[1]"
Monitor "Monitor[1]"
EndSection

Section "Device"
BoardName "MGA G400 AGP"
BusID "1:0:0"
Driver "mga"
Identifier "Device[0]"
Screen 0
VendorName "Matrox"
EndSection

Section "Device"
BoardName "MGA G400 AGP"
BusID "1:0:0"
Driver "mga"
Identifier "Device[1]"
Screen 1
VendorName "Matrox"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "on"
Screen "Screen[0]"
Screen "Screen[1]" RightOf "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
Thanks once again guys!
 
Old 09-07-2006, 09:25 PM   #7
sleepindawg
Member
 
Registered: Aug 2003
Location: Kansas... USA
Distribution: Mandrake10 Offical, Debian Sarge, Knoppix, GO Ubuntu!!! my new home
Posts: 79

Rep: Reputation: 15
Glad you got it all worked out. Sorry about the hiatus. Welcome to the wonderful world of Linux! It IS satisfying.
 
Old 09-08-2006, 09:12 AM   #8
ryale138
LQ Newbie
 
Registered: May 2006
Posts: 7

Original Poster
Rep: Reputation: 0
sleepindawg,
Thanks for the reply. You are definately right, Linux is satisfying. I love it. After getting the dual monitor set up, I have gone on and setup my FTP and telnet servers (just for fun, they can't be accessed from outside the house, and I really don't have much use for them, but they're nice). I absolutely love the linux environment. Anyways, once again, thanks for the help! It was great to recieve so much help getting this working.
 
  


Reply

Tags
dual, matrox, monitor


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Matrox G400 DRI single-head FrozenMist Linux - Hardware 5 12-26-2004 02:45 PM
Using each head of a Matrox G400 independently w/ DirectFB ultrabomberman Linux - Hardware 4 07-06-2004 11:39 PM
Monitor ghosting with Matrox G400 Dual Head Problem kiley_rodgers Linux - Hardware 1 06-07-2004 07:59 PM
Getting Dual Head to work on Matrox G450 davidcrawley Linux - Hardware 1 02-23-2004 04:43 AM
x86 Solaris 9 XSun and Matrox G550 dual-head... one head down, one to go. finegan Solaris / OpenSolaris 4 03-11-2003 12:39 PM


All times are GMT -5. The time now is 09:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration