LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 11-08-2003, 06:29 AM   #1
jrippon
LQ Newbie
 
Registered: Oct 2003
Location: UK
Distribution: Mandrake, Debian
Posts: 1

Rep: Reputation: 0
Question Mandrake 9.2 Alsa not working C-Media CM8738


Having installed Mandrake 9.2 GPL I have been unable to get sound to work at all.

Mandrake's install detected the sound card correctly from what I can see, and "alsaconf" also seems to find and configure the sound card but still no sound is being produced.

I have checked alsamixer, and also kmix (in case aRts was working) but all settings appear to be fine.

Output of 'lspci -vs 00:09.0':

Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at d400 [size=256]
Capabilities: [c0] Power Management version 2

The module appears to load correctly in the kernel - where should I look next?
 
Old 11-08-2003, 03:32 PM   #2
wuck
Member
 
Registered: Sep 2003
Location: barneveld.nl
Distribution: Slackware
Posts: 170

Rep: Reputation: 30
Look for your modules.
Please post the output of lsmod.

And don't forget to see if your sound is muted. aumix -q
 
Old 11-08-2003, 07:17 PM   #3
hawkwind
LQ Newbie
 
Registered: Nov 2003
Posts: 9

Rep: Reputation: 0
i am having the same exact problem. the card was supported nicely and automagically upon install of mandrake 8.2 - 9.1 without any problems. can someone please help get sound working with this card so that i can switch my g/f over from windows to linux :P

Any and all help would be greatly appreciated.

Hawkwind
 
Old 11-09-2003, 12:16 AM   #4
hawkwind
LQ Newbie
 
Registered: Nov 2003
Posts: 9

Rep: Reputation: 0
well after about 3 1/2 hours of messing around, it seems i got my C-Media CM8738 to work in 9.2 finally :P check your /etc/modules.conf file and see what all is in there.

probeall scsi_hostadapter ide-scsi
alias eth0 tulip
above snd-cmipci snd-pcm-oss

should be all that is needed in there. any more stuff and it will confuse alsa. after you get that completed, then do a full reboot, and sound should work. If you need more help, please feel free to join irc.oftc.net in the channel #Mandrake and i will be willing to help more if need be.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound on c-media CM8738 dhbiker Slackware 1 10-20-2004 03:20 PM
C-Media (cm8738) sound card & alsa problems BBQ_Matt Linux - Hardware 3 02-05-2004 04:39 AM
C-Media CM8738 - Successful Installation edwardp Linux - Hardware 0 08-10-2003 07:38 PM
C-Media CM8738 5.1 channel help dgt84 Linux - Hardware 0 01-25-2003 11:12 AM
C-Media cm8738 no_data Linux - General 0 10-19-2002 01:29 AM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration