LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-02-2011, 10:53 AM   #1
BEaSTFX
LQ Newbie
 
Registered: Jul 2008
Posts: 16

Rep: Reputation: 0
M-Audio Audiophile 24/96 - Pulseaudio 24 bit sound not working


I use M-audio audiophile 24/96. I don't see any configuration options to use the 24 bit sounds, every player plays up to 16 bit.
Can you help me use the full potential.

Regards

Code:
uname -a
Linux Lemuria 3.0.0-13-generic #21-Ubuntu SMP Mon Oct 17 20:18:51 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
 
Old 11-02-2011, 11:41 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, as far as I am aware, and reading this conversation...

http://lists.freedesktop.org/archive...ay/006915.html

Pulse should be able to handle it.

The 24bit @ 96kHz is for recording audio (you won't notice it playing an mp3 file).

This higher than CD resolution is nice when editing sound tracks,

allowing finer adjustments to the cut and paste editing and post-processing (adding effects, etc).

My Edirol UA-25EX (roland) will only do 96kHz when recording, no realtime monitoring of the previous track/signal.

But it does do a few other things I like and use.

Bottom line, if the M-audio 2496 is being used as playback of mastered material,

like movie sound and music tracks, it will operate as a normal sound card and deliver the program material.

If you want to record high quality sound tracks (for multitracking) the config lies with your software applications.

Hope this helps, Glenn

Last edited by GlennsPref; 11-02-2011 at 11:43 AM. Reason: spelling
 
Old 11-02-2011, 11:49 AM   #3
BEaSTFX
LQ Newbie
 
Registered: Jul 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Hello, GlennsPref

When I'm listening to 24 bit flac files, there is a notisable difference in the quality. Human ear can't notise the difference between 41khz and 96khz but that is not relevant
My player plays only on 16 bit on Ubuntu. I need it to play 24bit so i can listen to my 24bit flac music.

Regards
 
Old 11-02-2011, 01:32 PM   #4
BEaSTFX
LQ Newbie
 
Registered: Jul 2008
Posts: 16

Original Poster
Rep: Reputation: 0
I manage to fix the problem. Thank you for your help.
 
Old 11-07-2011, 12:58 PM   #5
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, how did you fix it?

cheers, Glenn
 
Old 07-15-2012, 01:42 AM   #6
Sweyn78
Member
 
Registered: Jul 2011
Location: Tallahassee, Florida
Distribution: Kubuntu 12.10
Posts: 43

Rep: Reputation: Disabled
Lightbulb I've Found the Solution!

I know that the problem has already been solved, but nobody posted the solution, and this post on LQ was the first thing that showed up on DuckDuckGo. Would have been nice if the information had been right there for me when I needed it, so I'm posting what I've found.

Here it is:
We're going to need to edit /etc/pulse/daemon.conf as root.
For Ubuntu (or really any distribution using Gnome), open up the terminal and paste (ctrl+shift+V, if using your keyboard):
Code:
sudo gedit /etc/pulse/daemon.conf
*use kwrite for KDE, leafpad for LXDE, etc.
Gedit (or your text editor, if not gedit) should pop up with the file.
Find the lines: (hint: they're at the end of the file | use ctrl+F if you're lazy :P)
Code:
; default-sample-format = s16le
; default-sample-rate = 44100
...And change their values. I would personally change only one at a time, starting with the sample rate. Accepted ones are generally: 44100, 48000, 96000, and [rarely] 192000. Decomment the line when you are done. For example:
Code:
default-sample-rate = 48000
Restart at your leisure.

...You restarted, right? Make sure the audio is working. If not, try a different sample rate or recomment out the line. If it is, indeed working, it's time to change the sample-format. There are actually a crapload of values for this; unfortunately, the only way I know of to find the best value is trial and error. Keep going to a higher value (restarting each time) until it no longer works. Here are the 24 and 32 bit values:
Code:
s24le s24-32le s32le float32le
s24be s24-32be s32be float32be
As the default is s16le, it's probably a good idea to start with the *le ones if Pulseaudio was working with the default value.
Example:
Code:
default-sample-format = s24le
Assuming everything went well, your audio should now be amazing, just like it would be in Windows.

Source: http://lists.freedesktop.org/archive...ay/006917.html

Last edited by Sweyn78; 07-15-2012 at 02:17 AM. Reason: Rewording.
 
1 members found this post helpful.
Old 07-16-2012, 11:02 AM   #7
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Thank you for your efforts.

(Quite Interesting.)

Cheers Glenn
 
Old 08-08-2012, 09:50 PM   #8
Sweyn78
Member
 
Registered: Jul 2011
Location: Tallahassee, Florida
Distribution: Kubuntu 12.10
Posts: 43

Rep: Reputation: Disabled
Exclamation New Info

I found out what le and be mean:
le = "little endian"
be = "big endian"
Presumably, you would also be able to use:
alaw, mulaw or imaadpcm, float or int, unsigned or signed, in addition to le or be
(I leanred that here: http://web.njit.edu/all_topics/Prog_...yer/sound.html)
But I'm not sure how. Float would, of course, increase audio quality even further if it isn't on by default, so it would be cool to get that in there, if possible. Also, big endian is undesirable for the average computer under most circumstances, so for those reading my mini-tutorial above, you shouldn't use big endian unless your audio is completely broken or you have a good reason to do so.

Last edited by Sweyn78; 08-08-2012 at 09:51 PM. Reason: Added my source.
 
1 members found this post helpful.
Old 07-21-2013, 02:00 PM   #9
oddiofile
Member
 
Registered: Sep 2003
Location: Victoria, BC
Distribution: debian testing
Posts: 42

Rep: Reputation: 15
Quote:
Originally Posted by Sweyn78 View Post
I know that the problem has already been solved, but nobody posted the solution, and this post on LQ was the first thing that showed up on DuckDuckGo. Would have been nice if the information had been right there for me when I needed it, so I'm posting what I've found.

Here it is:
We're going to need to edit /etc/pulse/daemon.conf as root.
I found an easier way.
This is an Envy24 sound card, and I'm on debian so I did "apt-cache search envy24".
If you're on another distro or using a GUI package manager, just search for that.
On my system, I came up with this match:

Package: mudita24
Version: 1.0.3+svn13-4
Installed-Size: 220
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Architecture: amd64
Depends: alsa-utils, libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.24.0), libgtk2.0-0 (>= 2.18.0), libpango1.0-0 (>= 1.14.0)
Description-en: ALSA GUI control tool for Envy24 (ice1712) soundcards
Mudita24 is a modification of the Linux alsa-tools' envy24control: an
application controlling the digital mixer, channel gains and other hardware
settings for sound cards based on the VIA Ice1712 chipset aka Envy24.

This gives you a GUI to modify those settings, if I'm not mistaken.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recording sound with PulseAudio from Line-In and Microphone, not working falmdavis Linux - Newbie 4 03-26-2012 07:03 PM
USB Sound (Mic) not working in Fedora 9 pulseaudio MikeyCarter Linux - Software 0 07-30-2008 10:01 AM
Gentoo: M-audio Audiophile 2496 sound card greeniguana00 Linux - General 4 02-21-2007 12:37 PM
Integrated 16-bit Sound Blaster Pro compatible audio 24-bit DAC jelgavchik Linux - Laptop and Netbook 2 11-16-2006 09:20 PM
Integrated 16-bit Sound Blaster Pro compatible audio 24-bit DAC jelgavchik Linux - Hardware 1 11-16-2006 05:31 PM


All times are GMT -5. The time now is 11:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration