LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-28-2005, 09:28 AM   #1
Fedorasjm
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
Angry ltmodem freezes on activate after upgrade


I am using Fedora core 4.

I WAS ABLE to get my ltmodem TO WORK using kernel 2.6.11-1.1369 (which came with by distribution CD). I was using the ltmodem-8.31b1.tar.gz driver. Using the up2date utility I upgraded my kernel to 2.6.14-1.1653 and now my computer freezes when I try to "activate" my network dial up connection.

I used the same build procedure to make my ltmodem driver. The DRIVER SUCCESSFULLY INSTALLS however whenever I try to activate my dial-up connection the computer freezes and I'm no longer able to use my mouse or keyboard. I have to reboot.

I tried building with my old gcc compiler as well as downloading the latest gcc comiler and rebuilding the kernel module. The latest compiler made no difference as far as the computer freeze. The build procedure tells me that the both the kernel module that I built and the kernel that I downloaded were both built with gcc 4.0.2.

Does anyone know why the ltmodem driver freezes the computer with kernel 2.6.14-1.1653 but works correctly with kernel 2.6.11-1.1369?
Reply With Quote

Last edited by Fedorasjm; 12-29-2005 at 10:14 AM.
 
Old 01-16-2006, 06:42 PM   #2
utopicdog
Member
 
Registered: Aug 2003
Location: france
Distribution: suse/fedora
Posts: 105

Rep: Reputation: 15
try building with the latest gcc 3.x , not a gcc 4.x, they are different.
otherwise - use that old noisy 386 machine in the shed with your old linux, a network card and ip forwarding.
Better still throw the lucent card away and get a new modem.
I had one once, but the house took a direct lightning hit and fried the modem, so I got adsl. I can't say I miss the lucent modem.

utopicdog.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse install freezes on "activate network services" phishead Linux - Distributions 1 05-19-2006 12:42 PM
eth0 freezes / hangs on boot after upgrade mandrake 10.1 to 10.2 Emmanuel_uk Mandriva 3 05-24-2005 07:26 AM
ltmodem problem quiet_penguin Linux - Newbie 0 08-04-2004 06:29 PM
LTModem zdawg LinuxQuestions.org Member Success Stories 1 01-22-2004 03:11 AM
Ltmodem wickdgin Slackware 0 09-16-2002 06:04 PM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration