LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-19-2007, 02:13 PM   #1
martin.klvana
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Rep: Reputation: 0
Low screen resolution problem: Fedora 7, Via P4M800Pro, Via/S3G Unichrome Pro IGP


Hello,

I have Fujitsu-Siemens AMILO Pro V2030 15" notebook with P4M800Pro motherboard and VIA/S3G Unichrome Pro IGP graphics card. I installed Fedora 7.

System >>> Preferences >>> Hardware >>> Screen resolution offers me only 800x600 or 640x480 and refresh rate 61. I need 1024x768 screen resolution.

I tried to install pre-compiled driver binary (linux-fbdev-kernel-bin_2.6.00.03a.tgz) provided by viaarena.com following installation instructions:
# vi /boot/grub/menu.lst (and add "vga=791")
# reboot
# tar zxvf linuxlinux-fbdev-kernel-bin_2.6.00.03a.tgz
# cd linux-fbdev-kernel-bin_2.6.00.03a
# ./viamenu (option 1. for install driver)

Here I got message:
-------- install start --------
./vinstall_2D: line 157: ldconfig: command not found
./vinstall_2D: line 176: depmod: command not found
-------- vinstall end --------
You can run vunistall to Rollback.

I replaced ldconfig and depmod in vinstall_2D file with /sbin/ldconfig and /sbin/depmod, respectively and tried again:
# ./viamenu

Now no error message is reported, however, installation does not proceed, because no message ("Now start to install VIA/S3G display utility..." etc. is reported between "install start" and "vinstall end" line:
-------- install start --------
-------- vinstall end --------
You can run vunistall to Rollback.

Last step is to load the module to the system; is the error here because the driver has not been installed or is this another problem?:
# /sbin/modprobe viafb mode=800x600 bpp=16
FATAL: Error inserting viafb (/lib/modules/2.6.20-2925.9.fc7xen/kernel/drivers/video/viafb.ko): Invalid module format

What is wrong? I tried forum at viaarena.com but I did not get help there.
The only thing I need is to have 1024x768 screen resolution.
I would appreciate very much if anybody can help me.

martink


/etc/X11/xorg.conf is below:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "LeftEdge" "120"
Option "RightEdge" "830"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapMove" "110"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.75"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
 
Old 08-25-2007, 08:27 AM   #2
jerryeguru
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
system-config-display (remember u hv to be root) can help, but i realised myself, Fedora 7 only has 2 options, so i edited /etc/X11/xorg.conf as root and i changed my resolution to 1024x768, and rebooted. I hope this helps.
 
Old 08-26-2007, 02:11 PM   #3
martin.klvana
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you for your suggestion. I tried that a time ago but it did not work.

I solved my problem by switching from Fedora to OpenSUSE (no graphics card driver was needed) and I am absolutely happy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VIA/S3G Unichrome Pro IGP on slk 12 darkslack Slackware 2 07-18-2007 08:55 AM
Unichrome Graphics card resolution problem Draylath Ubuntu 0 06-24-2007 01:24 PM
cant load KDE on Veratec AV3270. via s3g unichrome pro IGP card DragonTool Linux - Laptop and Netbook 2 03-19-2006 02:45 AM
low resolution w/ radeon 9800 pro KillerRoY Linux - Software 1 05-01-2005 07:18 AM
Support for a VIA Unichrome IGP Ephracis Linux - Laptop and Netbook 2 03-21-2005 07:54 PM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration