LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-06-2008, 04:49 AM   #1
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Rep: Reputation: 0
Unhappy Losing network connectivity between single user and multi user modes


Flavor: Debian
Kernel: 2.6.18-6-486
Network driver: RTL8169s/8110s

I installed Debian using the net install CD and can get to the net with either a static IP or DHCP configuration if I boot up in single user mode, but lose all connectivity as soon as I enter multiuser mode. I've checked the dmesg log and all eth0 entries seem to be consistent. I've disabled IPV6, uninstalled NetworkManager, disabled APIC, and checked my interfaces, hosts, and resolv.conf files as well. All seem fine. I feel I'm missing something simple but I've been going around in circles on the net trying to figure it out.

Any help would be appreciated.
 
Old 04-06-2008, 07:58 AM   #2
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Welcome to LQ

Please boot to multiuser mode. Then tell us the outputs of the following commands:

Code:
lsmod  |  grep  8169
ifconfig
cat   /etc/network/interfaces
 
Old 04-06-2008, 01:06 PM   #3
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the welcome. Here are the results

lsmod | grep 8169
r8169 27528 0

Ignoring commented lines I have (this works in single user mode)
auto lo
iface lo inet loopback

auto eth0
iface ethio inet static
address 192.168.0.110
netmask 25.25.255.0
gateway 192.168.0.1

Please boot to multiuser mode. Then tell us the outputs of the following commands:

[CODE]lsmod | grep 8169
ifconfig
cat /etc/network/interfaces
 
Old 04-06-2008, 01:40 PM   #4
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Quote:
lsmod | grep 8169
r8169 27528 0
- shows the module you need for your card is loaded - Good.
Quote:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.110
netmask 255.255.255.0
gateway 192.168.0.1
Your interfaces file isn't quite right, it needs the red 5's I have added for you, and it's "eth0" not "ethio" . Your typos perhaps?
Please check & correct the file as necessary.
This is linux, and absolute attention to detail is important. "eth0" is NOT the same as "etho"

But what was the output of ifconfig ? You didn't post that.
 
Old 04-06-2008, 05:24 PM   #5
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Sorry, My bad

I should've checked my typing better. I typoed when I entered it into the chat. All the info actually matches what you said. For clarification, it reads as follows without changes:

auto eth0
iface eth0 inet static
address 192.168.0.110
netmask 255.255.255.0
gateway 192.168.0.1

FYI, when I ran it with DHCP I used iface eth0 inet dhcp and commented out/removed the above settings except the auto eth0 (that remained.

The output of ifconfig is as follows (checked this time):

eth0 Link encap:Ethernet HWaddr (my MAC address)
inet addr:192.168.0.110 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 861 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:828 overrruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1133355 (110.6KiB) TX bytes:4666 (4.5KiB)
Interrupt:11 Base address:0xef00

Quote:
Originally Posted by tredegar View Post
- shows the module you need for your card is loaded - Good.

Your interfaces file isn't quite right, it needs the red 5's I have added for you, and it's "eth0" not "ethio" . Your typos perhaps?
Please check & correct the file as necessary.
This is linux, and absolute attention to detail is important. "eth0" is NOT the same as "etho"

But what was the output of ifconfig ? You didn't post that.
 
Old 04-07-2008, 03:09 AM   #6
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Thank you.
It looks (almost) OK to me.
Your card has an IP of 192.168.0.110
It has transmitted & received some data, but there are some TX errors.
Have you checked your cable / tried a different one?
Can you ping your router? ping -c5 192.168.0.1
Can you ping google by IP? ping -c5 64.233.167.99
Can you ping google by name? ping -c5 google.com

If the last step fails, what is the output of cat /etc/resolv.conf
 
Old 04-07-2008, 02:31 PM   #7
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Ping and resolve.conf

I've verified my cable. I'm unable to ping anything and my resolv.conf shows two nameserver IPs like it should.

Quote:
Originally Posted by tredegar View Post
Thank you.
It looks (almost) OK to me.
Your card has an IP of 192.168.0.110
It has transmitted & received some data, but there are some TX errors.
Have you checked your cable / tried a different one?
Can you ping your router? ping -c5 192.168.0.1
Can you ping google by IP? ping -c5 64.233.167.99
Can you ping google by name? ping -c5 google.com

If the last step fails, what is the output of cat /etc/resolv.conf
 
Old 04-07-2008, 03:50 PM   #8
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Quote:
I've verified my cable. I'm unable to ping anything and my resolv.conf shows two nameserver IPs like it should.
Well, I am running out of ideas here.
I suspect your install maybe didn't go too well: you say in post #1 that you used a "net install CD", not many people use these, so perhaps it is broken.

For what it's worth, kubuntu 6.06 has worked for me on 5 desktops & 3 laptops. They aren't all mine, but I have no complaints whatsoever. I don't like to "give up", but maybe it's time to try another distro?

http://www.kubuntu.org/download.php#lts

Burn the CD. Plug in and turn on all your hardware before you boot to the install, you may be pleasantly surprised.
 
Old 04-07-2008, 05:46 PM   #9
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks anyway

Well, I'm not set on any one particular install so maybe it's time to try another. Thanks again for the assist.
 
Old 04-08-2008, 07:52 AM   #10
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Let us know how you get on.
 
Old 04-12-2008, 11:56 AM   #11
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Network connectivity update,

I installed Kubuntu to see if that would correct the issue. Unfortunately, I get the same results. I can access the network/internet in single user, but not once I enter multi user. Here are my settings/results:

Flavor: Kubuntu
Kernel: 6.06-1
Network driver: RTL8169s


smod | grep 8169
r8169 28808 0

/etc/network/interfaces
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

auto eth0
iface eth0 inet static
address 192.168.0.110
netmask 255.255.255.0
gateway 192.168.0.1

/etc/resolv.conf
nameserver 65.24.7.10
nameserver 65.24.7.11

ifconfig
eth0 Link encap:Ethernet HWaddr (my MAC address)
inet addr:192.168.0.110 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::240:f4ff:fe9d:lb69/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 7282 errors:0 dropped:7222 overruns:0 frame:0
TX packets:14 errors:0 dropped:7398 overrruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1386904 (1.3 MiB) TX bytes:1645 (1.6 KiB)
Interrupt:201 Base address:0xaf00
 
Old 04-12-2008, 01:03 PM   #12
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Thanks for the update. Mostly it looks OK
But try changing /etc/resolv.conf to read just:
Code:
nameserver 192.168.0.1
If you don't know how to do this, in a terminal do:

Code:
kdesu kwrite /etc/resolv.conf
Make the changes, Save, close kwrite.
Then :
Code:
sudo ifdown eth0
sudo ifup eth0
To restart your network interface.

This should make your router your nameserver. It should forward requests to your ISP, and relay them back correctly.

Are you connected properly now?

This should survive a reboot.
I look forward to your results
 
Old 04-12-2008, 10:04 PM   #13
n3now
LQ Newbie
 
Registered: Apr 2008
Posts: 7

Original Poster
Rep: Reputation: 0
I changed the resolv.conf file to nameserver 192.168.0.1 and am still getting the host unreachable from a ping to my router (192.168.0.1) much less the internet. I even rebooted just in case with no luck.
 
Old 04-13-2008, 05:16 AM   #14
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
zzyzcx is having the same problem in this thread: http://www.linuxquestions.org/questi...1/#post3119712
He is trying an install from a regular CD, rather than the "net install", we'll see if that fixes the problem.
 
Old 04-13-2008, 01:13 PM   #15
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
zzyzcx has apparently now solved this problem in another thread, here: http://www.linuxquestions.org/questi...1/#post3120038
Please read that thread, try the sugestions (about IRQs) and let us know how you get on.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot login with any user except in single user mode scheidel21 Linux - Desktop 1 03-19-2008 01:42 PM
Single user or multi-user mode? hyphae Slackware 3 01-26-2007 10:52 AM
I can't run Firefox from my single user(only from a super user) nightrider Linux - Newbie 14 10-24-2006 08:35 PM
architecture of a multi user network with reference to the OSI model monty69 Linux - Networking 1 04-23-2006 05:07 PM
Multi-user and 3D sharing, 3D only works for the first logged in user foxy123 Suse/Novell 0 02-20-2005 04:31 AM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration