LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-02-2004, 04:44 AM   #1
kyvahe
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Rep: Reputation: 0
Post Logitech elite duo wireless troubles


Hi,

I got a really annoyinqg problem with my keyboard, its the logitech elite duo wireless model.q I know that logitech doesqn't support linux but qi need to know if anyone else has haqd this problem or knows a fix. When i'm typing it randomly qputs the letter Q in every now and then and sometimes worse then others. q

Example: (you can really just read the above and see all the Q's everwhere.)q qI will just type and it will qtype Qq's everywhere, no matter what key i'm using. Sometimes every key i strike it thqrows a Q up onto the screen!

I can go back and delete them (the Q's), but it gets really annoying qand it seems to make the problem worse.

Please help!! TIA
 
Old 01-02-2004, 08:02 AM   #2
rberry88
Member
 
Registered: Aug 2003
Location: Arlington Heights, IL USA
Distribution: Fedora Core 1 & WinXP Pro & Gentoo 1.4 & Arch Linux
Posts: 558

Rep: Reputation: 30
I have the same Logitech cordless Elite Duo setup (mouse and keyboard) and they work fine (notice no strange q's inserted). :P

Maybe check your XF86Config file to see if there is something strange going on in there and you can also check your keymaps directory to see if it recognizes the proper keyboard setup.

Without knowing what distro, wm or any other info its hard to give any answer other than just guesses.

rberry88
 
Old 01-02-2004, 12:16 PM   #3
kyvahe
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Original Poster
Rep: Reputation: 0
I'm running redhat 9

Last edited by kyvahe; 01-02-2004 at 01:00 PM.
 
Old 01-02-2004, 01:00 PM   #4
kyvahe
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Could someone with a working Elite duo setup paste up a copy of their XF86Config file, it would be greatly appreciated.

Thank you.
 
Old 01-03-2004, 12:01 PM   #5
rberry88
Member
 
Registered: Aug 2003
Location: Arlington Heights, IL USA
Distribution: Fedora Core 1 & WinXP Pro & Gentoo 1.4 & Arch Linux
Posts: 558

Rep: Reputation: 30
Quote:
Originally posted by kyvahe
Could someone with a working Elite duo setup paste up a copy of their XF86Config file, it would be greatly appreciated.

Thank you.
The keyboard section:
Code:
# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************
 
Section "InputDevice"
 
    Identifier  "Keyboard1"
    Driver      "Keyboard"
 
# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.
 
#    Option     "Protocol"      "Xqueue"
 
    Option "AutoRepeat" "500 30"

    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"  "us"
 
EndSection
The mouse section:

Code:
# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************
 
Section "InputDevice"
 
# Identifier and driver
 
    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"   "IMPS/2"
    Option "Device"      "/dev/psaux"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
 
# Mouse-speed setting for PS/2 mouse.
 
#    Option "Resolution"        "256"
 
# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
 
#    Option "Protocol"  "Xqueue"
 
# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
 
#    Option "BaudRate"  "9600"
#    Option "SampleRate"        "150"
 
# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
 
#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"
 
# ChordMiddle is an option for some 3-button Logitech mice
 
#    Option "ChordMiddle"
 
EndSection
Pretty basic setup but it all works, the only strange thing is that the wheel on the keyboard also works to scroll and I'm not sure how to adjust the settings for it. The mouse side button works as "back" in Mozilla and in Opera it acts as "rewind" and I don't see any settings for this anywhere.

But since it all works I'm not ready to break it and start over.

rberry88
 
Old 01-03-2004, 05:21 PM   #6
kyvahe
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you, hopefully i can use that and get it working. Thanks again!
 
Old 01-12-2004, 06:56 PM   #7
jcwebb
LQ Newbie
 
Registered: Mar 2003
Location: Florence, SC
Distribution: Redhat Linux 8.0, Fedora Core 3
Posts: 7

Rep: Reputation: 0
I am also running RH 9.0 with the Cordless MX Duo (Cordless Elite Keyboard / MX700 Mouse) and experienced a similar problem when running the keyboard / mouse receiver through a KVM Switch (iogear MiniView Micro). I have just now plugged the keyboard directly into my Linux box and have not seen any q's so far!

FWIW, I don't think it is an X-config issue as I also tried the keyboard (through the switch) running in console mode only and experienced error messages regarding invalid escape sequences.

Note that I have not had any problems (so far) with the keyboard through the KVM switch when running WinXP (Dual boot with Linux) or my Win2K Laptop.

My thinking is that the KVM switch has some problems with the wireless link (iogear does not support wireless through their switch), but where Windows ignores these characters, Linux tries to use them???
 
Old 01-12-2004, 10:14 PM   #8
dittohead
Member
 
Registered: Jul 2003
Location: /dev/random
Distribution: Ubuntu 5.10, Fedora Core 4, Gentoo
Posts: 62

Rep: Reputation: 15
If it's wireless, make sure there's no interference. This may not be an OS problem.

your manual should have some info on interference.

I can't use my new wireless mouse on my wacom tablet, because the tablet interferes with the mouse.

 
Old 01-13-2004, 08:16 AM   #9
jcwebb
LQ Newbie
 
Registered: Mar 2003
Location: Florence, SC
Distribution: Redhat Linux 8.0, Fedora Core 3
Posts: 7

Rep: Reputation: 0
Thanks dittohead, the RF interference makes more sense to me, but I've tried moving the receiver to several locations with no change in the quirky performance -- or course it's hard to find a spot on my desk without some kind of EM radiating device nearby!

What doesn't make sense is that I see no spurious characters on either of my windows machines -- one of which _is_ my Linux box as well, when running through the KVM switch. But I do get them in Linux, both at the console and under X (through the KVM).

So far, no problems under Linux with the Keyboard plugged directly into the PC.

However the other variable is that the KVM switch is strictly PS/2 connectors but currently I have the receiver plugged in via it's USB port. A bit more runtime under Linux - direct - USB and I'll switch to the PS/2 connectors.

John
 
Old 01-13-2004, 11:04 AM   #10
dittohead
Member
 
Registered: Jul 2003
Location: /dev/random
Distribution: Ubuntu 5.10, Fedora Core 4, Gentoo
Posts: 62

Rep: Reputation: 15
Hmm, quite strange.

Sorry I couldn't help more, it seems that the kvm switch maybe what's doing it.

I don't know KVM switches much, but The Screen Savers (a show on techtv cable station) use them quite a lot. Their problem with them most of the time is they don't last a very long time like most other peripherals.

You can try psoting in their forums: www.thescreensavers.com

But if you aren't getting any problems in windows, but you are in a linux, it makes me wonder if maybe the keyboard sends out special keycodes that alert the windows drivers of battery low, rf interference etc, that show up in linux as "q". Because they only showup in linux when the KVM switch is on, maybe the kvm switch doesn't translate well?

I'm out of ideas, I hope you find something.
 
Old 01-15-2004, 02:28 PM   #11
vduarte
LQ Newbie
 
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
spurrious q's with logitech elite duo wireless keyboard and linux

well misery loves company. I have the exact same problem with my wireless elite duo connected to a kvm switch. the q's never appear on either xp system but always appear on all linux versions on both boxes. RH9, RH8 and Java Desktop Services all exibit same problem. I also noted that the backspace key will almost always (99% of the time) generate the q but that a control-h or control-8 will not generate the q and will do the destructive backspace. further, there is an accumulation of q's if you do not type anything and then start to type. it's clear to me the keyboard and kvm are operating the same irrespective of the os. my guess is the logitech elite duo driver on windows is chucking the erroneous q's when then come in. wish i had a solution other than plugging the keyboard into the machine. i also noticed my wireless mouse gets stuck, true on all os's, and i need to pick it up and put it down to get it to move. weirdness.
 
Old 03-22-2004, 06:03 AM   #12
gyaresu
LQ Newbie
 
Registered: Feb 2003
Posts: 4

Rep: Reputation: 0
any answers?

Hi.
I've got the same problem.
logitech cordless desktop pro/ KVM switch.
The letter "q" appearing for long stretches, but not all the time.
Funny thing is it only happens sometimes and only on the main Debian box(shuttle).
My second computer is Debian as well but no "escape sequences" there as far as i can tell.
And it only started to happen recently.
So I am going to change the batteries on the keyboard and see what happens.
Will report back for posperity.
Love to hear any feadback from the previous posters.
regards.
g
 
Old 03-22-2004, 07:14 AM   #13
vduarte
LQ Newbie
 
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
spurrious q's with linux

I removed the kvm switch and everything works peachy. Changing batteries on the wireless keyboard had no effect.
 
Old 03-25-2004, 02:45 AM   #14
d4harvey
Member
 
Registered: Jul 2003
Location: Ontario, Canada
Distribution: Fedora Core 1 - 5
Posts: 99

Rep: Reputation: 15
Logitech Mouse and Keyboard

I know this is an old post but hey.....

I have the exact some problem on my Logitech Wireless Elite Duo. But herein I think lies your answer. I started sucking batteries like crazy with this keyboard and mouse, so I called logitech and they replaced the keyboard and mouse without question. They let me keep the old one and I setup the new one for home use, using the old one at work. Now I run fedora at work and home, but I get the Q problem at work only. So there is a problem with these early keyboards, not all of them mind you, just some of them. I also have very odd channel problems on the old keyboard and mouse where they will randomly flip channels then neither works and they both lock up. Solution recycle them and bought two new ones....you might want to try logitech for a replacement.

Cheers,

DH
 
Old 03-26-2004, 02:28 AM   #15
moschi
Member
 
Registered: Mar 2004
Location: boulder, co
Distribution: slack 12, debian 4, ubuntu server 6.10
Posts: 68

Rep: Reputation: 15
i am using the wireless elite duo through a kvm a well... on fedora, & i had this problem, except it was the letter w.

the only solution i could find was to unplug & re-plugin the keyboard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
logitech elite duo keyboard prints a 'q' when hitting backspace telesto Linux - Hardware 20 08-18-2004 11:50 PM
Logitech Elite Duo Keboard not working exiledone Linux - Hardware 0 07-23-2004 03:05 PM
logitech USB wireless mx duo elite problems acidburn2kx Linux - Hardware 1 01-05-2004 07:56 AM
Logitech Elite Duo help d0nny Linux - Hardware 1 10-06-2003 06:33 PM
Logitech Cordless Elite Duo netmatrix0 *BSD 0 07-04-2003 03:20 PM


All times are GMT -5. The time now is 03:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration