LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Loading Video Driver (http://www.linuxquestions.org/questions/linux-hardware-18/loading-video-driver-471854/)

Bgarret 08-08-2006 02:36 AM

Loading Video Driver
 
I have been at this for hours trying to successfully install a video driver. I have the S3 unichrome pro integrated graphics processor. I got the driver from the following site:
Viaarena

When installing this driver I get the following error:

-------- install start --------
install UniChrome console framebuffer driver
./viafb-install: line 120: [: ==: unary operator expected
./viafb-install: line 155: [: ==: unary operator expected
./viafb-install: line 155: [: ==: unary operator expected
./viafb-install: line 155: [: ==: unary operator expected
cp: cannot stat `///viafb.ko': No such file or directory

Any help would be appreciated.

Fedora 5.0 on a VIA VN800 chipset

Brad

ilpadrino 08-08-2006 04:42 AM

The problem is that you cannot compile the driver, probably due to compiler libraries compatibility problem, cause your Fedora Core 5 distro is really new.

cs-cam 08-08-2006 06:02 AM

I'm an Nvidia user but an Arch guy has that card and he was pretty impressed with the current Xorg drivers. Try using those, you either need to change the Driver line in xorg.conf to "via" or "unichrome", not sure which.

vado 10-13-2006 04:09 AM

Quote:

Originally Posted by Bgarret
I have been at this for hours trying to successfully install a video driver. I have the S3 unichrome pro integrated graphics processor. I got the driver from the following site:
Viaarena

When installing this driver I get the following error:

-------- install start --------
install UniChrome console framebuffer driver
./viafb-install: line 120: [: ==: unary operator expected
./viafb-install: line 155: [: ==: unary operator expected
./viafb-install: line 155: [: ==: unary operator expected
./viafb-install: line 155: [: ==: unary operator expected
cp: cannot stat `///viafb.ko': No such file or directory

Any help would be appreciated.

Fedora 5.0 on a VIA VN800 chipset

Brad

Problem is in sourse viafb-install. What is your kernel version?

You need change in viafb-install file by any text editor next strings:

2.6.9-1.667)
OS=FedoraCore
VER=3.0
;;

to

"your_kernel_ver")
OS=FedoraCore
VER=5.0

for example type in terminal uname -r - it`s will be you kernel ver... (i have 2.6.18), so I need change in viafb-install

2.6.9-1.667)
OS=FedoraCore
VER=3.0
;;

to

2.6.18)
OS=FedoraCore
VER=5.0
;;

it must to be work ;)


All times are GMT -5. The time now is 11:22 AM.