LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-30-2005, 09:50 AM   #1
marc1978
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa in Canada
Distribution: Mandriva 2005 LE (10.2)
Posts: 13

Rep: Reputation: 0
Exclamation loading the USB module at boot time


New Mandrake 10.2 install. (kernel 2.6)

-I had to disable my USB controller in the BIOS to install the OS.
-After install, I re-enabled it in the BIOS, and now, when I plug my digital camera, it doesn't recognize it. (it did before with a previous install having USB controller enabled in the bios at install time)
-I do NOT have 'USB' inside /proc/bus.

Here is the result of a lspci |grep USB

00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)

Someone told me it's because I do not have the usbcore module loaded. Is this the reason? If so, how do I add this module and make sure it works at boot time?

Let me know if I'm missing anything, I'll add it.
 
Old 10-31-2005, 04:56 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,321

Rep: Reputation: 141Reputation: 141
Here's my line from /etc/modprobe.conf that loads the usb drivers:

Code:
install usb-interface /sbin/modprobe uhci-hcd; /sbin/modprobe ehci-hcd; /bin/true
I also have mdk10.2(LE 2005). You can try adding the above line to your modprobe.conf file.
 
Old 10-31-2005, 06:11 PM   #3
marc1978
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa in Canada
Distribution: Mandriva 2005 LE (10.2)
Posts: 13

Original Poster
Rep: Reputation: 0
Excellent ! That did it.

Thanks alot for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Modem Module not loading Xaque208 Linux - Networking 2 10-08-2005 11:36 AM
USB Modem and ACM Module Loading problem ernesto_cgf Linux - Hardware 1 08-23-2004 10:34 PM
module loading at boot vasco1984 Linux - General 4 05-11-2004 06:39 AM
Loading a Module at boot time Nappa Fedora 8 04-14-2004 07:12 PM
Loading module at boot time. fei Linux - General 1 02-27-2004 09:05 PM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration