LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-23-2002, 03:14 AM   #1
apokalypse
LQ Newbie
 
Registered: Jul 2002
Posts: 6

Rep: Reputation: 0
Question Linux won't Mount Primary Slave HD


Linux refuses to mount my primary slave hard disk. It recognises it when the kernel is starting up, even what type it is (FUJITSU) and says that it will be hdb, but it refuses to mount it. It says "invalid block device".

I've tried editing fstab, and have tried using hdb1, hdb2 to refer to the partitions (there are 2 partitions on the disk), with no success.

I'm a complete newb when it comes to linux, so any help would be greatly appreciated...thnx.
 
Old 07-23-2002, 03:35 AM   #2
sarin
Member
 
Registered: May 2001
Location: India, Kerala, Thrissur
Distribution: FC 7-10
Posts: 354
Blog Entries: 2

Rep: Reputation: 34
Just try giving
fdisk -l
This show you all the partitions and all hds recognized. Currently I can't be of any more help. Pl. post what you see.
--Sarin
 
Old 07-23-2002, 03:54 AM   #3
apokalypse
LQ Newbie
 
Registered: Jul 2002
Posts: 6

Original Poster
Rep: Reputation: 0
Sarin, thanks for your help.

I tried fdisk -l, but it just gave me a list of the hda partitions (boot, swap and root). When i tried fdisk dev/hdb -l it said that hdb was an invalid device, or words to that effect. But I can use this utility to check if hdb is recognized a lot easier than trying to mount it.

Here's some more information I get when it starts up, which is what confuses me. It is recognising that hdb is a fujitsu drive, but it still isn't working.

Plus I find it hard to see exactly what it is doing, because it scrolls down so fast...if there was some way to pause it (the pause key doesn't work) I might be able to get more information.

This is what the start up says:

[lots of stuff]

hdb: FUJITSU

[lots of stuff]

hdb: driver not present
mount /dev/hdb1 : invalid block device

I have considered the possibility that the system does not have a driver for the hard drive, but I have used that hard drive (the fujitsu) as a dual-partition linux/windows system before with no problems, so I thought that this was unlikely.

Any ideas?
 
Old 07-23-2002, 04:57 AM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Try running these commands to look at your log files.

dmesg | less
tail -n 200 /var/log/messages

What distribution of linux are you using?

Last edited by linuxcool; 07-23-2002 at 04:58 AM.
 
Old 07-23-2002, 04:58 AM   #5
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Rep: Reputation: 30
Hi!

Use the dmesg command to see your kernel messages.
You can pipe it through 'less' to let you scroll through one page at a time.

Like so;
dmesg | less

Good Luck!
RefriedBean
 
Old 07-23-2002, 05:19 AM   #6
mikek147
Member
 
Registered: Mar 2002
Location: Elyria, Ohio
Distribution: Debian, Nothing else required
Posts: 141

Rep: Reputation: 15
What type of partitions are on hdb? -mk
 
Old 07-23-2002, 06:17 AM   #7
apokalypse
LQ Newbie
 
Registered: Jul 2002
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks everyone , dmesg is very useful!

I'm using Red Hat 7.3. I have an 80 gig drive (the pri. master), and a 3 gig drive (the pri. slave). There is 1 vfat partition and some linux partitions (I forget exactly) on the 3 gig drive. This was from a previous attempt to run Linux, until I realised I'd need a lot more space for both systems .

Ok, I used "dmesg | less", to see what the kernel is up to. This is what it says, ##### = some big numbers

....

hda: ST######, ATA DISK drive
hdb: FUJITSU###### E, ATA DISK drive

....

hda: setmax LBA #####, native ######
hda: ##### sectors, (#### mb), w/####k cache UDMA(33)
ide-floppy drive: [stuff]
Partition check
hda: hda1 hda2 hda3
Floppy drive(s) [stuff]

.....

The only further mention of hdb is when it repeats " hdb: driver not present" a number of times.

It's strange how it detects hda + hdb exactly the same, at the beginning. But it doesn't partition check or check sectors on hdb. It seems something is going wrong between those two checks.

I've had a thought - I will try changing the bios. At the moment both drives are on AUTO detection, so I'll try giving the second one a fixed setting...
 
Old 07-23-2002, 06:24 AM   #8
apokalypse
LQ Newbie
 
Registered: Jul 2002
Posts: 6

Original Poster
Rep: Reputation: 0
Update: I tried that, but didn't work.
Any more ideas?
 
Old 07-23-2002, 08:25 AM   #9
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Rep: Reputation: 30
Quote:
Originally posted by apokalypse
Update: I tried that, but didn't work.
Any more ideas?
Hi!
Well, here are some ideas;

Are the jumpers on hdb are set to slave, and not to master?

Have you tried putting hdb on the second ide controller, as the master/slave?

RefriedBean
 
Old 07-23-2002, 11:21 AM   #10
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Just a quick question. What is on this hard drive ? Is it empty with no filesystem or does it have a filesystem on it.

If so, how are you trying to mount the hard drive, with what options.. etc ?

If no filesystem, just two partitions.. have you tried this to create or edit existing partitions possibly:

fdisk /dev/hdb
 
Old 07-23-2002, 07:36 PM   #11
apokalypse
LQ Newbie
 
Registered: Jul 2002
Posts: 6

Original Poster
Rep: Reputation: 0
Refried: Good ideas

The jumpers on the slave are set to slave (as specified on the hard drive case). I checked carefully on that, but I certainly could have made a mistake.

I think it must be acting as slave properly, because the BIOS automatically detects it as such. Is this correct?

I'll try putting it on the second ide controller, but I'll need to get another IDE cable (I only have one).

trickykid: There is definitely a non-empty vfat (thats the Windows 98 file system, right?) file system on the slave drive, from which I want to copy some files to the master.

I have the following line in fstab:

/dev/hdb1 /mnt/hdb sw 0 0

THe partition I want to mount is either hdb1, hdb2 or hdb3. The other 2 should be valid linux partitions, though.

I have tried mounting hdb1, hdb2, hdb3, hdb4 manually, but it always says "mount: /dev/hdbx is not a valid block device". I don't use any options, just the device and the mount point - the options don't seem to make much of a difference. I have tried -t vfat but that doesn't seem to help.

Yes, I have tried fdisk /dev/hdb and it invariably says
"Unable to open /dev/hdb"....

Thanks...
 
Old 07-23-2002, 08:37 PM   #12
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by apokalypse
trickykid: There is definitely a non-empty vfat (thats the Windows 98 file system, right?) file system on the slave drive, from which I want to copy some files to the master.

I have the following line in fstab:

/dev/hdb1 /mnt/hdb sw 0 0

THe partition I want to mount is either hdb1, hdb2 or hdb3. The other 2 should be valid linux partitions, though.

I have tried mounting hdb1, hdb2, hdb3, hdb4 manually, but it always says "mount: /dev/hdbx is not a valid block device". I don't use any options, just the device and the mount point - the options don't seem to make much of a difference. I have tried -t vfat but that doesn't seem to help.

Yes, I have tried fdisk /dev/hdb and it invariably says
"Unable to open /dev/hdb"....
Well definitely if you have a fat filesystem on the drive you trying to mount, you should definitely be adding that to you fstab file or try it like this.

/dev/hdb1 /mnt/hdb vfat defaults 0 0

Also, without it being in your fstab file and assuming you have the empty /mnt/hdb directory created... what happens if you try this to mount it manually:

mount -t vfat /dev/hdb1 /mnt/hdb

Let us know..

Hey look at that.. I have over 5,000 posts now.. I think its time to start looking for a life.
 
Old 07-24-2002, 07:55 AM   #13
apokalypse
LQ Newbie
 
Registered: Jul 2002
Posts: 6

Original Poster
Rep: Reputation: 0
I've tried both things, but they both have the same errors, "invalid block device"... but thanks anyway
 
Old 08-27-2002, 11:25 AM   #14
tab
LQ Newbie
 
Registered: Aug 2002
Distribution: Redhat 7.2
Posts: 1

Rep: Reputation: 0
I had exactly the same problem, my hdc would not be recognised by linux although DOS was fine with it.

I found the problem resolved by removing the "hdc=ide-scsi" from the boot command, see /boot/grub/grub.conf

Not sure why though !

Best of luck,
TAB
 
Old 09-08-2002, 01:18 AM   #15
allan8989
LQ Newbie
 
Registered: Sep 2002
Posts: 9

Rep: Reputation: 0
...assuming you have the empty /mnt/hdb directory created... what happens if you try this to mount it manually:

mount -t vfat /dev/hdb1 /mnt/hdb

Let us know..

...i tried it in above way, OK and i can see the slave hard drive which is fat or NTFS in windoze and even all the files in it...i think probably something wrong with your hard drive or some hardware conflict in mainboard or hard disk or even BIOS...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot primary Linspire & XP primary slave? watmonki Linspire/Freespire 5 11-01-2005 08:16 PM
Linux 10 on primary Slave rich.jt Linare 6 09-06-2004 03:15 AM
boot loader, MBR, redhat9 on primary slave, winxp on primary master samik Linux - Hardware 4 10-15-2003 08:55 PM
Linux unstable after attaching primary slave IDE HDD glock19 Linux - General 4 01-28-2002 08:07 PM
Moving linux hard drive to primary slave flyboy320 Linux - General 4 01-23-2002 11:30 AM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration