LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Level1 Wireless LAN 108MBps USB,Model:WNC-0302USB,Chipset:Atheros 5523,Works in SUSE? (http://www.linuxquestions.org/questions/linux-hardware-18/level1-wireless-lan-108mbps-usb-model-wnc-0302usb-chipset-atheros-5523-works-in-suse-442442/)

nikodhmos 05-07-2006 07:46 AM

Level1 Wireless LAN 108MBps USB,Model:WNC-0302USB,Chipset:Atheros 5523,Works in SUSE?
 
Has anyone this Wi-Fi USB Device working in SUSE 10 Linux ? and if yes how ?
Level1 Wireless LAN 108MBps USB Adaptor, Model: WNC-0302USB, Chipset: Atheros 5523
I red in madwifi that they do not support yet USB wi-fi devices from Atheros.
My Configuration follows:
Novell SUSE Linux 10, Kernel:2.6.13-15.8-default (X86-64, AMD Athlon 64 3200+)
Related Hardware Information:
>> hal.1: read hal data
hal: connected to: :1.273
----- hal device list -----
39: udi = '/org/freedesktop/Hal/devices/usb_device_cf3_1_1_0'
info.udi = '/org/freedesktop/Hal/devices/usb_device_cf3_1_1_0'
linux.subsystem = 'usb'
linux.hotplug_type = 1 (0x1)
usb_device.bus_number = 1 (0x1)
usb_device.can_wake_up = false
usb_device.is_self_powered = false
usb_device.version_bcd = 512 (0x200)
usb_device.speed_bcd = 294912 (0x48000)
usb_device.serial = '1.0'
usb_device.linux.device_number = 2 (0x2)
usb_device.num_ports = 0 (0x0)
usb_device.max_power = 500 (0x1f4)
usb_device.device_revision_bcd = 1 (0x1)
info.product = 'AR5523'
usb_device.product = 'AR5523'
info.vendor = 'Atheros Communications, Inc.'
usb_device.vendor = 'Atheros Communications, Inc.'
usb_device.product_id = 1 (0x1)
usb_device.vendor_id = 3315 (0xcf3)
usb_device.device_protocol = 0 (0x0)
usb_device.device_subclass = 0 (0x0)
usb_device.device_class = 255 (0xff)
usb_device.num_interfaces = 1 (0x1)
usb_device.num_configurations = 1 (0x1)
usb_device.configuration_value = 1 (0x1)
usb_device.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:02.1/usb1/1-1'
info.linux.driver = 'usb'
info.bus = 'usb_device'
info.parent = '/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_02_1'
linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:02.1/usb1/1-1'
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:02.1/usb1/1-1'

>> usb.2: usb
usb device: name = 1-1:1.0, bus_id = 1-1:1.0, bus = usb
path = /devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0
modalias = "usb:v0CF3p0001d0001dcFFdsc00dp00icFFisc00ip00"
bInterfaceNumber = 0
bInterfaceClass = 255
bInterfaceSubClass = 0
bInterfaceProtocol = 0
if: 1-1:1.0 @ /devices/pci0000:00/0000:00:02.1/usb1/1-1
bDeviceClass = 255
bDeviceSubClass = 0
bDeviceProtocol = 0
idVendor = 0x0cf3
idProduct = 0x0001
manufacturer = "Atheros Communications Inc"
product = "AR5523"
serial = "1.0"
bcdDevice = 0001
speed = "480"

47: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_cf3_1_1_0_if0
Unique ID: ADDn.bu19_o35liD
Parent ID: k4bc.jjVX5a+F_4C
SysFS ID: /devices/pci0000:00/0000:00:02.1/usb1/1-1/1-1:1.0
SysFS BusID: 1-1:1.0
Hardware Class: unknown
Model: "Atheros AR5523"
Hotplug: USB
Vendor: usb 0x0cf3 "Atheros Communications Inc"
Device: usb 0x0001 "AR5523"
Revision: "0.01"
Serial ID: "1.0"
Speed: 480 Mbps
Module Alias: "usb:v0CF3p0001d0001dcFFdsc00dp00icFFisc00ip00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #46 (Hub)

xerakko 05-11-2006 05:22 PM

ar5523 works!
 
Maybe could be usefull to you, I had an SMC usb card with the Atheros ar5523 chipset working in my Debian. The madwifi driver don't support it yet, I needed ndiswrapper tools, but It works!!!

nikodhmos 05-12-2006 04:55 PM

Thank you for the reply, I 'll try the ndiswrapper
 
Thank you for the reply, I 'll try the ndiswrapper

1richard 05-19-2006 10:26 AM

HI I am using, Kubuntu, (debian) I have the 5523 chip on a usb stick, and I would like to get it to work, can ou please tell me what driver you used to get it to be recognized? thanks in advance


All times are GMT -5. The time now is 10:27 AM.