LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   LCD screen jitter (http://www.linuxquestions.org/questions/linux-hardware-18/lcd-screen-jitter-325460/)

jonfa 05-20-2005 04:00 PM

LCD screen jitter
 
Hi All,

I have a Fedora Core 3 box (kernel 2.6.11-1.14_FC3) and a Nvidia card with the latest Nvidia drivers working. The problem lies with my Mag Innovision 19" LCD monitor (LT982s). In certain columns the pixels are jittering. They are moving slightly, but just enough to catch your eye. The other coulmns are fine. I have the monitor set up with 1280x1024 @75 Hz refresh rate. I have tried changing the vertical and horizontal sync values in the xorg.cong, but it will only allow refresh rates up to 75 Hz. How can I increase this? Any ideas on how to tackle this??? Here is a copy of my xorg.conf:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x1024"
DisplaySize 350 260
HorizSync 50.0 - 120.0
VertRefresh 60.0 - 130.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX"
Option "OpenGLOverlay"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

cereal83 05-20-2005 04:09 PM

Are you sure that you have this right?

HorizSync 50.0 - 120.0
VertRefresh 60.0 - 130.0

On my lcd I have like 50-70 and 50-80. I mean if those rates are right for your monitor then I dunno but I think they look way too high. If you set them to the proper rates then you should be able to switch to the proper Hz for your monitor. So look it up and make sure they are right. If they are right then post back!

jonfa 05-20-2005 04:15 PM

That's the thing. I have tried all different combinations of rates. Those just happened to be the last set I tried. Currently they are at (v)31.0 - 70.0 and (h) 30.0 - 80.0. No matter what combination I get the same results. Perhaps the resolution is too small?

cereal83 05-20-2005 04:22 PM

I think it is the rates because for this monitor 50-75 would screw it up and make some of look bad but 50-70 would make it perfect. I just had to play arond until I found something that worked!

jonfa 05-20-2005 04:29 PM

You are correct. I seem to have found a happy medium by lowering rates some. (v)30-70 and (h)30-80 seems to be a winner!!!! Thanks for the help. At first I thought it was the Nvidia driver, but it was goofy with the vesa driver as well.

cereal83 05-20-2005 09:13 PM

Well I am glad that I could help out. Thank god this way an easy problem to fix because not all of them are this easy

:)

GBrushTWood 05-27-2005 03:32 PM

Hey, somewhat of a Linux newbie here, and I seem to be having a similar problem so I'll top this.

Fedora Core 3
NVidia GeForce2 MX (old and crappy hehe)
NEC MultiSync LCD1765 (not old and crappy)

I have the jittery and jumpy display issue, and I have toyed around with the xorg.conf as well. I found the specifications given for my LCD on the NEC website. They claim the horizontal sync should be between 31.5 and 81.1 Khz, while the vertical sync should be 56.0 - 75.0.

I have made these changes yet I am still seeing the jittery and jumpy GUI. Does anybody have some tips for toying around with these numbers to achieve the optimal settings? FWIW, the system recognized my LCD to have a 31.0 - 81.0 horizontal sync from simply plugging the monitor in, but these numbers were a little bit off. What are some reasonable numbers for a 17" LCD? Here's my monitor section of xorg.conf btw...

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "NEC LCD1765"
DisplaySize 340 270
HorizSync 31.5 - 81.1
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection


Also, should I expect to see changes as soon as I save changes to xorg.conf, or do I need to re-boot after each change I make? I've rebooted since making these changes, but am wondering for future changes to the file...

Thanks in advance..


All times are GMT -5. The time now is 02:10 AM.