LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 12-18-2006, 10:39 AM   #1
Laker Netman
LQ Newbie
 
Registered: Dec 2006
Distribution: Fedora Core (4,5,6)
Posts: 4

Rep: Reputation: 0
LCD display unexpectedly goes into low power mode with Nvidia card in FC6


Hi. I'm having an issue with my display going into low power mode.

The system is a Gateway E-4400 with 512MB RAM with a ViewSonic VG2021m display. The original AGP video card died and has been removed. Due to the age of the system and proprietary AGP card slot size, a PCI replacement card was my only viable option.

I just installed an EVGA e-GeForce FX5200 video card (128MB RAM, PCI) after getting fed up with the Radeon card I tried first. I downloaded, and installed without issue, the latest driver from Nivida. Release: Linux-x86 1.0-9631

I have the screen saver set to start after 30 minutes and all power management is disabled (AFAICT) in X and the BIOS. After a random amount of time (typically a few minutes, but sometimes several hours) the monitor drops into low power mode (screen blanks and monitor power button goes from blue to amber).

Mouse or keyboard activity wakes it back up, but here is where the heart of the problem lies: I use "synergy" (http://synergy2.sourceforge.net/) to link my laptop with this desktop system and keyboard/mouse activity generated from the laptop do not wake up the screen.

I have disabled synergy on the Gateway and still see the power down issue, so I don't believe it's related to that application.

I am running KDE 3.5.5, but have seen the same symptoms running Gnome as well.

Here is a copy of my xorg.conf, note I have already commented out the DPMS setting.

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Thu Nov  9 17:56:12 PST 2006

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
    FontPath        "unix/:7100"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/mouse"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "IMPS/2"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic VG2021m"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 76.0
#    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5200"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "1400x1050_60 +0+0; 1400x1050 +0+0; 1280x1024 +0+0; 1280x960 +0+0; 1280x800 +0                                            +0; 1152x864 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Ultimately, regardless of anything else, I really don't want the monitor to power down.

Ideas anyone?

Thanks,
Laker
 
Old 12-18-2006, 11:57 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
what does the output of xset q show ?

Quote:
DPMS (Energy Star):
Standby: 3600 Suspend: 3600 Off: 7200
DPMS is Enabled
Monitor is On
even though you have DPMS commented out in your config it would be good to verify it's not active..
 
Old 12-18-2006, 12:05 PM   #3
Laker Netman
LQ Newbie
 
Registered: Dec 2006
Distribution: Fedora Core (4,5,6)
Posts: 4

Original Poster
Rep: Reputation: 0
Well, whadda ya know. DPMS still says enabled

I have now done an "xset -dpms", restarted X and will post the results shortly.

Thanks farslayer!

Code:
Keyboard Control:
  auto repeat:  off    key click percent:  0    LED mask:  00000000
  auto repeat delay:  250    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffdfffdfe5ef
                        ffffffffffffffff
                        ffffffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  4
Screen Saver:
  prefer blanking:  no    allow exposures:  yes
  timeout:  1810    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  unix/:7100
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 1200    Suspend: 1800    Off: 2400
  DPMS is Enabled
  Monitor is On
Font cache:
  Server does not have the FontCache Extension
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/lib/xorg/modules
  Log file:     /var/log/Xorg.0.log
 
Old 12-19-2006, 09:16 AM   #4
Laker Netman
LQ Newbie
 
Registered: Dec 2006
Distribution: Fedora Core (4,5,6)
Posts: 4

Original Poster
Rep: Reputation: 0
Smile

Success! I went back into xorg.conf, uncommented
Code:
Option "DPMS"
and changed it to
Code:
Option "DPMS" "off"
I left the PC on overnight and when I came in this morning the screen saver was still running

Compared to the misery I went through with the ATI card I installed previously this was a breeze.

Thanks again farslayer.

Laker
 
Old 12-19-2006, 07:03 PM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
No problem, glad I could help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fc6, Nvidia & Sceptre Lcd cj100570 Fedora 1 11-01-2006 03:12 PM
Nvidia cause LCD to turn to standby mode, VGA fine Half_Elf Linux - Hardware 4 12-29-2005 08:59 PM
My display goes to power saving mode even during games. A.K Mandriva 1 03-22-2005 10:40 AM
nVidia GeForce & LCD display problem Cazar Red Hat 5 01-30-2004 05:49 PM
LCD is REDDISH after resuming from power-saving mode stevenhasty Linux - Laptop and Netbook 2 11-07-2003 05:10 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration