LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-23-2007, 03:37 AM   #1
Darthwader
LQ Newbie
 
Registered: Aug 2007
Distribution: Fedora 7
Posts: 4

Rep: Reputation: 0
Question Lan card problem in linux due to driver upgradation in windows


I have a lan/ethernet card by Realtek Semiconductors ltd. I updated its drivers while working in windows and it worked fine but when I logged in Linux( fedora 7 to be exact), my ethernet won't work.I tried searching on google for the solution but didn't find any. Finally just on a hunch I rolled back the drivers by logging onto windows and when I logged in fedora again and it worked! I am not able to understand as to why would updating the drivers in windows will cause problems in the working of the lan card in linux? None of my friends who have been using linux for sometime now have been able to give a convincing answer. Also does this mean that some other hardware may give similar problem if updated in windows?
 
Old 08-23-2007, 04:27 AM   #2
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
Normally it has no impact .
But give it a try start windows
go to the device manager
check the energy control tab of your network card. (power management)
disable all checkboxes

try again in linux.
 
Old 08-23-2007, 09:05 PM   #3
Darthwader
LQ Newbie
 
Registered: Aug 2007
Distribution: Fedora 7
Posts: 4

Original Poster
Rep: Reputation: 0
I tried what I was told to do in the above reply but still it didn't work
I think I didn't mention the actual problem
The problem is that the network card is not picking up IP address, the hardware is being detected but it is not working
I am studying in a college and use the Lan provided by the college, does that have anything to do with it? I don't think so.
 
Old 08-24-2007, 06:33 AM   #4
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
so what is the output
of ifconfig ?
does it say that i got a link?
is there a dhcp server running (...Lan provided by the college)?
check with system-config-network if everything matches.
maybe delete the settings and save them
issue service network restart
then configure your card again with system-config-network
and restart the network again service network restart

check the route -n command to the if the default gateway is present.
 
Old 09-04-2007, 02:03 PM   #5
carnage85
LQ Newbie
 
Registered: Sep 2007
Posts: 1

Rep: Reputation: 0
Exclamation

i have a similar difficulty....
i assign a ip address then service network restart...
when i view ifconfig it shows something like
127.0.0.1 but not showing the ip adress i issued....
i have a silan90231 nic....and i have
windows 98 running as well....in the same system.
and its working fine.....what may be the problem....plzzzz suggest....
thank u........
 
Old 09-05-2007, 02:06 AM   #6
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
@carnage85

check
ifconfig -a

that command will listen you all devices also the once that are not in use.

127.0.0.1 is alright, this is your loopback interface, some service need it.

You should look for eth1 or eth0.

Which Distribution do you use?
How did you try to assign the IP Address ?

is the "driver" for the lan card loaded?
What shows
lspci
regarding Ethernet?

If silan = sis then
lsmod

should show a sis module loaded
 
  


Reply

Tags
lan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
driver for intex RTL 8139D lan card in zenwalk linux madhanblore Zenwalk 9 02-16-2007 02:10 AM
Linux Sound Card Driver Inferior to Windows Driver? dudeman41465 Linux - Hardware 2 10-04-2006 10:01 AM
keymap problem due to *ati* driver. bruse Mandriva 2 08-25-2006 09:12 AM
download and install IBM R51e LAN card driver for linux bdwahid Linux - Laptop and Netbook 1 06-10-2006 09:57 AM
Lan Problem from Windows to Linux marcoratto Linux - Networking 1 06-03-2004 10:35 AM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration