LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 10-19-2007, 12:42 AM   #1
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Rep: Reputation: 15
KMix problem with Realtek ALC883 sound


I just installed openSUSE 10.3 and I'm having this quirky KMix problem. The "PC Speaker" control doesn't control the sound output; i.e I can move the slider up or down, or click mute but it doesn't change the sound output. The controls that work are the "Front" and "PCM" sliders. Oh, I also tried plugging the jack into the different female slots from the MB. Any thoughts on how I can get the "PC Speaker" slider to work.

Below are some pc info:

lspci:
Code:
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6100 nForce 430 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
modprobe | grep snd:
Code:
snd_pcm_oss            67456  0
snd_mixer_oss          34176  1 snd_pcm_oss
snd_seq                74992  0
snd_seq_device         25620  1 snd_seq
snd_hda_intel         368804  1
snd_pcm               108680  2 snd_pcm_oss,snd_hda_intel
snd_timer              42632  2 snd_seq,snd_pcm
snd                    84984  9 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer
soundcore              25360  1 snd
snd_page_alloc         28048  2 snd_hda_intel,snd_pcm
Regards!
 
Old 10-19-2007, 07:56 AM   #2
kafnir
Member
 
Registered: Oct 2002
Location: USA
Distribution: Fedora and Ubuntu
Posts: 137

Rep: Reputation: 15
I have the same problem

I have the same type of sound card in my laptop, but I have no luck either with opensuse, or ubuntu. I even download and install the alsa-driver, and nothing happened. I am still trying.
 
Old 10-19-2007, 10:48 AM   #3
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
So, your having the same problem I'm having then? It might be that they (alsa) do not support the NVidia chipset yet. Can anybody else comment on this?

Last edited by ccin1492; 10-19-2007 at 10:48 AM. Reason: spelling
 
Old 10-19-2007, 11:29 AM   #4
kafnir
Member
 
Registered: Oct 2002
Location: USA
Distribution: Fedora and Ubuntu
Posts: 137

Rep: Reputation: 15
I get my sound card working on OpenSuSe

I get this howto from ubuntuforums
I have a toshiba satellite A215 -7422

this is the howto:

this is a link to ubuntu forums
http://ubuntuforums.org/showthread.php?p=3524787

Install dependencies:
Code:

sudo apt-get install libncurses5-dev build-essential ncurses-dev gettext linux-headers-`uname -r`

Download the files needed (this is version 1.0.15rc2):
ftp://ftp.alsa-project.org/pub/drive....15rc2.tar.bz2
ftp://ftp.alsa-project.org/pub/lib/a....15rc2.tar.bz2
ftp://ftp.alsa-project.org/pub/utils....15rc1.tar.bz2

I save mine on separate home-partition first (in case of reinstall) to a directory called ~/ALSA/1.0.15rc2 and then I do the following:

Code:

sudo mkdir -p /usr/src/alsa
cd /usr/src/alsa
sudo cp ~/ALSA/1.0.15rc2/* .
sudo tar xjf alsa-driver-1.0.15rc2.tar.bz2
sudo tar xjf alsa-lib-1.0.15rc2.tar.bz2
sudo tar xjf alsa-utils-1.0.15rc1.tar.bz2

Then compile (I'm not sure if the --with-oss=yes is needed):
Code:

cd alsa-driver-1.0.15rc2/
sudo ./configure --with-cards=hda-intel --with-oss=yes
sudo make
sudo make install
cd ../alsa-lib-1.0.15rc2/
sudo ./configure
sudo make
sudo make install
cd ../alsa-utils-1.0.15rc1/
sudo ./configure
sudo make
sudo make install

Then edit alsa-base in /etc/modprobe.d:
Code:

sudo vim /etc/modprobe.d/alsa-base

And add the following line at the end:

Code:

options snd-hda-intel model=toshiba

Reboot.


Fantastic my laptop Acer Travelmate 5720 work perfectly with your suggets.

PS: for Acer users, before operate step by step, read the alsa documentation (/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz) and you can find
the supported options for your model.
I replaced

Code:

options snd-hda-intel model=toshiba

with

Code:

options snd-hda-intel model=acer


if you have an HP or dell etc. replace toshiba with your own model
have fun
 
Old 10-19-2007, 12:08 PM   #5
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
kafnir, you never said whether your issue was the same as mine. Can you give a brief comment on your issue?
 
Old 10-21-2007, 12:12 AM   #6
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
Ok, I've tried loading snd_hda_intel with "6stack-dig" option but the "PC Slider" is still not active. This might be an ALSA bug, but before I submit a case, does anyone have any other thoughts?
 
Old 10-26-2007, 06:59 PM   #7
beccon
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
Quote:
Fantastic my laptop Acer Travelmate 5720 work perfectly with your suggets.
So you can use the headphone plug and the microphone too? That'd be great.

Quote:
PS: for Acer users, before operate step by step, read the alsa documentation (/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz) and you can find
the supported options for your model.
I replaced

Code:

options snd-hda-intel model=toshiba

with

Code:

options snd-hda-intel model=acer
Well, I did exactly this - no avail. Distri is Gutsy Gibbon Kubuntu.
Though I can hear sound - unless I suspend to something - I cannot use the microphone nor the headphone plug.

Where did you put the option statement to? I did it in /etc/modprobe.p/alsa-base.

What's wrong? Thank you for help in advance.

Conrad
 
Old 10-27-2007, 10:00 AM   #8
mvil
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
Wink Right click on the speaker

I had the same problem. I'm using KDE and my soundcard chip is a Realtek ALC 883. When clicking on the "speaker" icon on the panel (kmix), I was initially unable to control the sound volume. In fact the solution is very simple: right click on that "speaker" icon and you'll see the word "select" followed by a sound channel name. In my case the channel name was "headphone", so I clicked on the "select" thing and choose "Master Channel". Now it works perfectly.
 
Old 10-27-2007, 12:50 PM   #9
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
Yeah, I discovered that as well. Turns out my master channel is "Front". So it seems my sound is working fine.
 
Old 11-08-2007, 11:12 PM   #10
mobrien_12
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
To get recording working, I had to use the 6stack-dig option, then set input source to line (kmix), then set input capture levels to high (kmix), then set audacity input to ALSA: default.
 
Old 12-09-2007, 08:10 PM   #11
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
How can I solve this problem? I compiled alsa-driver, alsa-utils, and alsa-libs. I have the same sound card, but not on a laptop. I have it onboard a desktop motherboard.
 
Old 12-10-2007, 10:43 AM   #12
kafnir
Member
 
Registered: Oct 2002
Location: USA
Distribution: Fedora and Ubuntu
Posts: 137

Rep: Reputation: 15
make sure the the volume is not disable in kmix

if you follow the installation process to install aslsa-driver, alsa-lib, and alsa-util. then blacklist the module in modprobe as this.

step 1: install kernel-devel, kernel-headers, ncurses, or kernel-source
step 2: driver installation:
cd /usr/src/ and create a new dir with mkdir alsa

copy the drivers to /usr/src/alsa

tar xvjf alsa-driver-xxx.bz2
./configure --with-cards=hda-intel --with-oss=yes
make
make install

tar xvjf alsa-libs-xxx.bz2
./configure
make
make install

tar xvjf alsa-util-xxx.bz2
./configure
make
make install

step 3: gedit /etc/modprobe.d/alsa-base

enter this in the blank page

options snd-hda-intel model=toshiba

example: model is the model of your sound card or the computer manufacture.
model=hp or model=dell, model=sony

save the file and reboot your computer

the sound card should be working by now.if it not, open alsamixgui or kmix to uncheck your volume, cdrom etc

good luck
 
Old 12-11-2007, 05:20 PM   #13
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
Quote:
Originally Posted by kafnir View Post
if you follow the installation process to install aslsa-driver, alsa-lib, and alsa-util. then blacklist the module in modprobe as this.

step 1: install kernel-devel, kernel-headers, ncurses, or kernel-source
step 2: driver installation:
cd /usr/src/ and create a new dir with mkdir alsa

copy the drivers to /usr/src/alsa

tar xvjf alsa-driver-xxx.bz2
./configure --with-cards=hda-intel --with-oss=yes
make
make install

tar xvjf alsa-libs-xxx.bz2
./configure
make
make install

tar xvjf alsa-util-xxx.bz2
./configure
make
make install

step 3: gedit /etc/modprobe.d/alsa-base

enter this in the blank page

options snd-hda-intel model=toshiba

example: model is the model of your sound card or the computer manufacture.
model=hp or model=dell, model=sony

save the file and reboot your computer

the sound card should be working by now.if it not, open alsamixgui or kmix to uncheck your volume, cdrom etc

good luck
I've done all of this except the add "options snd-hda-intel model=toshiba " to /etc/modprobe.d/alsa-base part. Is this problem caused by the alsa driver not knowing what model of sound card is being used? I checked and saw that the correct alsa module was loaded, snd-hda-intel. How can I know what model to use? My motherboard is an ECS, not Sony or Toshiba. My computer is not a brand such as Dell, Toshiba, HP, etc. I built it from parts. What is the cause of this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone does not work with Realtek ALC883 HDA fakie_flip Linux - Hardware 47 03-26-2012 08:25 PM
Configuring Realtek ALC883 onboard audio? cdrom600 Linux - Hardware 5 03-12-2010 08:10 AM
realtek ac'97 onboard sound 5.1 problem vlatko Suse/Novell 6 05-07-2006 11:34 AM
Problem with sound mixer (KMix) mad_ady Linux - Software 0 11-05-2003 01:24 PM
Problem with IC7-G on sound realtek ALC650 sjhannan Linux - Hardware 1 10-26-2003 02:41 PM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration