LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-16-2007, 03:06 AM   #1
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Rep: Reputation: 30
Keyboard strange behavior


Hey there guys.

i write to you because something strange happened to my keyboard. The thing is that i can no longer press and hold a key so that i can get as many characters as i want until i drop the key. For instance, if i mistype something, i cannot press and hold backspace until i erase everything i typed wrong; or, i cannot press any of the arrow keys so that i can move around freely until i get to where i want to be.

I have my thoughts about it and i can only guess that something changed it the xorg.conf file, i don't know where else i should be looking for the problem.

If you can throw a little light or the fix for that matter, i would greatly appreciate it.

Thanks in advance for the aid.

Last edited by trebek; 09-16-2007 at 02:13 PM.
 
Old 09-16-2007, 09:30 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
Probably something like

Option "AutoRepeat" "500 30"

in Keyboard section should give reasonable behavior.
 
Old 09-16-2007, 02:32 PM   #3
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
I just added that part to the keyboard section and nothing happened. I restarted X of course to make sure the changes took effect. But nothing happened.

I don't remember exactly how my initial xorg.conf file looked specifically for the keyboard sections, since it has always worked with the default settings. I just usually have to tweak the part for mouse, touchpad and video card part.

Any other suggestions would be greatly appreciated.
 
Old 09-16-2007, 04:01 PM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
What does 'xset q' say about repeat? Are you sure your xorg.conf has only one keyboard section?
 
Old 09-16-2007, 05:43 PM   #5
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
Output of xset q

Here's the output of the command you provided over there. Hope it helps you out.

Code:
Keyboard Control:
  auto repeat:  off    key click percent:  42    LED mask:  00000000
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fa9fffffffdffdff
                        ffffffffffffffff
                        ffffffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  51/10    threshold:  20
Screen Saver:
  prefer blanking:  yes    allow exposures:  no
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,/usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,/home/punisher/.fonts
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 1200    Suspend: 1800    Off: 2400
  DPMS is Enabled
  Monitor is On
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/lib/xorg/modules
  Log file:     /var/log/Xorg.0.log
The part for 'auto repeat: off' maybe wrong, i am guessing here.
 
Old 09-16-2007, 10:05 PM   #6
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
So, 'xset r on' switches autorepeat on? Maybe some program (window manager?) executes its own analog of 'xset r off'.. Is the problem the same in IceWM?
 
Old 09-17-2007, 02:00 AM   #7
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
I tried that xset r on and it got fixed, i hope that it stays this way after a reboot.

Thanks too much for the help, i'll shout out if something else comes up.

Last edited by trebek; 09-17-2007 at 02:02 AM.
 
Old 09-17-2007, 01:31 PM   #8
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
Such things usually do not stay OK after reboot... So the question about IceWM is not discarded.
 
Old 09-19-2007, 02:26 AM   #9
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
Hey, thanks for the help. I just downloaded kubuntu 7.04 and installed it, so i guess i will be ok for a while.

Either way, i learned a lot, LQ rules.

Thanks man.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange keyboard behavior VAS Arch 3 11-11-2006 12:07 PM
Very Strange Behavior raysr Mandriva 4 08-31-2004 02:06 PM
Strange Behavior andrewb758 Linux - Hardware 5 08-31-2003 02:42 PM
strange behavior abhijit Linux - General 3 07-09-2003 11:25 PM
Strange DHCPcd behavior padukes Linux - Networking 0 03-17-2002 09:55 AM


All times are GMT -5. The time now is 01:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration