LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Keyboard randomly fails when X starts (http://www.linuxquestions.org/questions/linux-hardware-18/keyboard-randomly-fails-when-x-starts-746882/)

reg.doug 08-11-2009 09:26 PM

Keyboard randomly fails when X starts
 
I have a Dell laptop with TinyMeLinux 2008.1 installed.

When I boot normally, the keyboard is totally unresponsive, rendering login impossible. However, when I boot in "failsafe" (single-user) mode and start X with "init 5" it works.

Even then, the keyboard will sometimes randomly fail when I start an application. In this case, logging out fixes the problem and I can log in and work normally. I have not ever had the keyboard fail after re-login.

There is a similar thread in LQ, but it did not fix my problem.

Thanks in advance

Reggie
dominic+k+92 at inbox dot com (remove +; replace at and dot)

Laurens73 08-12-2009 08:21 AM

Some distros don't create a configuration in xorg.conf at install doing an auto detect at startup today. Maybe this isn't the right configuration for your system. If you lookup your /etc/X11/xorg.conf file, can you find something like this: ?

Code:

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

and further on in the same file:

Code:

Section "InputDevice"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"        "xorg"
    Option        "XkbModel"        "pc105"
    Option        "XkbLayout"        "us"
    Option        "XkbVariant"      "alt-intl"
    Option        "XkbOptions"      "lv3:ralt_switch"
EndSection


reg.doug 08-12-2009 03:44 PM

My /etc/X11/xorg.conf was a bit different.

First, the ServerLayout was at the end of the file and it called the layout "Layout1"

Secondly, my Keyboard did not have options "CoreKeyboard" or "XkbRules"

I changed "Layout1" to "Layout0" and moved ServerLayout to the top of the file as well as adding "CoreKeyboard" and "XkbRules" to the keyboard section

Normal boot still doesn't work, but as ever before "init 5" works from single user mode. I don't understand why a normal boot should be any different that one that loads X from single user mode.

Thanks for your help, unfortunately I still have a problem.

Do you think that it could be due to dbus-x11, like it is attributed to in this post? What is dbus-x11?

Further advice would be very welcome.

Laurens73 08-13-2009 12:07 PM

dbus-x11 communicates between the devices and the processes running on the system. If it doesn't do what it's meant for all your external devices like your keyboard, mouse, etc. won't work anymore. Perhaps trying to re-install the previous version or a newer version would suffice. Try taking a look into the /var/cache/apt/archives folder and search for a version of dbus-x11 as root:

Code:

cd /var/cache/apt/archives/
ls dbus-x11*

For example in my cache dir are the following files visible:

Code:

dbus-x11_1.2.14-3_i386.deb  dbus-x11_1.2.16-2_i386.deb
dbus-x11_1.2.1-5_i386.deb

In my case the dbus-x11_1.2.16-2 version is the latest and dbus-x11_1.2.14-3 would be the first candidate to try:

Code:

dpkg -i dbus-x11_1.2.14-3_i386.deb
In your case the second version in your row of course.


If this doesn't solve the problem, the part about HAL managing the input devices after an upgrade could also help. Remember to re-install the latest version again if it didn't work :)


All times are GMT -5. The time now is 05:46 AM.