LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Keyboard inoperative when booting to Ubuntu CD or attempting to install Ubuntu (http://www.linuxquestions.org/questions/linux-hardware-18/keyboard-inoperative-when-booting-to-ubuntu-cd-or-attempting-to-install-ubuntu-692940/)

jdruin 12-25-2008 02:04 PM

Keyboard inoperative when booting to Ubuntu CD or attempting to install Ubuntu
 
Hello. I have a Toshiba l355d-s2578 laptop with Vista Home pre-installed. I want to install Ubuntu (latest edition). I created the Ubuntu install from an ISO downloaded at the standard Ubuntu download page. I downloaded the 32 bit version.

I set the laptop bios to boot from CD first. When I inserted the Ubuntu disk and rebooted, everything starts up well. When I got to the "pick your keyboard layout" area of the load process, I noticed the keyboard did not work when typing into the "try your keyboard" area but did not think much of it. Once the OS completely booted to the desktop, I attempted to use the keyboard in several settings (browser, help program,etc.). It would not work. I tried to use the keyboard settings wizard under the "system" menu but this did not offer any settings that made a difference.

I suppose this is something really simple but I can not figure it out. Can anyone help me get the keyboard working with Ubuntu? (It works perfect in Vista, so its not the actual hardware). Obviously not having a keyboard would be a deal breaker and I will be stuck with Windows

stress_junkie 12-25-2008 09:00 PM

Try using Ubuntu v8.04 rather than v8.10.

bman22 12-25-2008 09:04 PM

make sure usb emulation is on in your bios. This makes the usb devices look like ps2 devices when they are not natively supported. this usualy does the trick

stress_junkie 12-26-2008 09:46 AM

Quote:

Originally Posted by bman22 (Post 3387258)
make sure usb emulation is on in your bios. This makes the usb devices look like ps2 devices when they are not natively supported. this usualy does the trick

Also, in another thread someone said that legacy USB support should be turned off in the motherboard BIOS. That was for a different problem but it might apply here.

GlenDobbs 12-26-2008 10:11 AM

Quote:

Originally Posted by jdruin (Post 3387026)
Hello. I have a Toshiba l355d-s2578 laptop with Vista Home pre-installed. I want to install Ubuntu (latest edition). I created the Ubuntu install from an ISO downloaded at the standard Ubuntu download page. I downloaded the 32 bit version.

I set the laptop bios to boot from CD first. When I inserted the Ubuntu disk and rebooted, everything starts up well. When I got to the "pick your keyboard layout" area of the load process, I noticed the keyboard did not work when typing into the "try your keyboard" area but did not think much of it. Once the OS completely booted to the desktop, I attempted to use the keyboard in several settings (browser, help program,etc.). It would not work. I tried to use the keyboard settings wizard under the "system" menu but this did not offer any settings that made a difference.

I suppose this is something really simple but I can not figure it out. Can anyone help me get the keyboard working with Ubuntu? (It works perfect in Vista, so its not the actual hardware). Obviously not having a keyboard would be a deal breaker and I will be stuck with Windows

Possibly the easiest way to enable the KB is to ignore the select KB layout and let it default to the American layout. Then when Ubuntu is installed try the various keys in a terminal to see which one is which and either remember the position or make a cheat sheet for later.

jdruin 12-26-2008 07:32 PM

Thanks all. I basiclly just did what GlenDobbs suggested and let the Ubuntu CD load without touching anything. That worked increadibly. I am concerned that I dont know why this happened, but happy that the keyboard works now. Hopefully I can figure out a way to shrink the windows partition since the bult in partition manager in Windows is useless.


All times are GMT -5. The time now is 09:05 PM.