LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-10-2005, 05:55 AM   #1
Andrejchy
LQ Newbie
 
Registered: Jul 2005
Posts: 3

Rep: Reputation: 0
Angry keyboard & mouse problem with x-server


I have just installed Debian3.1r0 from floppy using network install. While I am in console keyboard is working well, but when I start x-windows, keyboard and mouse are not working anymore, so I have to hard-reset machine or I can login remotely and work remoteli in console. I believe, that XFree86 config file is just fine, I have reconfigured it....but no success. Can someone please help me with this fucking problem. I am sick and tired of it!

btw:Keyboard and mouse stop working if I just start xdm.
 
Old 07-10-2005, 11:45 PM   #2
Michael Johnson
Member
 
Registered: Jul 2005
Location: Wagga Wagga, Australia
Posts: 262

Rep: Reputation: 30
Please show us the config file and let us know the type of mouse and keyboard and the required language settings. It will most probably be in there somewhere.
 
Old 07-11-2005, 12:12 PM   #3
Andrejchy
LQ Newbie
 
Registered: Jul 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Well, I don't believe, that the problem is here, I think it's somevre else, but not sure where.

Keyboard: BTC 9000A
Mouse: PS/2 LG Optical
Required language settings: Slovenian (si)

/etc/X11/XF86Config-4:
Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
# Load "GLcore"
# Load "bitmap"
# Load "dbe"
# Load "ddc"
# Load "dri"
# Load "extmod"
Load "freetype"
# Load "glx"
# Load "int10"
# Load "record"
# Load "speedo"
# Load "type1"
# Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "si"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
#Section "InputDevice"
# Identifier "Generic Mouse"
# Driver "mouse"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
# Option "Emulate3Buttons" "true"
# Option "ZAxisMapping" "4 5"
#EndSection

Section "Device"
Identifier "Geforce4 MX 440"
# Driver "nv"
Driver "vesa"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "IDEK Iiyama"
HorizSync 30-60
VertRefresh 50-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Geforce4 MX 440"
Monitor "IDEK Iiyama"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
# InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Last few lines of startx script:
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Jul 11 17:10:08 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Could not init font path element unix/:7100, removing from list!
Could not init font path element /usr/lib/X11/fonts/Speedo, removing from list!
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse & keyboard problem 666 Ubuntu 4 03-17-2007 05:21 AM
keyboard & mouse problem with x-server Andrejchy Debian 1 07-10-2005 06:37 AM
Mouse & Keyboard problem after installation. M2H Linux - Hardware 3 02-05-2005 08:00 AM
USBMGR: problem with usb-keyboard&-mouse pablovschby Linux - Hardware 1 01-05-2004 05:57 AM
Wine, Keyboard & Mouse problem ! Baran Linux - Software 1 10-23-2003 11:25 AM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration