LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 10-14-2012, 10:00 AM   #1
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 148

Rep: Reputation: 3
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)


I've been running Slackware 13.37 for about a year on my laptop. It's a very stable OS and I really like it. This morning, I woke up to a power outage and my laptop which had been left on the previous night was dead. I attempted to boot and received a Kernel panic message:

Code:
 Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)
I have loaded up the Slackware DVD to try and use as a recovery console, but it's getting me nowhere. I've tried running e2fsck and I get an error message about a bad superblock. I've tried running something along the lines of

Code:
 e2fsck -b 8193 /dev/sda1
Which returns a long message about how the superblock cannot be read or does not describe a correct ext2 filesystem.

I tried to see what fdisk had to say about /dev/sda1 by running

Code:
 fdisk /dev/sda1
Which returned:

Code:
 fdisk.bin: unable to read /dev/sda1: Inappropriate ioctl for device
Code:
fsck /dev/sda1
Returns:

Code:
/sbin/e2fsck: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda1
Could this be a zero-length partition?
Really hoping I don't have to re-install.

Edit: Just out of curiosity I ran the "setup" utility and it told me that I had no linux partitions on my machine and prompted me to create one. I ran the partition table and /dev/sda1 did not show up at all. After running "cfdisk /dev/sda" it shows a 160GB partition of "Free Space"

Last edited by flyinggeorge; 10-14-2012 at 10:22 AM.
 
Old 10-14-2012, 01:55 PM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 661

Rep: Reputation: 71
Conclusion? Did you end up reinstalling everything?
 
Old 10-14-2012, 01:59 PM   #3
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 148

Original Poster
Rep: Reputation: 3
Okay, I have made some progress. But now I have a new issue.

From the recovery console (Slackware DVD) I ran "cfdisk" and changed the type of file system from "Free space" to "Linux" on /dev/sda. Cfdisk calls this partition /dev/sda2 now. I am able to boot my laptop from the Slackware DVD by running the workaround suggested at boot time:

Code:
boot: hugesmp.s root=/dev/sda2 rdinit=rw
From there, I can use my system like normal. But I want to be able to boot without this, so I updated lilo to use /dev/sda2 instead of /dev/sda1 as the root to boot from. This has mixed results. I can boot, but only to a read-only filesystem.

The error I am getting now is:

Code:
Testing root filesystem status: read-only filesystem
Checking root filesystem:
fsck from util-linux 2.19
/sbin/e2fsck: No such file or directory while tyring to open /dev/sda1
Possibly non-existene device?
What do I need to change to get the system to check /dev/sda2 instead of /dev/sda1? Any ideas would be appreciated.
 
Old 10-14-2012, 02:18 PM   #4
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 661

Rep: Reputation: 71
I honestly have no clue how you ended up with that kind of setup and am not sure exactly where your error message shows up and don't know anything about Lilo (I use Grub) but perhaps you have...
1) in the bootloader paramers somewhere sda1 mentioned (e.g. "root=/dev/sda1))?
2) in "/etc/fstab" the old entry "/dev/sda1 / <yourfs> <mount options> <other1> <other2>"?
 
1 members found this post helpful.
Old 10-14-2012, 02:26 PM   #5
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 148

Original Poster
Rep: Reputation: 3
Oh my goodness, thank you! It seems so obvious now that you pointed it out! But that did the trick. I would rather have my root on /dev/sda1, but I don't have to re-install and I've spent countless hours getting this installation right where I want it to be, so I'll take it. Anyway, thanks a lot; I appreciate it!
 
Old 10-14-2012, 03:02 PM   #6
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 661

Rep: Reputation: 71
Hehe... welcome
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic not syncing vfs unable to mount root fs on unknown block(0,0) k84834 Linux - Kernel 1 09-04-2012 10:37 AM
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) OR13 Linux - Kernel 18 01-12-2008 09:23 AM
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block bijit1709 Slackware 11 06-08-2007 04:38 PM
Kernel Panic!!! -Not Syncing VFS:Unable to mount root FS on unknown - block (0,0) scarabs Linux - Software 4 04-16-2006 04:16 PM
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2) Volgin Linux - Software 1 12-11-2005 07:46 PM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration