LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-08-2007, 04:47 PM   #1
marvelade
LQ Newbie
 
Registered: Dec 2006
Location: Belgium
Distribution: Mac OS X; Ubuntu 8.04 in a VM
Posts: 27

Rep: Reputation: 16
kernel panic - not syncing : IO-APIC


Hi All,

When I boot Linux I get the following error:

[17179570.272000] Kernel panic - not syncing : IO-APIC + timer doesn't work. Boot with apic=debug and send a report. Then try booting with the 'noapic' option.

How do I boot with the 'noapic' option?

I found a similar type problem on this forum here:
http://www.linuxquestions.org/questi...d.php?t=499929
Which I thought would help me because I have a similar Mobo M2NPV-Type from ASUS.

This post, however, doesn't tell me how to "boot with an option" (I'm a newbie as you might have guessed)

greetz,
Marvelade
 
Old 04-08-2007, 06:56 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
If you can get into and edit the bootloader configuration, then you would have a line near the start of the bootloader like the following:
append="noapic"

And that will make it happen every boot.
Meanwhile, to simply get the machine up and running, you need a boot: prompt, such as when you first arrive at the boot menu after turning on the machine. At the boot prompt you would enter your kernel name, followed by 'noapic', like: "boot: vmLinuz root=/dev/hda1 ro noapic" or "vmlinuz noapic" or similar. Check the manual for LILO or documentation for GRUB, depending which you use.
If you can find no way to get at a boot prompt, you may need to stick in the install CD, and use that to boot your system, with a command very much like the one above.
Change /dev/hda1 to match your own installation location, and adjust the name of the kernel's bootable image to whatever yours is (on Ubuntu it is sometimes 'casper' maybe, but I am not sure; it could be called something like 'linux-2.6.14')

Last edited by GrapefruiTgirl; 04-08-2007 at 07:00 PM.
 
Old 04-09-2007, 05:40 PM   #3
marvelade
LQ Newbie
 
Registered: Dec 2006
Location: Belgium
Distribution: Mac OS X; Ubuntu 8.04 in a VM
Posts: 27

Original Poster
Rep: Reputation: 16
Lightbulb

Quote:
Originally Posted by GrapefruiTgirl
If you can get into and edit the bootloader configuration, then you would have a line near the start of the bootloader like the following:
append="noapic"

And that will make it happen every boot.
I have GRUB set up to show a menu to choose between
- Kubuntu Linux 6.10 (hdb) which boots into KDE (at least: up till yesterday :s now I just get the error)
- Kubuntu Linux in safe mode (hdb) which boots to a "root@xxxx~#" prompt
- and last/least: Windows XP (hda)

I guess I could boot to a command prompt and use an editor to add the line 'append="noapic"' to the grub.conf file (althougug I think it's called differently... something with "list" or "lst"...). I guess I add it to the linux part of that file or do I put it at the very end or beginning??

Quote:
Originally Posted by GrapefruiTgirl
Meanwhile, to simply get the machine up and running, you need a boot: prompt, such as when you first arrive at the boot menu after turning on the machine.
I do not get a "boot:" prompt.

Best regards and big thanks for your help so far.
Marvelade
 
Old 04-09-2007, 05:44 PM   #4
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Code:
To pass the option noapic, you press 'e', in GRUB, on the boot option you want to edit. Then, press 'e' again on the line that start with kernel. Append "noapic" (without quotes) at the end of the line. Press Enter, then 'b'. It should boot fine.

To make the change permanent, you will need to edit to /boot/grub/menu.lst file. Here how to do that:

$ gksudo gedit /boot/grub/menu.lst

Now, find those lines:
## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

Add "noapic" to defoptions (do not uncomment it):
# defoptions=quiet splash noapic

Save and close.

Finally, generate you new menu.lst:
$ sudo update-grub
As quoted from:
https://answers.launchpad.net/ubuntu/+ticket/1808
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic - Not Syncing CamelWide Linux - Newbie 4 06-10-2009 07:31 AM
Kernel Panic - not syncing (2.6.9-22) Sayoji Linux - Kernel 5 11-29-2006 12:56 AM
Kernel Panic (!) - not syncing Andknig Linux - General 2 09-14-2006 01:15 PM
Kernel panic not syncing alfredo Linux - Newbie 6 02-27-2006 12:12 PM
Kernel panic not syncing n6rob Linux - General 3 02-15-2006 07:13 AM


All times are GMT -5. The time now is 01:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration